8.х Обработка как фоновое задание

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alex-79, 20 авг 2015.

  1. TopicStarter Overlay
    alex-79
    Offline

    alex-79 Опытный в 1С

    Регистрация:
    21 сен 2006
    Сообщения:
    643
    Симпатии:
    1
    Баллы:
    29
    Привет всем! В УТ 11 ( у меня релиз11.1.10.173) есть возможность запустить дополнительную обработку по расписанию. В модуле объекта прописал процедуры, но процедура ОбработкаКоманды() не хочет выполняться, хотя фоновое задание стартует и выполняется. Хотя не понятно, что оно выполняет.

    Код:
    Функция СведенияОВнешнейОбработке() Экспорт
        реквизитыТабличнойЧасти = Метаданные.Справочники.ДополнительныеОтчетыИОбработки.ТабличныеЧасти.Команды.Реквизиты;
        таблицаКоманд = Новый ТаблицаЗначений;
        таблицаКоманд.Колонки.Добавить("Представление", РеквизитыТабличнойЧасти.Представление.Тип);
        таблицаКоманд.Колонки.Добавить("Идентификатор", РеквизитыТабличнойЧасти.Идентификатор.Тип);
        таблицаКоманд.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
        таблицаКоманд.Колонки.Добавить("ПоказыватьОповещение", РеквизитыТабличнойЧасти.ПоказыватьОповещение.Тип);
        таблицаКоманд.Колонки.Добавить("Модификатор", РеквизитыТабличнойЧасти.Модификатор.Тип);
        таблицаКоманд.Колонки.Добавить("Скрыть", РеквизитыТабличнойЧасти.Скрыть.Тип);
      
        параметрыРегистрации = Новый Структура;
        параметрыРегистрации.Вставить("Вид", "ДополнительнаяОбработка");
        параметрыРегистрации.Вставить("Версия", "1.0");
        параметрыРегистрации.Вставить("Назначение", Новый Массив);
        параметрыРегистрации.Вставить("Наименование", "Отправка уведомлений продления договоров");
        параметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
        параметрыРегистрации.Вставить("Информация", "Отправка уведомлений продления договоров");
        параметрыРегистрации.Вставить("ВерсияБСП", "1.2.1.4");
        параметрыРегистрации.Вставить("Команды", таблицаКоманд);
        параметрыРегистрации.Вставить("Разрешения", Новый Массив);
      
        команда = параметрыРегистрации.Команды.Добавить();
        команда.Представление = "Отправка уведомлений продления договоров (ручной режим)";
        команда.Идентификатор = КомандаВыполнитьФорма;
        команда.Использование = "ОткрытиеФормы";
        команда.ПоказыватьОповещение = Истина;
      
        команда = параметрыРегистрации.Команды.Добавить();
        команда.Представление = "Отправка уведомлений продления договоров (автоматический режим)";
        команда.Идентификатор = КомандаВыполнитьАвто;
        команда.Использование = "ВызовСерверногоМетода";
        команда.ПоказыватьОповещение = Истина;
      
        Возврат параметрыРегистрации;
    КонецФункции
    
    Процедура ОбработкаКоманды(ИдентификаторКоманды, ПараметрыВыполненияКоманды) Экспорт
        ЗаписатьЛог("начало выполнения обработки");  
        Если ИдентификаторКоманды = КомандаВыполнитьАвто Тогда
            ВосстановитьНастройки();
            ВыполнитьОбработку(Истина);
        КонецЕсли;
    КонецПроцедуры
    
    
    Уже два дня бьюсь и не пойму что не так

Поделиться этой страницей