8.х Обработка "Групповой ввод документов"

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alex-terek, 30 май 2014.

  1. TopicStarter Overlay
    alex-terek
    Offline

    alex-terek

    Регистрация:
    30 май 2014
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день... очень нужна помощь.
    Есть обработка "Групповой ввод документов"

    1) Форма обработки заполняется все имеющимися документами "Заказ покупателя" за выбранный период.

    2) Создаются и записываются новые документы на указанную дату.


    Необходимо чтобы заполнялись документы только по определенным контрагентам. Все они находятся в отдельной группе.
    Не могу сообразить как...

    Код:
    Процедура ОсновныеДействияФормыЗаполнить(Кнопка)
    Если Проверка() = 1 Тогда
    Возврат;
    КонецЕсли;
    Режим = РежимДиалогаВопрос.ДаНет;
    Если ДокументыДляВыбора.Количество() > 0 Тогда
    
    Ответ = Вопрос("Таблица документов будет очищена. Продолжить?", Режим);
    Если Ответ = КодВозвратаДиалога.Нет Тогда
    Возврат;
    Иначе
    ДокументыДляВыбора.Очистить();
    КонецЕсли;
    КонецЕсли;
    
    Выборка = Документы.ЗаказПокупателя.Выбрать(НачПериода, КонПериода);
    Пока Выборка.Следующий() Цикл
    Если (Выборка.ПометкаУдаления = Истина)Тогда
    Продолжить;
    КонецЕсли;
    НовСтрока = ДокументыДляВыбора.Добавить();
    НовСтрока.Документ = Выборка.Ссылка;
    НовСтрока.Контрагент = Выборка.Контрагент;
    НовСтрока.ДоговорКонтрагента = Выборка.ДоговорКонтрагента;
    НовСтрока.СуммаПоДокументу = Выборка.СуммаДокумента;
    КонецЦикла;
    КонецПроцедуры
    Последнее редактирование модератором: 2 июн 2014
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    открывайте Синтаксис-помошник и читайте про метод Выбрать, конкретно про параметр
    и дорабатывайте свой код
  3. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.987
    Симпатии:
    398
    Баллы:
    104
    Лично я в подобных случаях использую запросы и только запросы. В запросе наложите нужные условия. И все. Вопрос 1-2 минут.


    Отправлено из моего iPhone используя Tapatalk

Поделиться этой страницей