8.х Обработка документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Nega, 31 мар 2009.

  1. TopicStarter Overlay
    Nega
    Offline

    Nega

    Регистрация:
    24 июл 2008
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Всем привет! У меня маленькая проблемка), нужно обработкой пробежаться по документам и реквизит табличной части с типом Число умножить например на 12. Выдает ошибку "Преобразование значения к типу Число не может быть выполнено"

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    Док=Документы.ВводНачальныхОстатковОС.Выбрать();
    Пока Док.Следующий() Цикл
    А=Док.ОС;
    Для Каждого СрокПолезногоИспользованияБУ Из А Цикл
    С=СрокПолезногоИспользованияБУ;
    С=С*12;
    КонецЦикла
    КонецЦикла
    КонецПроцедуры

    :unsure:
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    СрокПолезногоИспользованияБУ - не заполнено значение и это не будет числом.
  3. vitaly_mnpz
    Offline

    vitaly_mnpz Опытный в 1С

    Регистрация:
    15 фев 2009
    Сообщения:
    267
    Симпатии:
    0
    Баллы:
    26
    В этом чудесном коде "СрокПолезногоИспользованияБУ" - это не число, а строка табличной части

    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    Выборка =Документы.ВводНачальныхОстатковОС.Выбрать(); 
    Пока Выборка .Следующий() Цикл
    Объект = Выборка.Ссылка.ПолучитьОбъект();
    
    ТабличнаяЧасть = Объект.ОС;
    Для Каждого СтрокаТабличнойЧасти Из ТабличнаяЧасть Цикл
    НовыйСрокИспользования = СтрокаТабличнойЧасти.СрокПолезногоИспользованияБУ*12;
    СтрокаТабличнойЧасти.СрокПолезногоИспользованияБУ = НовыйСрокИспользования;
    КонецЦикла;
    
    Объект.Записать(РежимЗаписиДокумента.Проведение);
    
    КонецЦикла;
    КонецПроцедуры
    
    
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Точно, не посмотрел на цикл :)

    ЗЫ. Сразу видно - кризис и все убрали прогов и думают, что сами все смогут...
  5. TopicStarter Overlay
    Nega
    Offline

    Nega

    Регистрация:
    24 июл 2008
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    :unsure: я начинающий самоучка )

Поделиться этой страницей