7.7 Обработка для номенклатуры

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем SerzhM, 11 май 2012.

  1. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Нужно сделать обработку для очистки номенклатуры от задвоеной позиции номенклатуры.
    После тестирование и исправления восстановилось 5700 позиций с одним и тем же именем Р:ФС-1 думаю обработкой пометить на удаление все эти позиции но как это делать я и не знаю.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Эти позиции имеют ссылки на документы/регистры/справочники. 1с как раз восстановила "битые" ссылки. Просто так вы их удалить не сможете. Единственный вариант - замена ВСЕХ ссылок на одну - единственную. Тогда из 5700 можно будет удалить 4699. Но без анализа базы и этого сделать нельзя.
  3. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    ТИС 9,2 .База была создана путем быстрой очистки от документов через скрипт, оставив только номенклатуру и справочник цен. Тестирование и исправление сразу не сделали. Подчистили номенклатуру. Думаю что можно будет и так удалить. Попробую штук 200 пометить и удалить.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Думаю вы забыли про справочник партий.... Его не очистили. Если брали скрипт с этого сайта, нужно было еще глянуть в файле 1cv7.dd имя справочника партий и грохнуть его. Удалить - не получится. Нужно партии вычищать. Хотя могу и ошибаться - нужно смотреть на что ссылаются эти элементы ТМЦ
  5. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Сегодня попробывал все прекрасно удаляет
    Справочник: Номенклатура P:ФС-1
    Справочник: Номенклатура P:ФС-1
    Справочник: Номенклатура P:ФС-1
    Справочник: Номенклатура P:ФС-1
    Подскажите как сделать обработку что бы он пометил на удаление Р:ФС-1
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура Сформировать()
    НачатьТранзакцию();
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    Если Найти(Спр.Наименование,"ФС-1")<>0 Тогда
    Спр.Удалить(0)
    КонецЕсли;
    КонецЦикла;
    ЗафиксироватьТранзакцию();
    КонецПроцедуры
    
  7. TopicStarter Overlay
    SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Спасибо.

Поделиться этой страницей