7.7 Оборотный регистр

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ANDRE, 18 янв 2011.

  1. TopicStarter Overlay
    ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте всем.
    Пишу свою конфигурацию.
    Имеется оборотный регистр Выплаты (периодичность "год").
    Создал отчет и обращаюсь к оборотам регистра через запрос.
    Сам запрос:
    Код:
    	Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Период С НачДата По КонДата;
    |Сотрудник = Регистр.Выплаты.Сотрудник;
    |Сумма = Регистр.Выплаты.Сумма;
    |Группировка Сотрудник;
    |Функция Сум = Сумма(Сумма); 
    |Условие (Сотрудник = сотр);
    |";	//
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    
    Если Запрос.Группировка("Сотрудник") = 1 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда				</span>
    ПечВыдано=Запрос.Сум;
    КонецЕсли;
    
    
    В этом регистре выполняет движения только один документ.
    Есть документ от 28.12.10 по Сотруднику1 с суммой 100, который как раз и двигает регистр.
    Ситуация следующая: если выбирать обороты за период с 02.12.10 по 31.12.10, то запрос показывает верную сумму - 100, если же выбирать за период с 01.12.10 по 31.12.10, то запрос возвращает 0.
    С другими сотрудникам тоже самое происходит. Если изменить дату документа на 01.12.10, и выбрать обороты за месяц декабрь, то все показывает верно.
    Обороты по другим месяцам формируются верно.
    В чем может быть проблема при выборке оборотов за месяц ДЕКАБРЬ?

    Спасибо всем.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Сделате тестирование-исправление бд. Возможно непорядок с интесами или итогами
  3. TopicStarter Overlay
    ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Тож думал утром сделать это, к сожалению, положительного результата не дало.
    Что еще пробовал:
    - индексные файлы удалял
    - выгружал и загружал
    - сохранял и восстанавливал
    Проблема осталась
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А если написать обработку/отчет выборки движений. Группировка сотрудник и документ .Может это прояснит ситуацию или во всяком случае установить причину.
  5. 1Cman
    Offline

    1Cman Опытный в 1С

    Регистрация:
    25 июл 2009
    Сообщения:
    308
    Симпатии:
    0
    Баллы:
    26
    Периодичность регистра месяц?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Учимся внимательно читать вопросы... В первом посте сказано - ГОД
  7. TopicStarter Overlay
    ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Написал без запроса (в запросах не силен)
    Код:
    РегВыплаты = СоздатьОбъект("Регистр.Выплаты"); 
    РегВыплаты.ВыбратьДвижения(НачДата, КонДата);
    Пока РегВыплаты.ПолучитьДвижение()=1 Цикл
    Сообщить("ТекущийДокумент "+ РегВыплаты.ТекущийДокумент());
    Сообщить("	Сотрудник: " + РегВыплаты.Сотрудник);
    Сообщить("	Сумма: " + РегВыплаты.Сумма); 
    КонецЦикла;
    
    
    Выдал результат по одному документу, который вводился 28.12.10, больше движений нет никаких.
    И это правильно
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Период год? (в смысле за какой период выбирали)
  9. TopicStarter Overlay
    ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Быборку движений делаю за месяц Декабрь, в первом посте я писал,что проверял на разных периодах
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Может все-же стоит установить фильтр и взять движения за весь год?
  11. TopicStarter Overlay
    ANDRE
    Offline

    ANDRE Опытный в 1С

    Регистрация:
    12 мар 2008
    Сообщения:
    456
    Симпатии:
    0
    Баллы:
    26
    Странно, но поставив в регистре периодичность в МЕСЯЦ, обороты показывает верно!

    брал движения за весь год, показывал ерунду.

    Вопрос решился установкой в регистре периодичности МЕСЯЦ

    Всем спасибо!
  12. 1Cman
    Offline

    1Cman Опытный в 1С

    Регистрация:
    25 июл 2009
    Сообщения:
    308
    Симпатии:
    0
    Баллы:
    26
    Это был не вопрос, а решение вопроса :angry:
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Нужно было год+1 тогда брать... Почитайте описания оборотных регистров

Поделиться этой страницей