8.х Обновление Управление торговым предприятием 1.0.84

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем kot488, 5 июл 2011.

  1. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    День добрый решили обновить нашу не типовую конфигураци 1.0.8.4 на более новы релиз. Обновление прошло нормально все работает (обновили до 1.0.12.1) но вот при открытии счета фактуры и нажатии кнопки на печать вылазит ошибка
    {Документ.СчетНаОплатуПокупателю(2070)}: Метод об`єкту не виявлено (СформироватьЗаголовокДокумента)
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект), Ссылка);

    Все остальные документы печатаются нормально.
    Вид счета котрый отправляется на печать изменяли, добавляли кнопку Отправить по E-mail


    В какую степь копать?
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект) -

    1)посмотри как в других доках заголовок формируется...сделай так же
    2) Добавь функцию СформироватьЗаголовокДокумента в общем модуле ОбщегоНазначения
  3. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26

    У нас от счета много какие документы печатаются

    вот как сам модуль где ошибка

    Процедура Печать(ИмяМакета, КоличествоЭкземпляров = 1, НаПринтер = Ложь, НепосредственнаяПечать = Ложь) Экспорт

    Если НЕ ЭтотОбъект.Проведен Тогда
    //ЭтотОбъект.Записать(РежимЗаписиДокумента.Проведение);
    ЭтотОбъект.Записать(РежимЗаписиДокумента.Запись);
    КонецЕсли;

    Если ИмяМакета = "Счет" Тогда
    // Печать счета на оплату
    ТабДокумент = ПечатьСчетаЗаказа(ИмяМакета);
    ИначеЕсли ИмяМакета = "СчетФакс" Тогда
    // Печать счета на оплату
    ТабДокумент = ПечатьСчетаЗаказа(ИмяМакета);
    ИначеЕсли ИмяМакета = "ДляСклада" Тогда
    ПечатьАктаДляСклада(Истина);
    ИначеЕсли ИмяМакета = "ДляСкладПросмотр" Тогда
    ПечатьАктаДляСклада();
    ИначеЕсли ИмяМакета = "ОрдерФОП" Тогда
    Если Обработан=Истина Тогда
    ПечатьФОП();
    Иначе
    Режим = РежимДиалогаВопрос.ДаНет;
    Ответ = Вопрос("Не установлена галочка ""обработка"", установить ее?", Режим, 0);
    Если Ответ = КодВозвратаДиалога.Да Тогда
    Обработан=Истина;
    СтатьяДекларацииПоЕдиномуНалогу=Справочники.СтатьиНалоговыхДеклараций.НайтиПоКоду("00238");
    Если НЕ (ЗначениеЗаполнено(ЭтотОбъект.НомерТоварногоЧека)) И ЭтотОбъект.Организация.Наименование="ФОП" Тогда
    Зарпос=Новый Запрос(
    "ВЫБРАТЬ
    | МАКСИМУМ(СчетНаОплатуПокупателю.НомерТоварногоЧека) КАК НомерТоварногоЧека
    |ИЗ
    | Документ.СчетНаОплатуПокупателю КАК СчетНаОплатуПокупателю
    |ГДЕ
    | СчетНаОплатуПокупателю.Организация.Наименование = &Наименование");
    Зарпос.УстановитьПараметр("Наименование",Организация.Наименование);
    Результат=Зарпос.Выполнить().Выбрать();
    Результат.Следующий();
    ЭтотОбъект.НомерТоварногоЧека=Результат.НомерТоварногоЧека+1;
    ЭтотОбъект.Записать(РежимЗаписиДокумента.Запись);
    КонецЕсли;
    ПечатьФОП();
    КонецЕсли;

    КонецЕсли;
    ИначеЕсли ИмяМакета = "ПечатьДляХХ" Тогда
    ТабДокумент = ПечатьСчетаЗаказаХХ("Счет");
    КонецЕсли;

    Если НЕ (ИмяМакета = "ДляСклада") И НЕ (ИмяМакета = "ДляСкладПросмотр") Тогда
    Если ИмяМакета = "Счет" или ИмяМакета = "СчетФакс" Тогда
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект), Ссылка);
    Иначе
    ФормированиеПечатныхФорм.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(ЭтотОбъект), НепосредственнаяПечать);
    КонецЕсли;
    КонецЕсли;

    КонецПроцедуры // Печать
  4. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    Заменил

    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект), Ссылка);

    на

    ФормированиеПечатныхФорм.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(ЭтотОбъект), НепосредственнаяПечать);

    Пропала кнопка отправки по емайлу((
  5. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    мда

    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(ЭтотОбъект), Ссылка);

    вот что надо было сделать
  6. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    не понял, не то что надо было поменял?
  7. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    аха
  8. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    спс попробуемс
  9. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    Сделал

    Если НЕ (ИмяМакета = "ДляСклада") И НЕ (ИмяМакета = "ДляСкладПросмотр") Тогда
    Если ИмяМакета = "Счет" или ИмяМакета = "СчетФакс" Тогда
    ФормированиеПечатныхФорм.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(ЭтотОбъект), НепосредственнаяПечать);
    Иначе
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, ОбщегоНазначения.СформироватьЗаголовокДокумента(ЭтотОбъект), Ссылка);



    Все равно кнопки нема
  10. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    Вот как оно должно выглядеть)

    Если НЕ (ИмяМакета = "ДляСклада") И НЕ (ИмяМакета = "ДляСкладПросмотр") Тогда
    Если ИмяМакета = "Счет" или ИмяМакета = "СчетФакс" Тогда
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(ЭтотОбъект), Ссылка);
    Иначе
    ФормированиеПечатныхФорм.НапечататьДокумент(ТабДокумент, КоличествоЭкземпляров, НаПринтер, РаботаСДиалогами.СформироватьЗаголовокДокумента(ЭтотОбъект), НепосредственнаяПечать);
    КонецЕсли;
  11. TopicStarter Overlay
    kot488
    Offline

    kot488 Опытный в 1С

    Регистрация:
    9 мар 2011
    Сообщения:
    393
    Симпатии:
    0
    Баллы:
    26
    А по поводу вот такой ошибки не подскажите?

    РегистрНакопления.ПланыДвиженияДенежныхСредств: Жоден з документів не є реєстратором для регістру
  12. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    а по русски если

Поделиться этой страницей