8.х БП Обновление бух 3

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем Snegur, 22 июн 2016.

  1. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    Доброго дня
    Бухгалтерия 3
    делал обновление с 3.0.43.208 на 3.0.43.235
    ошибки
    первая
    {ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(381)}: Ошибка при вызове метода контекста (ЭтотУзел)
    Возврат ПланыОбмена.ОбменСообщениями.ЭтотУзел();
    по причине:
    Найдено более одной записи
    вторая
    При вызове обработчика обновления:
    "ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()"
    произошла ошибка:
    "{ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(381)}: Ошибка при вызове метода контекста (ЭтотУзел)
    Возврат ПланыОбмена.ОбменСообщениями.ЭтотУзел();
    по причине:
    Найдено более одной записи".

    почитал пишут косяк платформы попробовал на разных версиях платформах
    пробовал взять чистую конфу последней версии и просто тупо полной заменой загрузить
    вообщем не помогло всегда одно и тоже . Подскажите вдруг кто сталкивался ?
    [​IMG]
  2. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Через "Все функции" зайдите в план обмена "Обмен сообщениями". Там должен быть предопределенный узел (соответствующий этой информационной базе).
    Посмотрите, нет ли там у Вас задвоений. Может, два предопределенных узла.
    Snegur нравится это.
  3. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    вроде всех по одной
    это если конфигурацию новую чистую заменой загрузить
    {ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(381)}: Ошибка при вызове метода контекста (ЭтотУзел)
    Возврат ПланыОбмена.ОбменСообщениями.ЭтотУзел();
    по причине:
    Найдено более одной записи


    При вызове обработчика обновления:
    "ОбменСообщениямиВнутренний.УстановитьКодЭтойКонечнойТочки()"
    произошла ошибка:
    "{ОбщийМодуль.ОбменСообщениямиВнутренний.Модуль(381)}: Ошибка при вызове метода контекста (ЭтотУзел)
    Возврат ПланыОбмена.ОбменСообщениями.ЭтотУзел();
    по причине:
    Найдено более одной записи".


    [​IMG]
  4. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Сам план обмена-то откройте (провалитесь в него) ).
  5. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    две строчки удалить которая без зеленной точки ?
    --- Объединение сообщений, 22 июн 2016 ---
    как удалить только он не дает ошибку пишет и завершить либо перезапустить

    "Элемент с установленным признаком "ЭтотУзел" уже существует"
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Тестирование и Исправление запустите с проверкой ссылочной и логической целостности с удалением объектов и ссылок.
  7. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    С зеленой точкой один элемент или два?
  8. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    Один с зеленой
  9. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Попробуйте тогда просто открыть его и перезаписать.
    Если не поможет, тогда воспользуйтесь советом выше (тестирование и исправление).
  10. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    ужас после тестирования их три штуки одна с зеленой при входе в нее пишет найдено более одной записи
    --- Объединение сообщений, 22 июн 2016 ---
    [​IMG]
  11. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    В общем, суть в чем. "Предопределенный" элемент (с зеленой точкой) должен быть всегда один. У Вас он один. Но система думает, что какой-то из двух других - тоже предопределенный. Поэтому и ругается, что найдено их более одного.
    Я с этим планом обмена никогда не работал. Не знаю, за что он отвечает.
    Думаю, единственный выход - удалить те два элемента. Жестко.
    Попробуйте на копии.
    Если через пометку на удаление не получается, тогда какой-то обработкой надо.
    kisol нравится это.
  12. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    не могу удалить
    Можно как то ручное супер удаление включить ?(интерактивное через шифт делет пробовал)
    {ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(28)}: Ошибка при вызове метода контекста (Удалить)
    ПП.Удалить();
    по причине:
    Действие недоступно для этого узла

    &НаСервере
    Процедура Команда1НаСервере()
    запрос = Новый запрос ;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ОбменСообщениями.Ссылка,
    | ОбменСообщениями.ВерсияДанных,
    | ОбменСообщениями.ПометкаУдаления,
    | ОбменСообщениями.ЭтотУзел,
    | ОбменСообщениями.Код,
    | ОбменСообщениями.Наименование,
    | ОбменСообщениями.НомерОтправленного,
    | ОбменСообщениями.НомерПринятого,
    | ОбменСообщениями.Ведущая,
    | ОбменСообщениями.Заблокирована
    |ИЗ
    | ПланОбмена.ОбменСообщениями КАК ОбменСообщениями";

    выборка = Запрос.Выполнить().Выбрать();
    Пока выборка.Следующий() Цикл
    ПП = выборка.ссылка.ПолучитьОбъект();
    Если ПП.Ведущая = Ложь тогда
    ПП.Удалить();
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры

    &НаКлиенте
    Процедура Команда1(Команда)
    Команда1НаСервере();
    КонецПроцедуры
    --- Объединение сообщений, 23 июн 2016 ---
    пытался узел изменить с истины на ложь
    пишет
    {ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(24)}: Ошибка при вызове метода контекста (Записать)
    ПП.записать();
    по причине:
    Данные изменения приведут к отсутствию элемента с установленным признаком "ЭтотУзел"
    Последнее редактирование: 23 июн 2016
  13. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    все получилось , Всем спасибо !
  14. 1cUserAndrew
    Offline

    1cUserAndrew Профессионал в 1С Команда форума

    Регистрация:
    27 май 2010
    Сообщения:
    4.948
    Симпатии:
    149
    Баллы:
    104
    Как?
    Snegur нравится это.
  15. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    узел с истины на ложь поменял выше писал думал не получилось , а потом зашел посмотреть сработало

Поделиться этой страницей