[РЕШЕНО] Обновление 1С8.2 (8.2.19.83) редакция 2.5 (2.5.79.2)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем asdfr1, 25 мар 2014.

  1. TopicStarter Overlay
    asdfr1
    Offline

    asdfr1

    Регистрация:
    18 июн 2011
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте!
    Зарплата и Управление Персоналом, редакция 2.5 (2.5.79.2)
    обновился в конфигураторе, сохранил , запустил пользовательский режим, выдаёт ошибку :
    {ОбщийМодуль.ПроцедурыОбновленияИнформационнойБазы.Модуль(10575)}: Ошибка при вызове метода контекста (Записать)
    Объект.Записать();
    по причине:
    Дублирование вытесняющих видов расчета
    В нормальный режим войти не удаётся чтобы посмотреть и подправить, есть копия вчерашнего дня.

    Вложения:

    • 123.JPG
      123.JPG
      Размер файла:
      46,4 КБ
      Просмотров:
      5
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    копия обязана быть перед обновлением
    --- Объединение сообщений, 25 мар 2014 ---
    могла сама 1С накосячить, недавно с УТ так же было, что-то перемудрили там с общим тоже модулем, отзывали апдейт
    --- Объединение сообщений, 25 мар 2014 ---
    хм, в 78.1 в том модуле всего 10500 строк было
    щас попробую обновить

    а платформа какая именно?
    Последнее редактирование: 25 мар 2014
  3. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    обновилось нормально, правда платформа 8.3.4.408
    падает на этой процедуре
    Код:
    Процедура ПроставитьВидамРасчетаСтажДляПерсУчета2014() Экспорт
    
        Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ОсновныеНачисленияОрганизаций.Ссылка,
        |    ОсновныеНачисленияОрганизаций.ВидПособияСоциальногоСтрахования,
        |    ОсновныеНачисленияОрганизаций.ОбозначениеВТабелеУчетаРабочегоВремени,
        |    ОсновныеНачисленияОрганизаций.ВидВремени,
        |    ОсновныеНачисленияОрганизаций.ВидСтажаСЗВ4
        |ИЗ
        |    ПланВидовРасчета.ОсновныеНачисленияОрганизаций КАК ОсновныеНачисленияОрганизаций
        |ГДЕ
        |    ОсновныеНачисленияОрганизаций.ВидСтажаПерсУчета2014 = ЗНАЧЕНИЕ(Перечисление.ВидыСтажаПерсУчета2014.ПустаяСсылка)
        |    И ОсновныеНачисленияОрганизаций.ВидВремени В (ЗНАЧЕНИЕ(Перечисление.ВидыВремени.ПустаяСсылка), ЗНАЧЕНИЕ(Перечисление.ВидыВремени.ОтработанноеВПределахНормы), ЗНАЧЕНИЕ(Перечисление.ВидыВремени.ЦелодневноеНеотработанное))
        |
        |ОБЪЕДИНИТЬ
        |
        |ВЫБРАТЬ
        |    ОсновныеНачисленияОрганизаций.Ссылка,
        |    ОсновныеНачисленияОрганизаций.ВидПособияСоциальногоСтрахования,
        |    ОсновныеНачисленияОрганизаций.ОбозначениеВТабелеУчетаРабочегоВремени,
        |    ОсновныеНачисленияОрганизаций.ВидВремени,
        |    ОсновныеНачисленияОрганизаций.ВидСтажаСЗВ4
        |ИЗ
        |    ПланВидовРасчета.ОсновныеНачисленияОрганизаций КАК ОсновныеНачисленияОрганизаций
        |ГДЕ
        |    ОсновныеНачисленияОрганизаций.Ссылка = ЗНАЧЕНИЕ(ПланВидовРасчета.ОсновныеНачисленияОрганизаций.ПособиеПоУходуЗаРебенкомДо1_5Лет)";
        Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий() Цикл
            ВидПособияСоциальногоСтрахования = Выборка.ВидПособияСоциальногоСтрахования;
            ОбозначениеВТабелеУчетаРабочегоВремени = Выборка.ОбозначениеВТабелеУчетаРабочегоВремени;
            Если Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.ЧАЭС Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.ЧАЭС;
            ИначеЕсли ЗначениеЗаполнено(ВидПособияСоциальногоСтрахования)
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ОтпускПоБеременностиИРодам
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.Болезнь
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ДополнительныйОтпуск
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ОсновнойОтпуск
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ОтпускПоУходуЗаРебенком
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ПростойПоВинеРаботодателя
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ПовышениеКвалификацииВДругойМестности
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ОтпускНаОбучение
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ГосударственныеОбязанности
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ОтстранениеОтРаботыСОплатой
                Или ОбозначениеВТабелеУчетаРабочегоВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ОтстранениеОтРаботыБезОплаты Тогда
                ВидСтажаПерсУчета2014 = ПроцедурыПерсонифицированногоУчета.ПорядокВключенияПериодаВСтраховойСтаж2014(ВидПособияСоциальногоСтрахования, Выборка.ВидВремени, ОбозначениеВТабелеУчетаРабочегоВремени);
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.ВключаетсяВСтажДляДосрочногоНазначенияПенсии Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.ВключаетсяВСтажДляДосрочногоНазначенияПенсии;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.ВключаетсяВСтраховойСтаж Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.ВключаетсяВСтраховойСтаж;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.ВременнаяНетрудоспособность Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.ВременнаяНетрудоспособность;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.Декрет Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.Декрет;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.Дети Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.Дети;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.ДЛДЕТИ Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.ДЛДЕТИ;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.НеВключаетсяВСтраховойСтаж Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.НеВключаетсяВСтраховойСтаж;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.НЕОПЛ Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.НЕОПЛ;
            ИначеЕсли Выборка.ВидСтажаСЗВ4 = Перечисления.ВидыСтажаСЗВ4.ОтпускБезСохраненияЗарплаты Тогда   
                ВидСтажаПерсУчета2014 = Перечисления.ВидыСтажаПерсУчета2014.ОтпускБезСохраненияЗарплаты;
            Иначе
                Продолжить;
            КонецЕсли;
            Объект = Выборка.Ссылка.ПолучитьОбъект();
            Объект.ОбменДанными.Загрузка = Истина;
            Объект.ВидСтажаПерсУчета2014 = ВидСтажаПерсУчета2014;
            Объект.Записать();
        КонецЦикла;
      
    КонецПроцедуры
    
    где-то у вас "нахлёст"
  4. TopicStarter Overlay
    asdfr1
    Offline

    asdfr1

    Регистрация:
    18 июн 2011
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    "копия обязана быть перед обновлением" - в течении "горящего" дня - стечение...
    "могла сама 1С накосячить" - две базы нормально обновил
    где-то у вас "нахлёст" - что вы вкладываете в "нахлёст", бухи чего то там не могли изменить(хотя, немного, бывало такое)
    закомментировал, сохранив поддержку и изменение конфигурации
    Объект.Записать();получил нормальное "обновление"
    может быть,где-то, разобрав 1CD ?
  5. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    никаких стечений, перед обновлением всегда копия! или разгребать потом подобное или ещё хуже

    -"по причине:
    Дублирование вытесняющих видов расчета"
    или дважды документ по какому-то начислению на кого-то завели, или в разных документах что-то одно профигурировало
    что-то типа невыхода, больничного, отгула, потому что сказало про вытесняющие
  6. TopicStarter Overlay
    asdfr1
    Offline

    asdfr1

    Регистрация:
    18 июн 2011
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    всё это и выше сказанное было ДАВНО проделано. проблема решена через 1CD . Тема закрыта.
  7. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    сама ошибка никуда не делась, вы сейчас её только обошли в коде, она ещё всплывёт у вас
  8. TopicStarter Overlay
    asdfr1
    Offline

    asdfr1

    Регистрация:
    18 июн 2011
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    нормально обновилось
  9. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    обновление то прошло (вроде), но тот косяк на что оно ругалось остался в базе же?
  10. TopicStarter Overlay
    asdfr1
    Offline

    asdfr1

    Регистрация:
    18 июн 2011
    Сообщения:
    28
    Симпатии:
    0
    Баллы:
    1
    обновление прошло нормально, "косяков" - нет
  11. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    376
    Баллы:
    104
    дай бог, дай бог

Поделиться этой страницей