[РЕШЕНО] Обновить открытую форму документа из обработки (обычные формы)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем irris, 2 апр 2014.

  1. TopicStarter Overlay
    irris
    Offline

    irris

    Регистрация:
    23 авг 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Возникла проблема. По кнопочке хочу заполнить табличную часть по другому документы. Сделал событие при нажатии на эту кнопку
    Код:
    Процедура КоманднаяПанельТоварыЗаполнитьПоЗаказу(Кнопка)
        Форма = Обработки.ЗаполнениеНарядаПоЗаказу.ПолучитьФорму("Форма");
        // "Ссылочка" - это глобальная экспортная переменная модуля открываемой формы
    
        Форма.Ссылочка = ЭтотОбъект.Ссылка;
        Форма.Открыть();
    КонецПроцедуры
    
    открывается обработка. указываем там нужный документ по которому хотим заполнить и он Заполняет.
    Вот код

    Код:
    Перем Ссылочка Экспорт;
    
    
    Процедура КнопкаВыполнитьНажатие(Кнопка)
        Если ЗначениеЗаполнено(Заказ) Тогда
        ЗаказНаряд = наряд.ПолучитьОбъект();
        ЗаказНаряд.Товары.Очистить();
        ЗаказНаряд.Товары.Загрузить(Заказ.Товары.Выгрузить());
        ЗаказНаряд.Записать();
        КонецЕсли;
        ЭтаФорма.Закрыть();
    КонецПроцедуры
    
    Процедура ПриОткрытии()
        ЭтотОбъект.Наряд = Ссылочка;
    КонецПроцедуры
    
    после закрытии обработки нужно обновить форму открытого документа. никак не получается. Помогает только закрытие и повторное открытие документа. Как можно обновить форму?
  2. TopicStarter Overlay
    irris
    Offline

    irris

    Регистрация:
    23 авг 2012
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Тему закрываю. Всё сделал. Понял что начал делать через одно место,в итоге сделал по другому. Сделал просто с помощью внешней обработки заполнения ТЧ,подцепил к документу и всё получилось.

Поделиться этой страницей