8.х Обмен - выгружаются регистры без документов - ПОМОГИТЕ!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем prokhorenkov, 4 апр 2007.

  1. TopicStarter Overlay
    prokhorenkov
    Offline

    prokhorenkov

    Регистрация:
    4 апр 2007
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Такая проблемма:

    У нас есть центральная офис и филиал.
    Стоит УТ 10.2 (предприятие 8.0)

    Необходимо, чтобы из филиала выгружались в центральный офис все документы, а из центрального офиса в филиал выгружались только изменённые документы филиала (если их вдруг кто нибудь изменит).

    Пригласили мы специалиста по 1С, чтобы нам настроил такой обмен.
    Начали обмениваться, но через некоторое время заметили, что взаиморасчёты и остатки в филиале кривые.

    Потом выяснилось, что в филиал не выгружаются документы центрального офиса, но выгружаются все регистры по таким документам, из за чего соответственно в филиале проблеммы (объект не найден).

    Вот кусок кода, который нам настроили для выгрузки в филиал:
    Процедура ПриОтправкеДанныхПодчиненному(ЭлементДанных, ОтправкаЭлемента)

    Если ТипЗнч(ЭлементДанных) = Тип("ДокументОбъект.РеализацияТоваровУслуг")
    Тогда
    //на филиалы не должны попадать документы с реквизитом склад = складу ЦОфиса
    Если ЭлементДанных.Склад.ЭтоСкладЦентральногоОфиса ИЛИ ЭлементДанных.Склад = Справочники.Склады.ПустаяСсылка() Тогда
    ОтправкаЭлемента = ОтправкаЭлементаДанных.Игнорировать;
    КонецЕсли;
    //КонецЕсли;

    ИначеЕсли ТипЗнч(ЭлементДанных) = Тип("ДокументОбъект.ПоступлениеТоваровУслуг")
    Тогда
    //на филиалы не должны попадать документы с реквизитом склад = складу ЦОфиса
    Если ТипЗнч(ЭлементДанных.СкладОрдер) = Тип("СправочникСсылка.Склады") Тогда
    Если ЭлементДанных.СкладОрдер.ЭтоСкладЦентральногоОфиса ИЛИ ЭлементДанных.СкладОрдер = Справочники.Склады.ПустаяСсылка() Тогда
    ОтправкаЭлемента = ОтправкаЭлементаДанных.Игнорировать;
    КонецЕсли;
    КонецЕсли;
    //КонецЕсли;

    ...........

    КонецПроцедуры

    В чём собака порылась? Подскажите? А то пропадаем - все данные в филиале кривые из за выгруженных нефилиальных регистров!
    У нас распределённая ИБ.
    На регистрах (авторегистрация: разрешить).

    prokhorenkov@narod.ru
  2. рамиль
    Offline

    рамиль Опытный в 1С

    Регистрация:
    12 мар 2006
    Сообщения:
    595
    Симпатии:
    0
    Баллы:
    26
    Из этого куска не возможно понять , почему выгружаются только движения.Скорее всего у вас стоит обмен по регистрам, но не настроен фильтр.

Поделиться этой страницей