8.х ОБМЕН обмен УТ 10.3 и молокозавод

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Uliss, 29 апр 2016.

  1. TopicStarter Overlay
    Uliss
    Offline

    Uliss Опытный в 1С

    Регистрация:
    20 мар 2010
    Сообщения:
    182
    Симпатии:
    0
    Баллы:
    26
    Добрый день
    Пытаюсь сделать обмен между УТ 10.3.35.2 и 1с:молокозавод 1.3.73.2, но выдает ошибку

    Ошибка при выгрузке данных для узла плана обмена
    ТипОбъекта = План видов характеристик объект: Назначения свойств категорий объектов
    Объект = Документ требование-накладная
    ОписаниеОшибки = Ошибка в обработчике события ПриВыгрузкеОбъекта
    ПКО = НазначенияСвойствКатегорийОбъектов (ПланВидовХарактеристикСсылка.НазначенияСвойствКатегорийОбъектов --> ПланВидовХарактеристикСсылка.Наз)
    Объект = Документ требование-накладная (План видов характеристик объект: Назначения свойств категорий объектов)
    Обработчик = ПриВыгрузкеОбъекта
    ОписаниеОшибки = Ошибка при вызове конструктора (ОписаниеТипов): Недопустимое значение параметра (параметр номер '1') (ДокументСсылка.УдалитьТранспортДляЦелейДекларирования)
    ПозицияМодуля = (1)
    КодСообщения = 42
    ПозицияМодуля = Обработка.ОбменДаннымиXML.МодульОбъекта(1617)
    КодСообщения = 72
    УзелПланаОбмена = Управление торговлей, редакция 10.3
    Произошла ошибка при выгрузке объектов. Было выгружено: 43

    план обмена не изменялся. Где копать?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Не думаю, что правила обмена типовые. Смотрите их.
  3. TopicStarter Overlay
    Uliss
    Offline

    Uliss Опытный в 1С

    Регистрация:
    20 мар 2010
    Сообщения:
    182
    Симпатии:
    0
    Баллы:
    26
    нашел обработчик событий при выгрузке
    Код:
    Если Не Источник.Предопределенный и Не Источник.ЭтоГруппа Тогда
      
        ОписаниеТипов = Источник.ТипЗначения;
        УзелТипов = DOM_СоздатьУзел("Типы");
      
        КвЧисла       = ОписаниеТипов.КвалификаторыЧисла;
        КвСтроки      = ОписаниеТипов.КвалификаторыСтроки;
        КвДаты        = ОписаниеТипов.КвалификаторыДаты;
      
        DOM_УстановитьАтрибут(УзелТипов, "ДопустимыйЗнак",          СокрЛП(КвЧисла.ДопустимыйЗнак));
        DOM_УстановитьАтрибут(УзелТипов, "Разрядность",             СокрЛП(КвЧисла.Разрядность));
        DOM_УстановитьАтрибут(УзелТипов, "РазрядностьДробнойЧасти", СокрЛП(КвЧисла.РазрядностьДробнойЧасти));
        DOM_УстановитьАтрибут(УзелТипов, "Длина",                   СокрЛП(КвСтроки.Длина));
        DOM_УстановитьАтрибут(УзелТипов, "ДопустимаяДлина",         СокрЛП(КвСтроки.ДопустимаяДлина));
        DOM_УстановитьАтрибут(УзелТипов, "СоставДаты",              СокрЛП(КвДаты.ЧастиДаты));
      
        ИсключаемыеТипы = Неопределено;
        Выполнить(Алгоритмы.ИсключитьИзНазначенияСвойствКатегорийОбъектов);
        Для каждого Тип Из ОписаниеТипов.Типы() Цикл
            //Уберем типы, которых нет в приемнике
            Если ИсключаемыеТипы.СодержитТип(Тип) Тогда
                Продолжить;
            КонецЕсли;
            DOM_ДобавитьЭлемент(УзелТипов, "Тип", одТипЗначенияСтрокой(Тип));
        КонецЦикла;
    
        УзелТиповXML = УзелТипов.XML;
        ДобавитьПодчиненный(Приемник, УзелТиповXML);
    
    КонецЕсли;
    Моих никаких знаний не хватает понять что здесь не так.
    --- Объединение сообщений, 29 апр 2016 ---
    вроде типовые, начинал настройку обмена из УТ, как обмен УТ-УПП.
  4. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
    Трудно сказать по коду. нужно смотреть, что передается в переменные. Попробуйте отладить правила, думаю сразу все поймете? Умеет пользоваться отладкой?
  5. TopicStarter Overlay
    Uliss
    Offline

    Uliss Опытный в 1С

    Регистрация:
    20 мар 2010
    Сообщения:
    182
    Симпатии:
    0
    Баллы:
    26
    Ну если тыкнете мордой смогу наверно)
  6. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.991
    Симпатии:
    399
    Баллы:
    104
  7. Andy13
    Offline

    Andy13 Опытный в 1С

    Регистрация:
    1 мар 2010
    Сообщения:
    244
    Симпатии:
    2
    Баллы:
    29
    Такое ощущение. что Источник - неопределено, или NULL.
    Срыв происходит при передаче каких-то дополнительных реквизитов или свойств. И тип свойства - документ с префиксом в метаданных - "Удалить".
    Посмотрите доп.реквизиты или свойства. Нет ли там дохлых элементов? Они и могут дать по ссылке неопределено или NULL.
  8. TopicStarter Overlay
    Uliss
    Offline

    Uliss Опытный в 1С

    Регистрация:
    20 мар 2010
    Сообщения:
    182
    Симпатии:
    0
    Баллы:
    26
    вроде обмен прошел. сделал так: пытался зайти в план видов характеристик - Назначение свойств и категорий объектов, почему то стоял запрет(Данная форма является служебной. интерактивная работа с ней запрещена), убрал запрет в конфигураторе. а там был элемент "требование-накладная" на который ссылался еще один элемент "отпустил", тупо удалил их обоих, вопрос: все ли правильно сделал?

    ошибка: теперь со стороны УТ не идет загрузка: Ошибка при загрузке данных: {Обработка.ОбменДаннымиXML.МодульОбъекта(7783)}: Ошибка при установке значения атрибута контекста (ТипЗначения): Тип не является подмножеством типа значений плана видов характеристик
    Последнее редактирование: 2 май 2016
  9. TopicStarter Overlay
    Uliss
    Offline

    Uliss Опытный в 1С

    Регистрация:
    20 мар 2010
    Сообщения:
    182
    Симпатии:
    0
    Баллы:
    26
    Нашел свойство объектов "Формула расчета количества" с типом строка 100, которое переносится с типом "Значение свойств объектов" т.к. оказывается в УТ макс. длина строки 50, поставил 50, обмен пошел.

Поделиться этой страницей