8.х обмен с Access

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mazza, 14 янв 2011.

  1. TopicStarter Overlay
    mazza
    Offline

    mazza Опытный в 1С

    Регистрация:
    4 фев 2009
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    У справочника ККМ есть реквизит ТипККМ который, подчинен справочнику ТипыККМ. Как записать этот реквизит?
    Код:
    Если ЭлементыФормы.ПутьКФайлу.Значение = ""  Тогда        
    Предупреждение("Не выбрана база данных");       
    Возврат;       
    КонецЕсли;         
    MBD = Новый COMОбъект("ADODB.CONNECTION");       
    Попытка       
    MBD.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ЭлементыФормы.ПутьКФайлу.Значение+";Uid=Admin;Pwd=");   
    Исключение        Сообщить(ОписаниеОшибки());       
    Возврат;   
    КонецПопытки;       
    ТекстСелект = "SELECT * FROM ККМ";   
    НаборЗаписей = Новый COMОбъект("ADODB.RecordSet");      
    Попытка       
    НаборЗаписей=MBD.Execute(ТекстСелект);   
    Исключение        Сообщить(ОписаниеОшибки());   
    КонецПопытки;       
    Попытка        НаборЗаписей.MoveFirst();  
    Исключение //табилца пустая     
    Сообщить(ОписаниеОшибки());      
    НаборЗаписей.Close();        
    Возврат;  
    КонецПопытки; 
    Пока НаборЗаписей.EOF()=0 Цикл 
    Код = Строка(НаборЗаписей.Fields("КодККМ").Value);
    ЗавНномер = Строка(НаборЗаписей.Fields("ЗавНомерККМ").Value);             
    АдресУстановки = Строка(НаборЗаписей.Fields("АдресУстановки").Value);
    ТипККМ = Строка(НаборЗаписей.Fields("КодМоделиККМ").Value);
    КодВладелец = Строка(НаборЗаписей.Fields("КодКлиента").Value);
    ТорговаяТочка = Строка(НаборЗаписей.Fields("ТорговаяТочка").Value);
    Район = Строка(НаборЗаписей.Fields("РайонУстановки").Value);
    Примечание = Строка(НаборЗаписей.Fields("Примечание").Value);
    ЦенаЗаТО = Строка(НаборЗаписей.Fields("ЦенаЗаТО").Value);
    ДатаУдаления = Строка(НаборЗаписей.Fields("ДатаУдаления").Value);                                                                              
    НаборЗаписей.MoveNext(); 
    Код = Код;
    Кассы = Справочники.ККМ.ПустаяСсылка();
    
    КассыСсылка = Справочники.ККМ.НайтиПоКоду(Код);
    
    Если КассыСсылка.Пустая() Тогда
    // элемент не нашли - создаем его
    Кассы = Справочники.ККМ.СоздатьЭлемент();
    Иначе
    // получим существующий
    Кассы =  Справочники.ККМ.НайтиПоКоду(Код).ПолучитьОбъект();
    КонецЕсли;
    //заполнение реквизитов
    
    Кассы.ЗавНомер = ЗавНномер;
    Кассы.АдресУстановки = АдресУстановки;	  
    Кассы.ТипККМ = ТипККМ;
    
    Кассы.КодВладелец = КодВладелец;
    Кассы.ТорговаяТочка = ТорговаяТочка;
    Кассы.Район = Район;
    Кассы.Примечание = Примечание;
    Кассы.ЦенаЗаТО = ЦенаЗаТО;
    Кассы.ДатаУдаления = ДатаУдаления;
    Кассы.Записать();		  
    
    КонецЦикла;
    
    
  2. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Наверно так:

    Кассы.ТипККМ = Справочники.ТипыККМ.НайтиПоНаименованию(ТипККМ);
Похожие темы
  1. mazza
    Ответов:
    1
    Просмотров:
    529
  2. fokin
    Ответов:
    1
    Просмотров:
    1.711
  3. slaay
    Ответов:
    2
    Просмотров:
    1.531
  4. andreyka998
    Ответов:
    1
    Просмотров:
    716
Загрузка...

Поделиться этой страницей