8.х ОБМЕН Обмен между УПТ и Розницей

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем st.nospam, 6 апр 2010.

  1. TopicStarter Overlay
    st.nospam
    Offline

    st.nospam

    Регистрация:
    6 апр 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Вылетает ошибка:

    при заходе в конфигуратор выделяет данный кусок кода:

    Код:
    Функция СформироватьЗапросПоТабличнойЧасти(ДокументОбъект, ИмяТабличнойЧасти, СтруктураПолей,
    СтруктураСложныхПолей = Неопределено, СписокУсловийЗапроса = Неопределено) Экспорт
    
    ТекстЗапроса   = "";
    УсловияЗапроса = "";
    
    Запрос = Новый Запрос;
    
    Для Каждого Реквизит Из СтруктураПолей Цикл
    
    ТекстЗапроса  = ТекстЗапроса + ",
    |Док." + Реквизит.Значение + 
    " КАК " + СокрЛП(Реквизит.Ключ);
    
    КонецЦикла;
    
    Если ТипЗнч(СтруктураСложныхПолей) = Тип("Структура") Тогда // Добавим к запросу конструкции.
    
    Для Каждого Элемент Из СтруктураСложныхПолей Цикл
    
    ТекстЗапроса  = ТекстЗапроса + ",
    | " + Элемент.Значение + 
    " КАК " + СокрЛП(Элемент.Ключ);
    
    КонецЦикла;
    
    КонецЕсли;
    
    //Устанавливает дополнительные условия запроса
    Если ТипЗнч(СписокУсловийЗапроса) = Тип ("СписокЗначений") Тогда
    
    Для Каждого Элемент Из СписокУсловийЗапроса Цикл
    
    ПараметрЗапроса = СтрЗаменить(СокрЛП(Элемент.Представление), ".", "");
    
    УсловияЗапроса  = УсловияЗапроса + "
    | И Док." + Элемент.Представление
    + ?(Элемент.Пометка, " = &", " <> &")
    + СокрЛП(ПараметрЗапроса);
    
    Запрос.УстановитьПараметр(ПараметрЗапроса, Элемент.Значение);
    
    КонецЦикла;
    
    КонецЕсли;
    
    Запрос.Текст = "ВЫБРАТЬ 
    | Док.НомерСтроки " + ТекстЗапроса + "
    | ИЗ 
    |      Документ." + ДокументОбъект.Метаданные().Имя + "."+ СокрЛП(ИмяТабличнойЧасти) + 
    " КАК Док 
    |     ГДЕ Док.Ссылка = &ДокументСсылка" + УсловияЗапроса;
    
    // Установим параметры запроса.
    Запрос.УстановитьПараметр("ДокументСсылка" , ДокументОбъект.Ссылка);
    
    Возврат Запрос.Выполнить();
    
    КонецФункции
    
    Понятно, что деление на ноль...но где?(((
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    На строке
    Код:
    Запрос.УстановитьПараметр("ДокументСсылка" , ДокументОбъект.Ссылка);
    
    Поставьте точку останова и посмотрите текст запроса. Его в студию.
  3. TopicStarter Overlay
    st.nospam
    Offline

    st.nospam

    Регистрация:
    6 апр 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Спасибо, нашли уже затык*)
  4. Seofil
    Offline

    Seofil

    Регистрация:
    12 апр 2010
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Господа, стою на тех же граблях, можно изложить решение проблемы подробнее.
  5. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    версии конфигураций скажите
  6. xdim
    Offline

    xdim

    Регистрация:
    24 янв 2012
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Номенклатура.ЕдиницаХраненияОстатков.Коэффициент = 0


    То есть нужно групповой обработкой найти номенклатуру где Номенклатура.ЕдиницаХраненияОстатков.Коэффициент = 0

    и затем изменить этот реквизит на 1. Если конечно нет пачек товаров.

Поделиться этой страницей