8.х ОБМЕН Обмен данными УТ Агент+ (10.3)-Бухгалтерия Предприятия (8.2))

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Катерина казань, 27 фев 2012.

  1. TopicStarter Overlay
    Катерина казань
    Offline

    Катерина казань Опытный в 1С

    Регистрация:
    6 апр 2011
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток!
    Необходимо написать правила обмена данными между УТ Агент+ и БП 8.2.
    Создала с нуля обменивается, но не заполняет поля которых не было в Агенте+. Создала правила на основе стандартных УТ-БП - не загружает (ошибки конвертации части текста). Как правильно делать то нужно? Помогите, пожалуйста.
  2. TopicStarter Overlay
    Катерина казань
    Offline

    Катерина казань Опытный в 1С

    Регистрация:
    6 апр 2011
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    И еще вопрос. При использовании обработки для обмена данными задаю период выгрузки определенный (от 01.02.2012 до 01.03.2012 например), а мне иногда весь 2011 год еще выгружает. С чем связано это?
  3. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.758
    Симпатии:
    509
    Баллы:
    204
    Читайте правила форума - один вопрос - одна тема.
  4. TopicStarter Overlay
    Катерина казань
    Offline

    Катерина казань Опытный в 1С

    Регистрация:
    6 апр 2011
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    хорошо. снимаю второй вопрос.
  5. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.758
    Симпатии:
    509
    Баллы:
    204
    Тогда ответ на первый вопрос:)
    Используйте конфигурацию Конвертация данных, создавайте правила обмена и успех будет на вашей стороне:)
  6. TopicStarter Overlay
    Катерина казань
    Offline

    Катерина казань Опытный в 1С

    Регистрация:
    6 апр 2011
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    ХА. Вы думаете я так не делала? Сделала, но (тут читаем первое сообщение) не заполняются некоторые поля на стороне приемника. Забиваю их вручную, основываясь на стандартных правилах УТ-БП, но те поля что должны быть в табличной части не заполняются.

    Вот текст обработчика "ПослеЗагрузки" документа РеализацияТиУ, например:
    Код:
    //склад и организация по умолчанию
    Если ПараметрыОбъекта <> Неопределено тогда
    ТаблицаПараметровТовары = ПараметрыОбъекта["ТоварыТабличнаяЧасть"];
    
    НомерСтроки = 0;
    Для Каждого СтрокаПараметров Из ТаблицаПараметровТовары Цикл
    ЗначениеПараметра = СтрокаПараметров.Комиссия;
    
    СтрокаТЧ = Объект.Товары.Получить(НомерСтроки);
    СчетаУчета = БухгалтерскийУчет.ПолучитьСчетаУчетаНоменклатуры(Объект.Организация, СтрокаТЧ.Номенклатура, Объект.Склад);
    
    Объект.ЗаполнитьСчетаУчетаВСтрокеТабЧасти(СтрокаТЧ, "Товары", Истина);
    
    Если ЗначениеПараметра = Истина Тогда
    СтрокаТЧ.ПереданныеСчетУчета = ПланыСчетов.Хозрасчетный.ТоварыПереданныеНаКомиссию;
    СтрокаТЧ.СчетУчета		   = ПланыСчетов.Хозрасчетный.ТоварыНаСкладе;
    КонецЕсли;
    
    НомерСтроки = НомерСтроки + 1;
    КонецЦикла;
    КонецЕсли;
    Объект.ЗаполнитьСчетаУчетаВТабЧасти(Объект.ВозвратнаяТара, "ВозвратнаяТара", Истина);
    СчетаУчета = БухгалтерскийУчетРасчетовСКонтрагентами.ПолучитьСчетаРасчетовСКонтрагентом(Объект.Организация, Объект.Контрагент, Объект.ДоговорКонтрагента);
    Если Объект.ДоговорКонтрагента.ВидДоговора = Перечисления.ВидыДоговоровКонтрагентов.СКомиссионером Тогда
    Объект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
    Объект.СчетУчетаРасчетовПоАвансам	 = ПланыСчетов.Хозрасчетный.ПустаяСсылка();
    Объект.СчетУчетаРасчетовПоТаре		= ПланыСчетов.Хозрасчетный.ПустаяСсылка();
    Иначе
    Объект.СчетУчетаРасчетовСКонтрагентом = СчетаУчета.СчетРасчетовПокупателя;
    Объект.СчетУчетаРасчетовПоАвансам	 = СчетаУчета.СчетАвансовПокупателя;
    Объект.СчетУчетаРасчетовПоТаре		= СчетаУчета.СчетУчетаТарыПокупателя;
    КонецЕсли;
    Объект.СчетУчетаРасчетовПоТаре		= СчетаУчета.СчетУчетаТарыПокупателя;
    Объект.СчетУчетаРасходовПоТаре	  = СчетаУчета.СчетУчетаРасходовПоТаре;
    Объект.СчетУчетаДоходовПоТаре	   = СчетаУчета.СчетУчетаДоходовПоТаре;
    // обработка счетов НУ и УСН
    Объект.ЗаполнитьСчетаУчетаВТабЧастиУслуги(Истина);
    После его выполнение никакие поля не изменяются. Явно я где то не так делаю. Посмотрите, пожалуйста, не замыленым взглядом
  7. TopicStarter Overlay
    Катерина казань
    Offline

    Катерина казань Опытный в 1С

    Регистрация:
    6 апр 2011
    Сообщения:
    125
    Симпатии:
    0
    Баллы:
    26
    Решено. Всем спасибо.
    Задавала значения строкой "90.01.1" и т.д. без указания типов

Поделиться этой страницей