7.7 Обмен данными 7.7 торговля 24h и frontol через встроеный почтовый клиент

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем JenyaSmol, 20 фев 2013.

  1. TopicStarter Overlay
    JenyaSmol
    Offline

    JenyaSmol

    Регистрация:
    20 фев 2013
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Неотправляет письмо (на почту)
    Основные ошибки SMTP сервер требует аутификации... (при использовании почты Mail.ru)
    При использовании rambler и google выдает ( 5.7.1 authentication required)
    Вот код отпраки письма из конфигуратора 1с

    Процедура ОтправитьПочту()

    Если ПустоеЗначение(АдресСМТП)=1 Тогда
    Результат.ДобавитьЗначение("У выбранного обоуродвания не настроен адрес сервера для получения почты","Почта");
    Возврат;
    КонецЕсли;
    Если ПустоеЗначение(ПортСМТП)=1 Тогда
    Результат.ДобавитьЗначение("У выбранного обоуродвания не настроен порт сервера для получения почты","Почта");
    Возврат;
    КонецЕсли;
    Если ПустоеЗначение(ФайлЗагрузки)=1 Тогда
    Результат.ДобавитьЗначение("У выбранного обоуродвания не настроен путь к файлу загрузки","Почта");
    Возврат;
    КонецЕсли;

    t24h.POP_Disconnect();
    t24h.SMTP_Disconnect();
    Если ФС.СуществуетФайл(ФайлЗагрузки)=0 Тогда
    Результат.ДобавитьЗначение("Файл загрузки не найден. Письмо не отправлено.","Почта");
    Возврат;
    КонецЕсли;
    //t24h.POP_SetProxySettings("193.167.187.188", 3128);
    ///Авторизация
    Если t24h.POP_Connect(СокрЛП(АдресПОП),ПортПОП)=0 Тогда //Подключение
    Результат.ДобавитьЗначение("Не удалось подключиться к серверу сообщений. Письмо не отправлено","Почта");
    Результат.ДобавитьЗначение(t24h.POP_Response(),"ПочтаПодробно");
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;
    Если t24h.POP_LogIn(СокрЛП(ЛогинПОП),СокрЛП(ПарольПОП))=0 Тогда
    Результат.ДобавитьЗначение("Не удалось войти в почту. Письмо не отправлено","Почта");
    Результат.ДобавитьЗначение(t24h.POP_Response(),"ПочтаПодробно");
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;
    ///\\\
    //t24h.SMTP_SetProxySettings("193.167.187.188", 3128);
    Если t24h.SMTP_Connect(СокрЛП(АдресСМТП),ПортСМТП)=0 Тогда //Подключение
    Результат.ДобавитьЗначение("Не удалось подключиться к серверу отправки сообщений. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;

    Если t24h.SMTP_From(СокрЛП(АдресОтправителя))=0 Тогда
    Результат.ДобавитьЗначение("Не удалось добавить адрес отправителя. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;

    Если t24h.SMTP_To(СокрЛП(АдресПолучателя))=0 Тогда
    Результат.ДобавитьЗначение("Не удалось добавить адрес получателя. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;

    Если t24h.SMTP_Subject("ATOL_RMK_CHANGE_001")=0 Тогда
    Результат.ДобавитьЗначение("Не удалось добавить тему сообщения. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;

    Если t24h.SMTP_Body("This message was sent by T24h. Don`t reply.")=0 Тогда
    Результат.ДобавитьЗначение("Не удалось прикрепить тело сообщения. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;
    Если ФлагАвтоЗагрузки=1 Тогда
    ТекстФайлФлаг =СоздатьОбъект("Текст");
    Попытка
    ТекстФайлФлаг.Записать(ФайлФлагАвтоЗагрузки);
    Исключение
    Результат.Установить("Описание" ,"Ошибка записи служебного файл-флага!");
    Результат.Установить("ПодробноеОписание",ОписаниеОшибки());
    Возврат;
    КонецПопытки;
    Если t24h.SMTP_AddAttach(ФайлФлагАвтоЗагрузки)<>0 Тогда
    Результат.ДобавитьЗначение("Не удалось прикрепить Файл флаг автозагрузки данных. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;
    КонецЕсли;
    Если t24h.SMTP_AddAttach(ФайлЗагрузки)<>0 Тогда
    Результат.ДобавитьЗначение("Не удалось прикрепить файл данных. Письмо не отправлено.","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;

    Если t24h.SMTP_Send()=0 Тогда
    Результат.ДобавитьЗначение("Не удалось отправить письмо","Почта");
    Результат.ДобавитьЗначение(t24h.SMTP_Response(),"ПочтаПодробно");
    t24h.SMTP_Disconnect();
    t24h.POP_Disconnect();
    Возврат;
    КонецЕсли;
    t24h.POP_Disconnect();
    t24h.SMTP_Disconnect();

    Если ФлагАвтоЗагрузки = 1 Тогда
    ФС.УдалитьФайл(ФайлФлагАвтоЗагрузки);
    КонецЕсли;

    Результат.ДобавитьЗначение("Письмо с файлом загрузки успешно отправлено","Почта");


    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    а где вы идентифицируетесь? Т.е. где логин/пароль?

Поделиться этой страницей