8.х Объект Только Просмотр

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Эмиль0690, 28 авг 2016.

  1. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день!
    Нужно убрать доступ на изменение объекта документа
    посмотрите пожалуйста код, не работает и даже ошибки нету
    как правильно нужно писать???
    Спасибо!

    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
       
        Если Не РольДоступна("Админ") и ЗначениеЗаполнено(Объект.ПоКурсу)Тогда
            Объект.ПоКурсу.ТолькоПросмотр  = Истина;
        КонецЕсли;         
       
    КонецПроцедуры
    
  2. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    327
    Симпатии:
    53
    Баллы:
    54
    Просмотр можно регулировать только для элемента формы
    Код:
    Элементы.ПоКурсу.ТолькоПросмотр = Истина;
  3. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    нет не работает
    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
       
        Если Не РольДоступна("Админ") и ЗначениеЗаполнено(Объект.ПоКурсу)Тогда
            Элементы.ПоКурсу.ТолькоПросмотр  = Истина;
        КонецЕсли;         
       
    КонецПроцедуры
    
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    А интерфейс кто будет обновлять ?
  5. 1с-ник
    Offline

    1с-ник Профессионал в 1С

    Регистрация:
    5 окт 2014
    Сообщения:
    327
    Симпатии:
    53
    Баллы:
    54
    Все работает, смотрите отладчиком, наверняка в этой же процедуре ПриСозданииНаСервере() имеется последующее изменение доступности этого элемента формы.
    Внимательней проверьте элементы формы для него ли вы меняете доступность.
  6. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Все зависит от того, в каком обработчике этот код прописывать. Если ПриЧтенииНаСервере(), то реквизиту можно выставлять сразу, если ПриОткрытии(), то уже на клиенте нужно обновлять интерфейс, вроде так :)
  7. TopicStarter Overlay
    Эмиль0690
    Offline

    Эмиль0690 Опытный в 1С

    Регистрация:
    3 фев 2014
    Сообщения:
    290
    Симпатии:
    2
    Баллы:
    29
    Добрый день:)
    скажите пожалуйста а как обновить интерфейс?
  8. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    ОбновитьОтображениеДанных()

Поделиться этой страницей