8.х Объединение строк строк в матете

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Pentыch, 28 авг 2014.

  1. TopicStarter Overlay
    Pentыch
    Offline

    Pentыch Опытный в 1С

    Регистрация:
    18 сен 2013
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток.
    Подскажите, пожалуйста.
    Есть отчет, в нем нужно объединить ячейки где период одинаковый.
    Пример кода:

    Код:
    Пока РезультатЗапроса.Следующий() Цикл
    ПериодСлед = РезультатЗапроса.Период;
    Если ЗначениеНеЗаполнено(РезультатЗапроса.Заявка) И ПериодПред <> ПериодСлед Тогда
                ОбластьПериод.Параметры.Период = РезультатЗапроса.Период;
                ОбластьПериод.Параметры.Комментарий = ?(ЗначениеНеЗаполнено(РезультатЗапроса.Заявка),  "Рекламаций не зарегистрировано","");
                ТабДок.Вывести(ОбластьПериод);
                N = 0;
            Иначе
                ОбластьДанные.Параметры.ПериодДанные = РезультатЗапроса.Период;
                ОбластьДанные.Параметры.Заполнить(РезультатЗапроса);
                ЗаявкаСлед = РезультатЗапроса.Заявка.Номер;
                Если ПериодСлед <> ПериодПред и ПериодПред <> Неопределено Тогда
                    N = 0;
                КонецЕсли;
                ТабДок.Вывести(ОбластьДанные);
                ПериодПред = ПериодСлед;
                ЗаявкаПред = ЗаявкаСлед;
    
                N = N + 1;
            КонецЕсли;
            Если (N > 1) Тогда
                ОбластьПериода1 = ТабДок.Область(ТабДок.ВысотаТаблицы-N,2,ТабДок.ВысотаТаблицы,2);
                ОбластьПериода1.Объединить();
            КонецЕсли;
    КонецЦикла;
    Однако, конечный результат не устаревает пользователя.
    Как видно на скриншоте, объединяет странно, т.е. не монолитный блок по периоду и заявке, а несколько ячеек, может сталкивался кто, как можно это обойти?
    [​IMG]
  2. TopicStarter Overlay
    Pentыch
    Offline

    Pentыch Опытный в 1С

    Регистрация:
    18 сен 2013
    Сообщения:
    51
    Симпатии:
    0
    Баллы:
    26
    И да, в коде одно объединение, но это новая версия (объединение заявки убрал пока что).
  3. Morris
    Offline

    Morris Новичок в 1С

    Регистрация:
    13 авг 2014
    Сообщения:
    22
    Симпатии:
    1
    Баллы:
    4
    При каждой итерации, т.е. при выводе каждой строки, объединение происходит заново? (по условию N > 1)
    Я вот не знаю, как 1С в этом случае работает, она старое (предыдущее) объединение сама разъединяет? Если нет, то это источник ошибки.
    Попробуйте разъединить вначале то, что объединили на предыдущей итерации.
    Последнее редактирование: 28 авг 2014

Поделиться этой страницей