8.х Объединение документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем OIT, 7 июл 2009.

  1. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Как можно объединить два документа одного и того же вида
    Благодарю Вас
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Что Вы по этим подразумеваете?
  3. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    если в отчете то запросом "Объединить" если что то другое то объясните ...
  4. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Информация введена двумя документами "Начисление зарплаты работниками организаций" с номерами каф00068 и каф00070 объем этих документов большой несколько сотен как объединить информацию этих документов в один документ или из одного документа добавить к другому документу
    программным путем либо есть другой вариант ?
    Благодарю Вас
  5. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Сделай внешнюю обработку заполнения ТЧ документа. Подцепи ее и все будут счастливы.
    Код:
    Процедура Инициализировать(Объект,ИмяТабличнойЧасти,ТабличноеПолеОбъекта)		Экспорт
    // форма с выбором документа, из которого брать данные
    ПолучитьФорму().ОткрытьМодально();
    
    // проверки по вкусу (удаление лишних строк, выбран ли документ и т.д.)
    Если Не СсылкаНаДокумент.Пустая() Тогда
    // перебираем строки и добавляем их снизу
    Для каждого Строка Из СсылкаНаДокумент.Начисления Цикл
    НоваяСтрока = Объект[ИмяТабличнойЧасти].Добавить();
    НоваяСтрока.Сотрудник = Строка.Сотрудник;
    // список всех остальных реквизитов...
    КонецЦикла; 
    
    КонецЕсли; 
    
    КонецПроцедуры
    
  6. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Взято из типовой ЗУП:

    Код:
    // Добавляет в таблицу значений строки из другой таблицы значений и 
    // в них значения колонок с совпадающими наименованиями.
    //
    // Параметры:
    //  ТаблицаИсточник - таблица значений, откуда берутся значения.
    //  ТаблицаПриемник - таблица значений, куда добавляются строки.
    //
    Процедура ЗагрузитьВТаблицуЗначений(ТаблицаИсточник, ТаблицаПриемник) Экспорт
    
    // Заполним значения в совпадающих колонках.
    Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл
    
    СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить();
    ЗаполнитьЗначенияСвойств(СтрокаТаблицыПриемника, СтрокаТаблицыИсточника);
    
    КонецЦикла;
    
    КонецПроцедуры // ЗагрузитьВТаблицуЗначений()
    
    
  7. TopicStarter Overlay
    OIT
    Offline

    OIT Опытный в 1С

    Регистрация:
    7 май 2007
    Сообщения:
    347
    Симпатии:
    0
    Баллы:
    26
    Я в растерянности как лучше сделать мне просто информацию из документа каф00068 присоединить к
    информации в документе каф00070 и все Я предполагала найти эти номера документов как-то открыть
    каф00070 и каким-то образом переслать из каф00068,но как в скобках в процедуре инициализировать
    оформить не представляю,что записать в ТабичноеПолеОбъекта,а также не понятен второй вариант
    зачем таблица значений это проще что ли?
    Благодарю Вас
  8. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    На базе 1С:ЗУП 2.5.15.4.

    Прогони на копии по-любому.
    Подцепляется как внешняя..табличных частей..

    P.S. Единственное, я не сворачивал по сотрудникам..при повторении возможны предупреждения..

    Вложения:

Поделиться этой страницей