8.х Нужно найти накладную

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ZSergey, 30 окт 2006.

  1. TopicStarter Overlay
    ZSergey
    Offline

    ZSergey

    Регистрация:
    30 окт 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Привет знатокам!
    В 1С вообще (не говоря уже о восьмерке) я новичек, потому прошу сильно не пинать.
    В Документах есть "Расходная накладная на маршрут" . Я создаю новый документ и мне нужно добраться, т.е. найти определенную накладную и извлеч из нее данные. Делаю так:
    Код:
    Процедура Кнопка2Нажатие(Элемент)
    //Накл1 = Документы.РасхНакл_НаМаршрут.НайтиПоРеквизиту("Водитель", "Добролинский А.С."); //Так тоже не работает
    Накл1 = Документы.РасхНакл_НаМаршрут.НайтиПоНомеру("Кос-000918");
    Пусто = Документы.РасхНакл_НаМаршрут.ПустаяСсылка();
    Если Накл1 = Пусто Тогда
    Предупреждение("Накладная не найдена");
    Иначе
    Предупреждение(Накл1.Водитель);
    КонецЕсли;
    КонецПроцедуры
    
    Данный вариант не работает, т.е. система сообщает "Накладная не найдена".
    Не подскажете, как нужно сделать правильно :)
  2. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Код:
    Накл1 = Документы.РасхНакл_НаМаршрут.НайтиПоНомеру("Кос-000918", Дата(2006, 1, 1));
    Если НЕ Накл1.Пустая() Тогда 
    // Выполнить действия в случае обнаружения такого документа. … 
    КонецЕсли; 
    
    
  3. TopicStarter Overlay
    ZSergey
    Offline

    ZSergey

    Регистрация:
    30 окт 2006
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Спасибо, все теперь работает!
  4. Nadusha
    Offline

    Nadusha

    Регистрация:
    31 янв 2007
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Уважаемые знатоки.
    Объясните новичку, почему НайтиПоНомеру() возвращает пустую ссылку, хотя точно известно, что документ существует. Возможно ли это из-за того, что не указывается дата.

    НомДок = "ОК001614823"; // Этот номер я копирую из поля НОМЕР самого документа

    ДокСсылка = Документы.РеализацияТоваровИУслуг.НайтиПоНомеру(НомДок); //Здесь всегда возвращается Документы.РеализацияТоваровИУслуг.ПустаяСсылка()

    Если этот же документ вытаскивать запросом подставляя в качестве параметра переменную Номер, то я нахожу нужный мне документ.

    Помогите Плизззззззззззз.
  5. Coder1C
    Offline

    Coder1C Слуга форума Команда форума Администратор

    Регистрация:
    10 фев 2006
    Сообщения:
    506
    Симпатии:
    31
    Баллы:
    54

    Попробуй так!

    ДокСсылка = Документы.РеализацияТоваровИУслуг.НайтиПоНомеру(СокрЛП(НомДок));
    Сообщить(ДокСсылка);

Поделиться этой страницей