8.х Нужно добавить колонку в Справочнике что бы выводить остатки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем iceborn, 15 июл 2010.

  1. TopicStarter Overlay
    iceborn
    Offline

    iceborn Опытный в 1С

    Регистрация:
    17 июн 2010
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    Имеется справочник Номенклатура, добавил колонку "Остатки" необходимо что бы в ней показывались остатки товара. Остатки товара хранятся у меня в регистре накопления. Подскажите как быстрее всего это сделать
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.554
    Симпатии:
    716
    Баллы:
    204
    запросом в процедуре "ПриПолученииДанных" для ТЧ СправочникСписок.Номенклатура
  3. TopicStarter Overlay
    iceborn
    Offline

    iceborn Опытный в 1С

    Регистрация:
    17 июн 2010
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    Если бы я ещё знал что в этой процедуре писать ((
  4. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.756
    Симпатии:
    509
    Баллы:
    204
    Писать нужно выборку из вашего регистра накопления, с отбором по номенклатуре.
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
  6. TopicStarter Overlay
    iceborn
    Offline

    iceborn Опытный в 1С

    Регистрация:
    17 июн 2010
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    BabySG это совсем не то что мне надо, мне надо в колонке ставить галочку...Мне надо что бы в этой колонке отображались остатки этого товара а именно с Регистра сведений Остатки
  7. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    BabySG лишь привел пример работы с "ПриПолученииДанных", а получение остатка из регистра НАКОПЛЕНИЯ - это уж за вами.

    Начинайте писать, дальше поможем.
  8. TopicStarter Overlay
    iceborn
    Offline

    iceborn Опытный в 1С

    Регистрация:
    17 июн 2010
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    Не так написал "Мне НЕ надо что бы в этой колонке отображались"
  9. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Не понял, в чем у Вас проблема?
  10. Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    iceborn, по-моему, вы путаете себя и других. Вы хотите чтобы у вас в колонке "Остаток" отображалось КоличествоОстаток из Регистра накопления. Для этого необходимо воспользоваться событием элемента формы "ПриПолученииДанных". Пример берем из ссылки, приведенной BabySG. Только переписываем эту процедуру "под себя", где вы будете получать остаток. Начните писать - если не будет получаться - поможем.
  11. TopicStarter Overlay
    iceborn
    Offline

    iceborn Опытный в 1С

    Регистрация:
    17 июн 2010
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    У меня получилось сделать что бы цена выводилась в справочнике номенклатура, создал колону Цена и использовал код


    Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    // Для элементов отобразим цену и ...
    Если Не ДанныеСтроки.ЭтоГруппа Тогда
    ОтборНоменклатуры = Новый Структура;
    ОтборНоменклатуры.Вставить("Номенклатура", ДанныеСтроки.Ссылка);
    ОформлениеСтроки.Ячейки.Цена.ОтображатьТекст = Истина;
    АктуальнаяЦена = РегистрыСведений.Цены.ПолучитьПоследнее( , ОтборНоменклатуры).Цена;
    ОформлениеСтроки.Ячейки.Цена.Текст = АктуальнаяЦена;

    // низкие цены выделим другим цветом
    Если АктуальнаяЦена<500 Тогда
    ОформлениеСтроки.Ячейки.Цена.ЦветТекста = WEBЦвета.Васильковый;
    КонецЕсли;
    КонецЕсли;

    // Для элементов отобразим цену и ...
    Если Не ДанныеСтроки.ЭтоГруппа Тогда
    ОтборНоменклатуры = Новый Структура;
    ОтборНоменклатуры.Вставить("Номенклатура", ДанныеСтроки.Ссылка);
    ОформлениеСтроки.Ячейки.Остаток.ОтображатьТекст = Истина;
    АктуальнаяЦена = РегистрыСведений.Остаток.ПолучитьПоследнее( , ОтборНоменклатуры).Остаток;
    ОформлениеСтроки.Ячейки.Остаток.Текст = АктуальнаяЦена;

    // низкие цены выделим другим цветом
    Если АктуальнаяЦена<500 Тогда
    ОформлениеСтроки.Ячейки.Остаток.ЦветТекста = WEBЦвета.Васильковый;

    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры

    Все отлично выводит! Подскажите код что бы в колнку "Остаток" так же само как и в колонку цена выводилась информация про остаток в РегистреСведений - Остаток
  12. TopicStarter Overlay
    iceborn
    Offline

    iceborn Опытный в 1С

    Регистрация:
    17 июн 2010
    Сообщения:
    204
    Симпатии:
    0
    Баллы:
    26
    Попытался по такой же системе сделать остатки не получилось
  13. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.756
    Симпатии:
    509
    Баллы:
    204
    Остаток-это регистр накопления. Выбирайте из него, например, из регистра накопления ТоварыНаСкладах.Количество или из виртуальной таблицы ТоварыНаСкладахОстатки.КоличествоОстаток.
  14. plasmoid
    Offline

    plasmoid

    Регистрация:
    27 окт 2006
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
    
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ
    |	ТоварыНаСкладахОстатки.Номенклатура как Номенклатура,
    |	Сумма(ЕСТЬNULL(ТоварыНаСкладахОстатки.КоличествоОстаток, 0)) КАК КоличествоОстаток
    |ИЗ
    |	РегистрНакопления.ТоварыНаСкладах.Остатки(
    |			&Период,
    |			Склад = &Склад
    |				И Номенклатура В (&МассивНоменклатуры)) КАК ТоварыНаСкладахОстатки
    |
    |СГРУППИРОВАТЬ ПО
    |	ТоварыНаСкладахОстатки.Номенклатура";
    
    Запрос.УстановитьПараметр("Период",	КонецДня(ТекущаяДата()));	 //Дата
    Запрос.УстановитьПараметр("Склад",	Справочники.Склады.НайтиПоКоду("000000001"));	 //Справочник ссылка: Склады (места хранения)
    
    Если Элемент.Колонки.Остаток.Видимость Тогда
    МассивНоменклатуры = Новый Массив;
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    МассивНоменклатуры.Добавить(ОформлениеСтроки.ДанныеСтроки.Ссылка);            
    КонецЦикла; 
    Запрос.УстановитьПараметр("МассивНоменклатуры",	МассивНоменклатуры);	 //Справочник ссылка: Номенклатура
    
    ТабНоменклатуры = Запрос.Выполнить().Выгрузить();
    
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    Если Не ОформлениеСтроки.ДанныеСтроки.ЭтоГруппа тогда
    Совпадения = ТабНоменклатуры.Найти(ОформлениеСтроки.ДанныеСтроки.Ссылка, "Номенклатура");
    ОформлениеСтроки.Ячейки.Остаток.Текст =?(Совпадения <> Неопределено, Совпадения.КоличествоОстаток, 0); 
    ОформлениеСтроки.Ячейки.Остаток.ОтображатьТекст = Истина;
    КонецЕсли;
    
    КонецЦикла; 
    
    КонецЕсли;
    КонецПроцедуры
    
  15. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Так, пора заканчивать эту демогогию, диктую, записывайте.
    Открываете типовую конфигурацию "Управление торговлей ред 10.3" и аккуратно и без шума варуете код получения остатка товара на складах.
    Для того чтоб предотвратить вопрос "а как это сделать" я скопирую всё сам, Вам остаётся в это мероприятие вникнуть, т.к. запрос очень даже не простой, но очень быстрый, что важно, товар может быть получен с ценой и остатком по каждому складу и по каждой характеристике одновременно. Т.к. Вы не указали с какой конфигурцией работаете, что является грубым нарушением, я не имею представления для чего именно Вы пишите данную задачу, держите
    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier"><span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПолучитьДеревоОстатковНоменклатуры[color=red]([/color]ДеревоОстатков[color=red],[/color] Номенклатура[color=red],[/color] ОтображатьСклады[color=red],[/color] 
    СписокЦенОстатков [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span>[color=red],[/color] ВсеТипыЦен [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red],[/color] 
    КурсыВалют[color=red],[/color] СписокСкладов [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/неопределено')">Неопределено</span>[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/экспорт')">Экспорт</span>
    ДеревоОстатков[color=red].[/color]Строки[color=red].[/color]Очистить[color=red]([/color][color=red])[/color][color=red];[/color]
    
    ТипыЦен [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Массив[color=red];[/color]
    МассивРассчитываемыхЦен [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Массив[color=red];[/color]
    СформироватьМассивБазовыхТиповЦен[color=red]([/color]СписокЦенОстатков[color=red],[/color] ТипыЦен[color=red],[/color] МассивРассчитываемыхЦен[color=red],[/color] ВсеТипыЦен[color=red])[/color][color=red];[/color]
    
    ПолучатьЦены [color=red]=[/color] [color=red]([/color]ТипыЦен[color=red].[/color]Количество[color=red]([/color][color=red])[/color] [color=red]>[/color] [color=black]0[/color][color=red])[/color][color=red];[/color]
    
    Запрос [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый</span> Запрос[color=red];[/color]
    
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"Номенклатура"[/color]        [color=red],[/color] Номенклатура[color=red])[/color][color=red];[/color]
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ПустаяХарактеристика"[/color][color=red],[/color] Справочники[color=red].[/color]ХарактеристикиНоменклатуры[color=red].[/color]ПустаяСсылка[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ПустойСклад"[/color]         [color=red],[/color] Справочники[color=red].[/color]Склады[color=red].[/color]ПустаяСсылка[color=red]([/color][color=red])[/color][color=red])[/color][color=red];[/color]
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"ТипыЦен"[/color]             [color=red],[/color] ТипыЦен[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ЗначениеЗаполнено[color=red]([/color]СписокСкладов[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Запрос[color=red].[/color]УстановитьПараметр[color=red]([/color][color=black]"Склады"[/color]       	[color=red],[/color] СписокСкладов[color=red])[/color][color=red];[/color]	
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    ОграничениеПоСкладу [color=red]=[/color] [color=red]?[/color][color=red]([/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеЗаполнено[color=red]([/color]СписокСкладов[color=red])[/color][color=red],[/color] [color=black]""[/color][color=red],[/color] [color=black]" И Склад В (&Склады) "[/color] [color=red])[/color][color=red];[/color]
    
    ТекстЗапроса [color=red]=[/color] [color=black]"[/color]
    [color=black]		|	ВЫБРАТЬ РАЗРЕШЕННЫЕ[/color]
    [color=black]		|		ХарактеристикиНоменклатуры.Ссылка               КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|		"[/color] [color=red]+[/color] [color=red]?[/color][color=red]([/color]ОтображатьСклады[color=red],[/color][color=black]", ВложенныйЗапрос.Склад КАК Склад, АдресныйСклад.МестоХранения КАК МестоХранения"[/color][color=red],[/color][color=black]""[/color][color=red])[/color] [color=red]+[/color] [color=black]"[/color]
    [color=black]		|		, ВложенныйЗапрос.КоличествоОстаток             КАК КоличествоОстаток[/color]
    [color=black]		|		, ВложенныйЗапрос.КоличествоСвободныйОстаток    КАК КоличествоСвободныйОстаток[/color]
    [color=black]		|		, ВложенныйЗапрос.КоличествоВРезерве            КАК КоличествоВРезерве[/color]
    [color=black]		|		, 0                                             КАК КоличествоСвободныйОстатокВЗаказахПоставщикам[/color]
    [color=black]		|"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПолучатьЦены <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]			|	,[/color]
    [color=black]			|	Цены.ФлагУсловийПоставки  КАК ФлагЦены,[/color]
    [color=black]			|	ЕСТЬNULL(Цены.Цена, 0.00) КАК Цена,[/color]
    [color=black]			|	Цены.Валюта               КАК Валюта,[/color]
    [color=black]			|	Цены.ЕдиницаИзмерения     КАК ЕдиницаЦены,[/color]
    [color=black]			|	1                         КАК КурсВалюты,[/color]
    [color=black]			|	1                         КАК КратностьВалюты,[/color]
    [color=black]			|	Цены.ТипЦен               КАК ТИПЦЕН[/color]
    [color=black]			|"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|	ИЗ[/color]
    [color=black]		|	([/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ХарактеристикиНоменклатуры.Ссылка   КАК Ссылка,[/color]
    [color=black]		|			ХарактеристикиНоменклатуры.Владелец КАК Владелец[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры[/color]
    [color=black]		|		ГДЕ[/color]
    [color=black]		|			ХарактеристикиНоменклатуры.Владелец = &Номенклатура[/color]
    [color=black]		|[/color]
    [color=black]		|		ОБЪЕДИНИТЬ[/color]
    [color=black]		|[/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка),[/color]
    [color=black]		|			&Номенклатура КАК Владелец[/color]
    [color=black]		|[/color]
    [color=black]		|		) КАК ХарактеристикиНоменклатуры[/color]
    [color=black]		|ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|	(ВЫБРАТЬ[/color]
    [color=black]		|		ВложенныйЗапрос.ХарактеристикаНоменклатуры                     КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|		"[/color] [color=red]+[/color] [color=red]?[/color][color=red]([/color]ОтображатьСклады[color=red],[/color][color=black]", ВложенныйЗапрос.Склад "[/color][color=red],[/color][color=black]""[/color][color=red])[/color] [color=red]+[/color] [color=black]"[/color]
    [color=black]		|		, СУММА(ВложенныйЗапрос.ТоварыНаСкладахОстатки [/color]
    [color=black]		|				+ ВложенныйЗапрос.ТоварыВРозницеОстатки [/color]
    [color=black]		|				+ ВложенныйЗапрос.ТоварыВНТТОстатки)                   КАК КоличествоОстаток[/color]
    [color=black]		|		, СУММА(ВложенныйЗапрос.ТоварыНаСкладахОстатки[/color]
    [color=black]		|				+ ВложенныйЗапрос.ТоварыВРозницеОстатки[/color]
    [color=black]		|				+ ВложенныйЗапрос.ТоварыВНТТОстатки[/color]
    [color=black]		|				- ВложенныйЗапрос.ТоварыВРезервеСкладахОстатки[/color]
    [color=black]		|				- ВложенныйЗапрос.ТоварыКПередачеСоСкладовОстатки)     КАК КоличествоСвободныйОстаток[/color]
    [color=black]		|		, СУММА(ВложенныйЗапрос.ТоварыВРезервеСкладахОстатки)          КАК КоличествоВРезерве[/color]
    [color=black]		|	ИЗ[/color]
    [color=black]		|		(ВЫБРАТЬ[/color]
    [color=black]		|			ТоварыНаСкладахОстатки.ХарактеристикаНоменклатуры          КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			, ТоварыНаСкладахОстатки.Склад                             КАК Склад[/color]
    [color=black]		|			, ТоварыНаСкладахОстатки.КоличествоОстаток                 КАК ТоварыНаСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРозницеОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВНТТОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРезервеСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыКПередачеСоСкладовОстатки[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрНакопления.ТоварыНаСкладах.Остатки(, Номенклатура = &Номенклатура"[/color] [color=red]+[/color] ОграничениеПоСкладу [color=red]+[/color] [color=black]") КАК ТоварыНаСкладахОстатки[/color]
    [color=black]					[/color]
    [color=black]		|		ОБЪЕДИНИТЬ ВСЕ[/color]
    [color=black]				[/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ТоварыВРозницеОстатки.ХарактеристикаНоменклатуры           КАК ХарактеристикаНомнклатуры[/color]
    [color=black]		|			, ТоварыВРозницеОстатки.Склад                              КАК Склад[/color]
    [color=black]		|			, 0                                                        КАК ТоварыНаСкладахОстатки[/color]
    [color=black]		|			, ТоварыВРозницеОстатки.КоличествоОстаток                  КАК ТоварыВРозницеОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВНТТОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРезервеСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыКПередачеСоСкладовОстатки[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрНакопления.ТоварыВРознице.Остатки(, Номенклатура = &Номенклатура"[/color] [color=red]+[/color] ОграничениеПоСкладу [color=red]+[/color] [color=black]") КАК ТоварыВРозницеОстатки[/color]
    [color=black]					[/color]
    [color=black]		|		ОБЪЕДИНИТЬ ВСЕ[/color]
    [color=black]				[/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ТоварыВНТТОстатки.ХарактеристикаНоменклатуры               КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			, ТоварыВНТТОстатки.Склад                                  КАК Склад[/color]
    [color=black]		|			, 0                                                        КАК ТоварыНаСкладахОстаток[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРозницеОстатки[/color]
    [color=black]		|			, ТоварыВНТТОстатки.КоличествоОстаток                      КАК ТоварыВНТТОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРезервеСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыКПередачеСоСкладовОстатки[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрНакопления.ТоварыВНТТ.Остатки(, Номенклатура = &Номенклатура"[/color] [color=red]+[/color] ОграничениеПоСкладу [color=red]+[/color] [color=black]") КАК ТоварыВНТТОстатки[/color]
    [color=black]					[/color]
    [color=black]		|		ОБЪЕДИНИТЬ ВСЕ[/color]
    [color=black]				[/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ТоварыВРезервеСкладахОстатки.ХарактеристикаНоменклатуры    КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			, ТоварыВРезервеСкладахОстатки.Склад                       КАК Склад[/color]
    [color=black]		|			, 0                                                        КАК ТоварыНаСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРозницеОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВНТТОстатки[/color]
    [color=black]		|			, ТоварыВРезервеСкладахОстатки.КоличествоОстаток           КАК ТоварыВРезервеСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыКПередачеСоСкладовОстатки[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрНакопления.ТоварыВРезервеНаСкладах.Остатки(, Номенклатура = &Номенклатура"[/color] [color=red]+[/color] ОграничениеПоСкладу [color=red]+[/color] [color=black]") КАК ТоварыВРезервеСкладахОстатки[/color]
    [color=black]					[/color]
    [color=black]		|		ОБЪЕДИНИТЬ ВСЕ[/color]
    [color=black]				[/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ТоварыКПередачеСоСкладовОстатки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			, ТоварыКПередачеСоСкладовОстатки.Склад                    КАК Склад[/color]
    [color=black]		|			, 0                                                        КАК ТоварыНаСкладахОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРозницеОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВНТТОстатки[/color]
    [color=black]		|			, 0                                                        КАК ТоварыВРезервеСкладахОстатки[/color]
    [color=black]		|			, ТоварыКПередачеСоСкладовОстатки.КоличествоОстаток        КАК ТоварыКПередачеСоСкладовОстатки[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрНакопления.ТоварыКПередачеСоСкладов.Остатки(, Номенклатура = &Номенклатура"[/color] [color=red]+[/color] ОграничениеПоСкладу [color=red]+[/color] [color=black]") КАК ТоварыКПередачеСоСкладовОстатки[/color]
    [color=black]					[/color]
    [color=black]		|		) КАК ВложенныйЗапрос[/color]
    [color=black]		|	СГРУППИРОВАТЬ ПО ВложенныйЗапрос.ХарактеристикаНоменклатуры "[/color] [color=red]+[/color] [color=red]?[/color][color=red]([/color]ОтображатьСклады[color=red],[/color][color=black]", ВложенныйЗапрос.Склад"[/color][color=red],[/color][color=black]""[/color][color=red])[/color] [color=red]+[/color] [color=black]"[/color]
    [color=black]		|	) КАК ВложенныйЗапрос[/color]
    [color=black]		|ПО ХарактеристикиНоменклатуры.Ссылка = ВложенныйЗапрос.ХарактеристикаНоменклатуры[/color]
    [color=black]		|"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ОтображатьСклады <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОграничениеЗапросаПоСкладу [color=red]=[/color] [color=red]?[/color][color=red]([/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">НЕ</span> ЗначениеЗаполнено[color=red]([/color]СписокСкладов[color=red])[/color][color=red],[/color] [color=black]""[/color][color=red],[/color] Символы[color=red].[/color]ПС [color=red]+[/color] [color=black]"И МестаХраненияНоменклатуры.Склад В (&Склады) "[/color] [color=red])[/color][color=red];[/color]
    
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ [/color]
    [color=black]		|	МестаХраненияНоменклатуры.МестоХранения КАК МестоХранения,[/color]
    [color=black]		|	МестаХраненияНоменклатуры.Склад КАК Склад,[/color]
    [color=black]		|	МестаХраненияНоменклатуры.Номенклатура КАК Номенклатура,[/color]
    [color=black]		|	МестаХраненияНоменклатуры.Приоритет КАК Приоритет[/color]
    [color=black]		|ИЗ[/color]
    [color=black]		|	РегистрСведений.МестаХраненияНоменклатуры КАК МестаХраненияНоменклатуры[/color]
    [color=black]		|ГДЕ[/color]
    [color=black]		|	МестаХраненияНоменклатуры.Номенклатура = &Номенклатура "[/color][color=red]+[/color] ОграничениеЗапросаПоСкладу [color=red]+[/color] [color=black]" ) КАК АдресныйСклад[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		АдресныйСклад.Склад = ВложенныйЗапрос.Склад[/color]
    [color=black]		|"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПолучатьЦены <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|[/color]
    [color=black]		|ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|([/color]
    [color=black]		|ВЫБРАТЬ ЦеныНаБазовыйТип.Номенклатура,[/color]
    [color=black]		| 		ЦеныНаБазовыйТип.ХарактеристикаНоменклатуры,[/color]
    [color=black]		|		ВЫБОР	КОГДА ЦеныНаБазовыйТип.Рассчитывается[/color]
    [color=black]		|				ТОГДА[/color]
    [color=black]		|					ВЫБОР	КОГДА ЦеныНаБазовыйТип.СпособРасчета = ЗНАЧЕНИЕ(Перечисление.СпособыРасчетаЦены.ПоПроцентнойНаценкеНаБазовыйТип)[/color]
    [color=black]		|							ТОГДА ЕСТЬNULL(ЦеныНаБазовыйТип.Цена, 0.00) + ЕСТЬNULL(ЦеныНаБазовыйТип.Цена, 0.00) * (ЦеныНаБазовыйТип.ПроцентСкидкиНаценки /100)[/color]
    [color=black]		|							ИНАЧЕ ЕСТЬNULL(ЦенаПоДиапазону.Цена, 0.00)[/color]
    [color=black]		|					КОНЕЦ[/color]
    [color=black]		|				ИНАЧЕ ЕСТЬNULL(ЦеныНаБазовыйТип.Цена, 0.00)[/color]
    [color=black]		|		КОНЕЦ КАК Цена,[/color]
    [color=black]		|		ВЫБОР 	КОГДА ЦеныНаБазовыйТип.Рассчитывается[/color]
    [color=black]		|				ТОГДА[/color]
    [color=black]		|					ВЫБОР 	КОГДА ЦеныНаБазовыйТип.СпособРасчета = ЗНАЧЕНИЕ(Перечисление.СпособыРасчетаЦены.ПоПроцентнойНаценкеНаБазовыйТип)[/color]
    [color=black]		|							ТОГДА ЦеныНаБазовыйТип.Валюта[/color]
    [color=black]		|							ИНАЧЕ ЦенаПоДиапазону.Валюта[/color]
    [color=black]		|						КОНЕЦ[/color]
    [color=black]		|				ИНАЧЕ ЦеныНаБазовыйТип.Валюта[/color]
    [color=black]		|		КОНЕЦ КАК Валюта,[/color]
    [color=black]		|		ВЫБОР	КОГДА ЦеныНаБазовыйТип.Рассчитывается[/color]
    [color=black]		|				ТОГДА[/color]
    [color=black]		|					ВЫБОР	КОГДА ЦеныНаБазовыйТип.СпособРасчета = ЗНАЧЕНИЕ(Перечисление.СпособыРасчетаЦены.ПоПроцентнойНаценкеНаБазовыйТип)[/color]
    [color=black]		|							ТОГДА ЦеныНаБазовыйТип.ЕдиницаИзмерения[/color]
    [color=black]		|							ИНАЧЕ ЦенаПоДиапазону.ЕдиницаИзмерения[/color]
    [color=black]		|					КОНЕЦ[/color]
    [color=black]		|				ИНАЧЕ ЦеныНаБазовыйТип.ЕдиницаИзмерения[/color]
    [color=black]		|		КОНЕЦ КАК ЕдиницаИзмерения,[/color]
    [color=black]		|		ЛОЖЬ КАК ФлагУсловийПоставки,[/color]
    [color=black]		|		ЦеныНаБазовыйТип.Рассчитывается,[/color]
    [color=black]		|		ЦеныНаБазовыйТип.ТипЦенБазовыйДинамический КАК ТипЦен[/color]
    [color=black]		| ИЗ[/color]
    [color=black]		|([/color]
    [color=black]		|	ВЫБРАТЬ[/color]
    [color=black]		|		НоменклатураХарактеристикаТипЦены.Номенклатура,[/color]
    [color=black]		|		НоменклатураХарактеристикаТипЦены.ХарактеристикаНоменклатуры,[/color]
    [color=black]		|		ВЫБОР 	КОГДА НоменклатураХарактеристикаТипЦены.Рассчитывается[/color]
    [color=black]		|				ТОГДА 	ВЫБОР 	КОГДА ЕСТЬNULL(КурсВалют.Кратность, 0.00) = 0 ИЛИ ЕСТЬNULL(КурсВалютДинамическийТип.Курс, 0.00) = 0[/color]
    [color=black]		|								ТОГДА 0.00[/color]
    [color=black]		|								ИНАЧЕ ЕСТЬNULL(ЕСТЬNULL(ЦеныНоменклатуры.Цена, ЦеныНоменклатурыПустаяХарактеристика.Цена), 0.00)[/color]
    [color=black]		|									  * ЕСТЬNULL(КурсВалют.Курс, 0.00)[/color]
    [color=black]		|									  * ЕСТЬNULL(КурсВалютДинамическийТип.Кратность, 0.00)[/color]
    [color=black]		|									  / КурсВалют.Кратность[/color]
    [color=black]		|									  / КурсВалютДинамическийТип.Курс[/color]
    [color=black]		|						КОНЕЦ[/color]
    [color=black]		|				ИНАЧЕ ЕСТЬNULL(ЦеныНоменклатуры.Цена, ЦеныНоменклатурыПустаяХарактеристика.Цена)[/color]
    [color=black]		|		КОНЕЦ КАК Цена,[/color]
    [color=black]		|		ВЫБОР 	КОГДА НоменклатураХарактеристикаТипЦены.Рассчитывается[/color]
    [color=black]		|				ТОГДА 	ВЫБОР 	КОГДА ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.СпособРасчетаЦены, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.СпособРасчетаЦены) ЕСТЬ NULL[/color]
    [color=black]		|				                ТОГДА ТипЦенНоменклаутры.СпособРасчетаЦены[/color]
    [color=black]		|				                ИНАЧЕ ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.СпособРасчетаЦены, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.СпособРасчетаЦены)[/color]
    [color=black]		|				        КОНЕЦ[/color]
    [color=black]		|				ИНАЧЕ NULL[/color]
    [color=black]		|		КОНЕЦ КАК СпособРасчета,[/color]
    [color=black]		|		ВЫБОР 	КОГДА НоменклатураХарактеристикаТипЦены.Рассчитывается[/color]
    [color=black]		|				ТОГДА 	ВЫБОР 	КОГДА ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.ПроцентСкидкиНаценки, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.ПроцентСкидкиНаценки) ЕСТЬ NULL[/color]
    [color=black]		|				                ТОГДА ТипЦенНоменклаутры.ПроцентСкидкиНаценки[/color]
    [color=black]		|				                ИНАЧЕ ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.ПроцентСкидкиНаценки, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.ПроцентСкидкиНаценки)[/color]
    [color=black]		|				        КОНЕЦ[/color]
    [color=black]		|				ИНАЧЕ NULL[/color]
    [color=black]		|		КОНЕЦ КАК ПроцентСкидкиНаценки,[/color]
    [color=black]		|		ВЫБОР 	КОГДА НоменклатураХарактеристикаТипЦены.Рассчитывается[/color]
    [color=black]		|				ТОГДА ЕСТЬNULL(ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.Валюта, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.Валюта), ТипЦенНоменклаутры.ВалютаЦены)[/color]
    [color=black]		|				ИНАЧЕ ЕСТЬNULL(ЦеныНоменклатуры.Валюта, ЦеныНоменклатурыПустаяХарактеристика.Валюта)[/color]
    [color=black]		|		КОНЕЦ КАК Валюта,[/color]
    [color=black]		|		КурсВалютДинамическийТип.Валюта КАК ВалютаДинамическийТип,[/color]
    [color=black]		|		ЕСТЬNULL(ЕСТЬNULL(ЦеныНоменклатуры.ЕдиницаИзмерения, ЦеныНоменклатурыПустаяХарактеристика.ЕдиницаИзмерения), НоменклатураХарактеристикаТипЦены.ЕдиницаХраненияОстатков) КАК ЕдиницаИзмерения,[/color]
    [color=black]		|		НоменклатураХарактеристикаТипЦены.ТипЦен,[/color]
    [color=black]		|		НоменклатураХарактеристикаТипЦены.ТипЦенБазовыйДинамический,[/color]
    [color=black]		|		НоменклатураХарактеристикаТипЦены.Рассчитывается[/color]
    [color=black]		|	ИЗ[/color]
    [color=black]		|	([/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			НоменклатураХарактеристикаТипЦены.Номенклатура,[/color]
    [color=black]		|			НоменклатураХарактеристикаТипЦены.ХарактеристикаНоменклатуры,[/color]
    [color=black]		|			НоменклатураХарактеристикаТипЦены.ЕдиницаХраненияОстатков КАК ЕдиницаХраненияОстатков,[/color]
    [color=black]		|			ВЫБОР 	КОГДА СпрТипЦены.Рассчитывается[/color]
    [color=black]		|					ТОГДА СпрТипЦены.БазовыйТипЦен[/color]
    [color=black]		|					ИНАЧЕ СпрТипЦены.Ссылка[/color]
    [color=black]		|			КОНЕЦ КАК ТипЦен,[/color]
    [color=black]		|			СпрТипЦены.Ссылка КАК ТипЦенБазовыйДинамический,[/color]
    [color=black]		|			СпрТипЦены.Рассчитывается[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|		([/color]
    [color=black]		|			ВЫБРАТЬ НоменклатураХарактеристика.Номенклатура,[/color]
    [color=black]		|					НоменклатураХарактеристика.ХарактеристикаНоменклатуры,[/color]
    [color=black]		|					СпрНомеклатура.ЕдиницаХраненияОстатков КАК ЕдиницаХраненияОстатков,[/color]
    [color=black]		|					сТипыЦенНоменклатуры.Ссылка КАК ТипЦен[/color]
    [color=black]		|			ИЗ[/color]
    [color=black]		|			([/color]
    [color=black]		|				ВЫБРАТЬ	[/color]
    [color=black]		|					Характеристики.Владелец КАК Номенклатура,[/color]
    [color=black]		|					Характеристики.Ссылка КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|				ИЗ[/color]
    [color=black]		|					Справочник.ХарактеристикиНоменклатуры КАК Характеристики[/color]
    [color=black]		|					ГДЕ Характеристики.Владелец = &Номенклатура[/color]
    [color=black]		|				ОБЪЕДИНИТЬ[/color]
    [color=black]		|				ВЫБРАТЬ [/color]
    [color=black]		|						&Номенклатура КАК Номенклатура,[/color]
    [color=black]		|						ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка) КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			) КАК НоменклатураХарактеристика[/color]
    [color=black]		|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|				Справочник.Номенклатура КАК СпрНомеклатура[/color]
    [color=black]		|			ПО[/color]
    [color=black]		|				СпрНомеклатура.Ссылка = НоменклатураХарактеристика.Номенклатура[/color]
    [color=black]		|			ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|				Справочник.ТипыЦенНоменклатуры КАК сТипыЦенНоменклатуры[/color]
    [color=black]		|			ПО ИСТИНА[/color]
    [color=black]		|			ГДЕ[/color]
    [color=black]		|				сТипыЦенНоменклатуры.Ссылка В (&ТипыЦен)[/color]
    [color=black]		|		) КАК НоменклатураХарактеристикаТипЦены[/color]
    [color=black]		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|			Справочник.ТипыЦенНоменклатуры КАК СпрТипЦены[/color]
    [color=black]		|		ПО[/color]
    [color=black]		|			СпрТипЦены.Ссылка = НоменклатураХарактеристикаТипЦены.ТипЦен[/color]
    [color=black]		|	) КАК НоменклатураХарактеристикаТипЦены[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, Номенклатура = &Номенклатура) КАК ЦеныНоменклатуры[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		ЦеныНоменклатуры.Номенклатура = НоменклатураХарактеристикаТипЦены.Номенклатура[/color]
    [color=black]		|		И ЦеныНоменклатуры.ХарактеристикаНоменклатуры = НоменклатураХарактеристикаТипЦены.ХарактеристикаНоменклатуры[/color]
    [color=black]		|		И ЦеныНоменклатуры.ТипЦен = НоменклатураХарактеристикаТипЦены.ТипЦен[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, Номенклатура = &Номенклатура) КАК ЦеныНоменклатурыПустаяХарактеристика[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		ЦеныНоменклатурыПустаяХарактеристика.Номенклатура = НоменклатураХарактеристикаТипЦены.Номенклатура[/color]
    [color=black]		|		И ЦеныНоменклатурыПустаяХарактеристика.ХарактеристикаНоменклатуры = ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка)[/color]
    [color=black]		|		И ЦеныНоменклатурыПустаяХарактеристика.ТипЦен = НоменклатураХарактеристикаТипЦены.ТипЦен[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, Номенклатура = &Номенклатура) КАК ЦеныНоменклатурыДинамическийТип[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		ЦеныНоменклатурыДинамическийТип.Номенклатура = НоменклатураХарактеристикаТипЦены.Номенклатура[/color]
    [color=black]		|		И ЦеныНоменклатурыДинамическийТип.ХарактеристикаНоменклатуры = НоменклатураХарактеристикаТипЦены.ХарактеристикаНоменклатуры[/color]
    [color=black]		|		И ЦеныНоменклатурыДинамическийТип.ТипЦен = НоменклатураХарактеристикаТипЦены.ТипЦенБазовыйДинамический[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, Номенклатура = &Номенклатура) КАК ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.Номенклатура = НоменклатураХарактеристикаТипЦены.Номенклатура[/color]
    [color=black]		|		И ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.ХарактеристикаНоменклатуры = ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка)[/color]
    [color=black]		|		И ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.ТипЦен = НоменклатураХарактеристикаТипЦены.ТипЦенБазовыйДинамический[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		РегистрСведений.КурсыВалют.СрезПоследних() КАК КурсВалют[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		КурсВалют.Валюта = ЕСТЬNULL(ЦеныНоменклатуры.Валюта, ЦеныНоменклатурыПустаяХарактеристика.Валюта)[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		Справочник.ТипыЦенНоменклатуры КАК ТипЦенНоменклаутры[/color]
    [color=black]		|	ПО [/color]
    [color=black]		|		ТипЦенНоменклаутры.Ссылка = НоменклатураХарактеристикаТипЦены.ТипЦенБазовыйДинамический[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		РегистрСведений.КурсыВалют.СрезПоследних() КАК КурсВалютДинамическийТип[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		КурсВалютДинамическийТип.Валюта = 	ВЫБОР 	КОГДА НоменклатураХарактеристикаТипЦены.Рассчитывается И ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.Валюта, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.Валюта) ЕСТЬ NULL[/color]
    [color=black]		|													ТОГДА ТипЦенНоменклаутры.ВалютаЦены[/color]
    [color=black]		|													ИНАЧЕ ЕСТЬNULL(ЦеныНоменклатурыДинамическийТип.Валюта, ЦеныНоменклатурыПустаяХарактеристикаДинамическийТип.Валюта)[/color]
    [color=black]		|											КОНЕЦ[/color]
    [color=black]		|) КАК ЦеныНаБазовыйТип[/color]
    [color=black]		|//Динамический тип цен[/color]
    [color=black]		|ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|([/color]
    [color=black]		|	ВЫБРАТЬ[/color]
    [color=black]		|	        ДинамическийТипЦен.Номенклатура[/color]
    [color=black]		|	      , ДинамическийТипЦен.ХарактеристикаНоменклатуры[/color]
    [color=black]		|	      , ДинамическийТипЦен.ДинамическийТип КАК БазовыйТипЦен[/color]
    [color=black]		|	      , ДинамическийТипЦен.ЕдиницаИзмерения КАК ЕдиницаИзмерения[/color]
    [color=black]		|	      , ЕСТЬNULL(ЦенаПоДиапазону.Цена, 0.00) КАК Цена[/color]
    [color=black]		|	      , ЦенаПоДиапазону.Валюта[/color]
    [color=black]		|	ИЗ[/color]
    [color=black]		|	([/color]
    [color=black]		|		ВЫБРАТЬ  ЦенаДляРасчетаДиапазона.Номенклатура,[/color]
    [color=black]		|			ЦенаДляРасчетаДиапазона.ХарактеристикаНоменклатуры,		[/color]
    [color=black]		|	  		ЦенаДляРасчетаДиапазона.ДинамическийТип,[/color]
    [color=black]		|	  		МИНИМУМ(ЦенаПоДиапазону.Валюта) КАК Валюта,[/color]
    [color=black]		|	  		МИНИМУМ(ЦенаДляРасчетаДиапазона.ЕдиницаИзмерения) КАК ЕдиницаИзмерения,[/color]
    [color=black]		|	  		МИНИМУМ(ЦенаПоДиапазону.ВерхняяГраница) КАК Цена[/color]
    [color=black]		|	ИЗ[/color]
    [color=black]		|	([/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			НомеклатураХарактеристикаТип.Номенклатура КАК Номенклатура,[/color]
    [color=black]		|			НомеклатураХарактеристикаТип.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,[/color]
    [color=black]		|			ЕСТЬNULL(ЕСТЬNULL(ЦеныБазовые.Цена, ЦеныБазовыеПустаяХарактеристика.Цена), 0.00) КАК Цена,[/color]
    [color=black]		|			ЕСТЬNULL(ЦеныБазовые.ТипЦен, ЦеныБазовыеПустаяХарактеристика.ТипЦен) КАК ДинамическийТип,[/color]
    [color=black]		|			ЕСТЬNULL(ЦеныБазовые.ЕдиницаИзмерения, ЦеныБазовыеПустаяХарактеристика.ЕдиницаИзмерения) КАК ЕдиницаИзмерения[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|		([/color]
    [color=black]		|			ВЫБРАТЬ	[/color]
    [color=black]		|				Характеристики.Владелец КАК Номенклатура,[/color]
    [color=black]		|				Характеристики.Ссылка КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			ИЗ[/color]
    [color=black]		|				Справочник.ХарактеристикиНоменклатуры КАК Характеристики[/color]
    [color=black]		|			ГДЕ Характеристики.Владелец = &Номенклатура[/color]
    [color=black]		|			ОБЪЕДИНИТЬ[/color]
    [color=black]		|			ВЫБРАТЬ [/color]
    [color=black]		|					&Номенклатура КАК Номенклатура,[/color]
    [color=black]		|					ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка) КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|		) КАК НомеклатураХарактеристикаТип[/color]
    [color=black]		|		ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|			РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, Номенклатура = &Номенклатура И (НЕ ТипЦен.Рассчитывается И ТипЦен В (&ТипыЦен))) КАК ЦеныБазовые[/color]
    [color=black]		|		ПО[/color]
    [color=black]		|			ЦеныБазовые.Номенклатура = НомеклатураХарактеристикаТип.Номенклатура[/color]
    [color=black]		|			И ЦеныБазовые.ХарактеристикаНоменклатуры = НомеклатураХарактеристикаТип.ХарактеристикаНоменклатуры[/color]
    [color=black]		|		ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|			РегистрСведений.ЦеныНоменклатуры.СрезПоследних(, Номенклатура = &Номенклатура И (НЕ ТипЦен.Рассчитывается И ТипЦен В (&ТипыЦен))) КАК ЦеныБазовыеПустаяХарактеристика[/color]
    [color=black]		|		ПО[/color]
    [color=black]		|			ЦеныБазовыеПустаяХарактеристика.Номенклатура = НомеклатураХарактеристикаТип.Номенклатура[/color]
    [color=black]		|			И ЦеныБазовыеПустаяХарактеристика.ХарактеристикаНоменклатуры = ЗНАЧЕНИЕ(Справочник.ХарактеристикиНоменклатуры.ПустаяСсылка)[/color]
    [color=black]		|		ГДЕ[/color]
    [color=black]		|			НЕ ЕСТЬNULL(ЦеныБазовые.ТипЦен, ЦеныБазовыеПустаяХарактеристика.ТипЦен) ЕСТЬ NULL[/color]
    [color=black]		|	) КАК ЦенаДляРасчетаДиапазона[/color]
    [color=black]		|	ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|	([/color]
    [color=black]		|		ВЫБРАТЬ  Диапазон.Валюта[/color]
    [color=black]		|				,ТипыЦен.БазовыйТипЦен КАК ТипЦен[/color]
    [color=black]		|				, Диапазон.Цена[/color]
    [color=black]		|				, Диапазон.ВерхняяГраница[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрСведений.ДиапазоныЦенДляНаценки.СрезПоследних(,) КАК Диапазон [/color]
    [color=black]		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|		(	[/color]
    [color=black]		|			ВЫБРАТЬ	ТипЦен[/color]
    [color=black]		|					, МАКСИМУМ(Период) КАК Период[/color]
    [color=black]		|			ИЗ РегистрСведений.ДиапазоныЦенДляНаценки.СрезПоследних(, ) КАК Диапазон [/color]
    [color=black]		|			СГРУППИРОВАТЬ ПО Диапазон.ТипЦен[/color]
    [color=black]		|		) КАК Диапазон2[/color]
    [color=black]		|		ПО Диапазон2.ТипЦен = Диапазон.ТипЦен И Диапазон2.Период = Диапазон.Период[/color]
    [color=black]		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|			Справочник.ТипыЦенНоменклатуры КАК ТипыЦен[/color]
    [color=black]		|		ПО[/color]
    [color=black]		|			ТипыЦен.Ссылка = Диапазон.ТипЦен[/color]
    [color=black]		|	) КАК ЦенаПоДиапазону[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		ЦенаПоДиапазону.ТипЦен = ЦенаДляРасчетаДиапазона.ДинамическийТип[/color]
    [color=black]		|		И ЦенаПоДиапазону.ВерхняяГраница > ЦенаДляРасчетаДиапазона.Цена[/color]
    [color=black]		|	ГДЕ[/color]
    [color=black]		|		НЕ ЦенаПоДиапазону.ВерхняяГраница ЕСТЬ NULL	[/color]
    [color=black]		|	СГРУППИРОВАТЬ ПО ЦенаДляРасчетаДиапазона.ДинамическийТип[/color]
    [color=black]		|					, ЦенаДляРасчетаДиапазона.ХарактеристикаНоменклатуры[/color]
    [color=black]		|					, ЦенаДляРасчетаДиапазона.Номенклатура	[/color]
    [color=black]							[/color]
    [color=black]		|	) КАК ДинамическийТипЦен[/color]
    [color=black]		|	ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|	(	[/color]
    [color=black]		|		ВЫБРАТЬ  Диапазон.Валюта[/color]
    [color=black]		|				, ТипыЦен.БазовыйТипЦен КАК ТипЦен[/color]
    [color=black]		|				, Диапазон.Цена[/color]
    [color=black]		|				, Диапазон.ВерхняяГраница[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			РегистрСведений.ДиапазоныЦенДляНаценки.СрезПоследних(,) КАК Диапазон [/color]
    [color=black]		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|			Справочник.ТипыЦенНоменклатуры КАК ТипыЦен[/color]
    [color=black]		|		ПО[/color]
    [color=black]		|			ТипыЦен.Ссылка = Диапазон.ТипЦен[/color]
    [color=black]		|	) КАК ЦенаПоДиапазону[/color]
    [color=black]		|	ПО[/color]
    [color=black]		|		ЦенаПоДиапазону.ТипЦен = ДинамическийТипЦен.ДинамическийТип[/color]
    [color=black]		|		И ЦенаПоДиапазону.ВерхняяГраница = ДинамическийТипЦен.Цена[/color]
    [color=black]		|) КАК ЦенаПоДиапазону[/color]
    [color=black]		|ПО[/color]
    [color=black]		|	ЦенаПоДиапазону.БазовыйТипЦен = ЦеныНаБазовыйТип.ТипЦен[/color]
    [color=black]		|	И ЦенаПоДиапазону.Номенклатура = ЦеныНаБазовыйТип.Номенклатура[/color]
    [color=black]		|	И ЦенаПоДиапазону.ХарактеристикаНоменклатуры = ЦеныНаБазовыйТип.ХарактеристикаНоменклатуры[/color]
    [color=black]		|ГДЕ[/color]
    [color=black]		|	ВЫБОР	КОГДА ЦеныНаБазовыйТип.Рассчитывается[/color]
    [color=black]		|			ТОГДА[/color]
    [color=black]		|				ВЫБОР 	КОГДА ЦеныНаБазовыйТип.СпособРасчета = ЗНАЧЕНИЕ(Перечисление.СпособыРасчетаЦены.ПоПроцентнойНаценкеНаБазовыйТип)[/color]
    [color=black]		|						ТОГДА ЕСТЬNULL(ЦеныНаБазовыйТип.Цена, 0.00) + ЕСТЬNULL(ЦеныНаБазовыйТип.Цена, 0.00) * (ЦеныНаБазовыйТип.ПроцентСкидкиНаценки /100)[/color]
    [color=black]		|						ИНАЧЕ ЕСТЬNULL(ЦенаПоДиапазону.Цена, 0.00)[/color]
    [color=black]		|				КОНЕЦ[/color]
    [color=black]		|			ИНАЧЕ ЕСТЬNULL(ЦеныНаБазовыйТип.Цена, 0.00)[/color]
    [color=black]		|	КОНЕЦ > 0[/color]
    [color=black]		|) КАК Цены[/color]
    [color=black]		|ПО[/color]
    [color=black]		|	Цены.Номенклатура = ХарактеристикиНоменклатуры.Владелец[/color]
    [color=black]		|	И Цены.ХарактеристикаНоменклатуры = ХарактеристикиНоменклатуры.Ссылка[/color]
    [color=black]		|"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|		ОБЪЕДИНИТЬ ВСЕ[/color]
    [color=black]				[/color]
    [color=black]		|		ВЫБРАТЬ[/color]
    [color=black]		|			ЗаказаныйТовар.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|			 "[/color] [color=red]+[/color] [color=red]?[/color][color=red]([/color]ОтображатьСклады[color=red],[/color][color=black]", "[/color][color=black]"НеВыводить"[/color][color=black]" КАК Склад, "[/color][color=black]"НеВыводить"[/color][color=black]" КАК МестоХранения "[/color][color=red],[/color][color=black]""[/color][color=red])[/color] [color=red]+[/color] [color=black]"[/color]
    [color=black]		|			, 0 КАК КоличествоОстаток[/color]
    [color=black]		|			, 0 КАК КоличествоСвободныйОстаток[/color]
    [color=black]		|			, 0 КАК КоличествоВРезерве[/color]
    [color=black]		|			, ЗаказаныйТовар.КоличествоОстаток КАК КоличествоСвободныйОстатокВЗаказахПоставщикам"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПолучатьЦены <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]			|	,[/color]
    [color=black]			|	0  КАК ФлагЦены,[/color]
    [color=black]			|	0 КАК Цена,[/color]
    [color=black]			|	0 КАК Валюта,[/color]
    [color=black]			|	0 КАК ЕдиницаЦены,[/color]
    [color=black]			|	0 КАК КурсВалюты,[/color]
    [color=black]			|	0 КАК КратностьВалюты,[/color]
    [color=black]			|	NULL КАК ТИПЦЕН"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|		ИЗ[/color]
    [color=black]		|			(ВЫБРАТЬ[/color]
    [color=black]		|				ЗаказыПоставщикамОстатки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры[/color]
    [color=black]		|				, СУММА(ЕСТЬNULL(ЗаказыПоставщикамОстатки.КоличествоОстаток, 0.00)[/color]
    [color=black]		|						-[/color]
    [color=black]		|						ЕСТЬNULL(РазмещениеЗаказовПокупателейОстатки.КоличествоОстаток,0.00)[/color]
    [color=black]		|				) 	КАК КоличествоОстаток[/color]
    [color=black]		|			ИЗ[/color]
    [color=black]		|				РегистрНакопления.ЗаказыПоставщикам.Остатки(, Номенклатура = &Номенклатура) КАК ЗаказыПоставщикамОстатки[/color]
    [color=black]		|			ЛЕВОЕ СОЕДИНЕНИЕ[/color]
    [color=black]		|				РегистрНакопления.РазмещениеЗаказовПокупателей.Остатки(, Номенклатура = &Номенклатура) КАК РазмещениеЗаказовПокупателейОстатки[/color]
    [color=black]		|			ПО[/color]
    [color=black]		|				РазмещениеЗаказовПокупателейОстатки.ЗаказПоставщику = ЗаказыПоставщикамОстатки.ЗаказПоставщику[/color]
    [color=black]		|				СГРУППИРОВАТЬ ПО ЗаказыПоставщикамОстатки.ХарактеристикаНоменклатуры[/color]
    [color=black]		|			) КАК ЗаказаныйТовар[/color]
    [color=black]		|		ГДЕ ЕСТЬNULL(ЗаказаныйТовар.КоличествоОстаток , 0.00) > 0[/color]
    [color=black]		|"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ОтображатьСклады <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|	УПОРЯДОЧИТЬ ПО[/color]
    [color=black]		|		ХарактеристикаНоменклатуры,[/color]
    [color=black]		|		Склад[/color]
    [color=black]		|		//,АдресныйСклад.Приоритет[/color]
    [color=black]		|	ИТОГИ 	СУММА(КоличествоСвободныйОстатокВЗаказахПоставщикам) ПО[/color]
    [color=black]		|	ХарактеристикаНоменклатуры,[/color]
    [color=black]		|	Склад,[/color]
    [color=black]		|	МестоХранения[/color]
    [color=black]		|"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе	</span>
    ТекстЗапроса [color=red]=[/color] ТекстЗапроса [color=red]+[/color] [color=black]"[/color]
    [color=black]		|	УПОРЯДОЧИТЬ ПО[/color]
    [color=black]		|		ХарактеристикаНоменклатуры, КоличествоСвободныйОстатокВЗаказахПоставщикам Убыв[/color]
    [color=black]		| "[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Запрос[color=red].[/color]Текст [color=red]=[/color] ТекстЗапроса[color=red];[/color]
    РезультатЗапроса [color=red]=[/color] Запрос[color=red].[/color]<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/выполнить')">Выполнить</span>[color=red]([/color][color=red])[/color][color=red];[/color]
    [color=green]// ничего не выбрали - нечего и обрабатывать[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> РезультатЗапроса[color=red].[/color]Пустой[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    СтрокаХарактеристика [color=red]=[/color] ДеревоОстатков[color=red].[/color]Строки[color=red].[/color]Добавить[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ОтображатьСклады <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    [color=green]// отображение результатов с итогами по Характеристикам и Складам[/color]
    ВыборкаХарактеристика [color=red]=[/color] РезультатЗапроса[color=red].[/color]Выбрать[color=red]([/color]ОбходРезультатаЗапроса[color=red].[/color]ПоГруппировкам[color=red],[/color] [color=black]"ХарактеристикаНоменклатуры"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> ВыборкаХарактеристика[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    СтрокаХарактеристика [color=red]=[/color] ДеревоОстатков[color=red].[/color]Строки[color=red].[/color]Добавить[color=red]([/color][color=red])[/color][color=red];[/color]
    ЗаполнитьХарактеристикуТовара[color=red]([/color]СтрокаХарактеристика[color=red],[/color] ВыборкаХарактеристика[color=red])[/color][color=red];[/color]
    
    ВыборкаСклад [color=red]=[/color] ВыборкаХарактеристика[color=red].[/color]Выбрать[color=red]([/color]ОбходРезультатаЗапроса[color=red].[/color]ПоГруппировкам[color=red],[/color] [color=black]"Склад"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">			Пока</span> ВыборкаСклад[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> ВыборкаСклад[color=red].[/color]Склад [color=red]=[/color] [color=black]"НеВыводить"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/продолжить')">					продолжить</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> ЗначениеЗаполнено[color=red]([/color]ВыборкаСклад[color=red].[/color]Склад[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрокаСклад [color=red]=[/color] СтрокаХарактеристика[color=red].[/color]Строки[color=red].[/color]Добавить[color=red]([/color][color=red])[/color][color=red];[/color]
    СтрокаСклад[color=red].[/color]ХарактеристикаСклад [color=red]=[/color] ВыборкаСклад[color=red].[/color]Склад[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    ПервыйПроходМестХранения [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/истина')">Истина</span>[color=red];[/color]
    
    ВыборкаМестаХранения [color=red]=[/color] ВыборкаСклад[color=red].[/color]Выбрать[color=red]([/color]ОбходРезультатаЗапроса[color=red].[/color]ПоГруппировкам[color=red],[/color] [color=black]"МестоХранения"[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">				Пока</span> ВыборкаМестаХранения[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> ПервыйПроходМестХранения <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВыборкаДетальных [color=red]=[/color] ВыборкаМестаХранения[color=red].[/color]Выбрать[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">						Если</span> ВыборкаДетальных[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    
    [color=green]// остатки везде одинаковые[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">							Если</span> ЗначениеЗаполнено[color=red]([/color]ВыборкаСклад[color=red].[/color]Склад[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ЗаполнитьПоляОстатков[color=red]([/color]СтрокаСклад[color=red],[/color] ВыборкаДетальных[color=red])[/color][color=red];[/color]
    
    [color=green]// для итогов еще более верхнего уровня дополняем суммы[/color]
    ДополнитьПоляОстатков[color=red]([/color]СтрокаХарактеристика[color=red],[/color] ВыборкаДетальных[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">							КонецЕсли</span>[color=red];[/color]
    
    [color=green]// в разрезе цен заполняем[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">							Если</span> ПолучатьЦены <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ЗаполнитьПоляСумм[color=red]([/color]СтрокаХарактеристика[color=red],[/color] ВыборкаДетальных[color=red],[/color] СписокЦенОстатков[color=red],[/color] КурсыВалют[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">								Пока</span> ВыборкаДетальных[color=red].[/color]Следующий[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">									Если</span> ПолучатьЦены <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ЗаполнитьПоляСумм[color=red]([/color]СтрокаХарактеристика[color=red],[/color] ВыборкаДетальных[color=red],[/color] СписокЦенОстатков[color=red],[/color] КурсыВалют[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">									КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">								КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">							КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">						КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> ЗначениеЗаполнено[color=red]([/color]ВыборкаМестаХранения[color=red].[/color]МестоХранения[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СтрокаСклад[color=red].[/color]МестоХранения [color=red]=[/color] [color=red]?[/color][color=red]([/color]ПустаяСтрока[color=red]([/color]СтрокаСклад[color=red].[/color]МестоХранения[color=red])[/color][color=red],[/color] [color=black]""[/color][color=red],[/color] СтрокаСклад[color=red].[/color]МестоХранения [color=red]+[/color] [color=black]"; "[/color][color=red])[/color] [color=red]+[/color] ВыборкаМестаХранения[color=red].[/color]МестоХранения[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    
    ПервыйПроходМестХранения [color=red]=[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/ложь')">Ложь</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">				КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">			КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Ина

Поделиться этой страницей