8.х Нужна обложка для кассовой книги

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем ГулЁна, 9 июл 2010.

  1. TopicStarter Overlay
    ГулЁна
    Offline

    ГулЁна

    Регистрация:
    9 июл 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Помогите пожалуйста,на 8.1 почти не пишу,но стараюсь ознакомиться! Буху нужно,чтобы обложка для кассовой книги выводилась каждый месяц!!!! :smile: Пробовала кое-что в модуле менять, получается не совсем то...Подскажите как это можно сделать... :unsure:
  2. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    Выкладывайте что именно надо, что пробовали, что получилось? будем помогать
  3. TopicStarter Overlay
    ГулЁна
    Offline

    ГулЁна

    Регистрация:
    9 июл 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Вобщем я тот код,который был написал для вывода обложки по концу года скопировала в то место,где выводится по концу месяц. Все вроде бы нормально, да количество листов считается как в конце года,а не как по концу месяца!!
    А код вот:
    Если (НачалоДня(КонецМесяца(ДатаЛиста)) = ДатаЛиста) Или
    (НачалоМесяца(ДатаЛиста) <> НачалоМесяца(ДатаКон)) Или
    (ПоследнийЛист <> 0) Тогда
    ОбластьЛистовЗаМесяцОтчет.Параметры.НадписьЛистовЗаМесяц = "Количество листов кассовой книги за месяц: " +ЛистовЗаМесяц;
    ДокументРезультат.Вывести(ОбластьЛистовЗаМесяцОтчет);
    ДокументРезультат.Присоединить(ОбластьЛистовЗаМесяцОтчет);
    // ВОТ ПРОВЕРЯЮ НЕ КОНЕЦ ЛИ ГОДА
    Если (НачалоДня(КонецГода(ДатаЛиста)) = ДатаЛиста) Или
    (НачалоГода(ДатаЛиста) <> НачалоГода(ДатаКон)) Или
    (ПоследнийЛист = 2) Тогда
    Г=1;
    КонецЕсли;
    //если не конец года будет,то выводим обложку
    Если Г <> 1 Тогда
    // Печать обложки и титульного листа
    Т1 = Новый ТабличныйДокумент;
    Макет1 = ПолучитьМакет("Обложка");
    ОбластьОбложка = Макет1.ПолучитьОбласть("Обложка");
    СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Организация);
    НазваниеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм");;
    ОбластьОбложка.Параметры.НазваниеОрганизации = НазваниеОрганизации;
    ОбластьОбложка.Параметры.НадписьОбложка = " на "+Формат(ДатаЛиста, "ДФ=ММ.yyyy") + " г.";
    ОбластьОбложка.Параметры.КодОКПО = СведенияОбОрганизации.КодПоОКПО;
    Т1.Вывести(ОбластьОбложка);
    Т1.ВывестиГоризонтальныйРазделительСтраниц();
    Т1.Вывести(ОбластьОбложка);
    // Последний лист кассовой книги
    Т1.ВывестиГоризонтальныйРазделительСтраниц();
    ОбластьПослДеньГода = Макет1.ПолучитьОбласть("ПослДеньГода");
    Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Организация, КонецДня(ДатаЛиста),);
    ОбластьПослДеньГода.Параметры.ГлБухгалтер = Руководители.ГлавныйБухгалтер;
    ОбластьПослДеньГода.Параметры.Руководитель = Руководители.Руководитель;
    ОбластьПослДеньГода.Параметры.РуководительДолжность = Руководители.РуководительДолжность;
    ОбластьПослДеньГода.Параметры.ЛистовЗаГод = ЛистовЗаГод;
    Т1.Вывести(ОбластьПослДеньГода);
    Т1.ОтображатьСетку = Ложь;
    Т1.ОтображатьЗаголовки = Ложь;
    Т1.Показать("Обложка и титульный лист кассовой книги","");
    КонецЕсли;
    КонецЕсли;
    //ВОТ ЕСЛИ НА САМОМ ДЕЛЕ КОНЕЦ ГОДА
    Если Г = 1 Тогда
    ОбластьЛистовЗаГодОтчет.Параметры.НадписьЛистовЗаГод = "Количество листов кассовой книги за год: " + ЛистовЗаГод;
    ДокументРезультат.Вывести(ОбластьЛистовЗаГодОтчет);
    ДокументРезультат.Присоединить(ОбластьЛистовЗаГодОтчет);
    // Печать обложки и титульного листа
    Т1 = Новый ТабличныйДокумент;
    Макет1 = ПолучитьМакет("Обложка");
    ОбластьОбложка = Макет1.ПолучитьОбласть("Обложка");
    СведенияОбОрганизации = УправлениеКонтактнойИнформацией.СведенияОЮрФизЛице(Организация);
    НазваниеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации, "НаименованиеДляПечатныхФорм");;
    ОбластьОбложка.Параметры.НазваниеОрганизации = НазваниеОрганизации;
    ОбластьОбложка.Параметры.НадписьОбложка = " на "+Формат(ДатаЛиста, "ДФ=yyyy") + " г.";
    ОбластьОбложка.Параметры.КодОКПО = СведенияОбОрганизации.КодПоОКПО;
    Т1.Вывести(ОбластьОбложка);
    Т1.ВывестиГоризонтальныйРазделительСтраниц();
    Т1.Вывести(ОбластьОбложка);
    // Последний лист кассовой книги
    Т1.ВывестиГоризонтальныйРазделительСтраниц();
    ОбластьПослДеньГода = Макет1.ПолучитьОбласть("ПослДеньГода");
    Руководители = РегламентированнаяОтчетность.ОтветственныеЛицаОрганизаций(Организация, КонецДня(ДатаЛиста),);
    ОбластьПослДеньГода.Параметры.ГлБухгалтер = Руководители.ГлавныйБухгалтер;
    ОбластьПослДеньГода.Параметры.Руководитель = Руководители.Руководитель;
    ОбластьПослДеньГода.Параметры.РуководительДолжность = Руководители.РуководительДолжность;
    ОбластьПослДеньГода.Параметры.ЛистовЗаГод = ЛистовЗаГод;
    Т1.Вывести(ОбластьПослДеньГода);
    Т1.ОтображатьСетку = Ложь;
    Т1.ОтображатьЗаголовки = Ложь;
    Т1.Показать("Обложка и титульный лист кассовой книги","");
    КонецЕсли;
  4. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    Это вы в каком объекте вносили и куда именно ? процедуру?
  5. TopicStarter Overlay
    ГулЁна
    Offline

    ГулЁна

    Регистрация:
    9 июл 2010
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Это часть модуля объекта Кассовая книга. В самом конце там такой код. Код-то работает,все хорошо, но нумерация страниц идет как по концу года, то есть если в июне формируем кассовую книгу,то уже не в обложке,а в самой кассовой книге нумерация страниц не с 1 начинается,а например у меня с 88....то есть это номер страница для книги по концу года. :unsure:

    Получается с обложкой я добилась своего....А вот чтобы нумерация листов в самой кассовой книге была с 1....это никак :smile:
  6. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Запускайте отладчий, и изучайте, и изучайте...

Поделиться этой страницей