7.7 нужен совет. зик(не типовая)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем fiskal, 29 апр 2010.

  1. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    ТЗ="";
    СуммаБезПроцента = глКВыплатеЗаПериод(Сотрудник,ДатаПериода, ЖурналЗарплата, , , Контекст,ТЗ);
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл
    //тут все что вам нужно
    КонецЦикла;
    
    
    Еще подсказать или подумаете?
  2. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    до меня не как не дойдет как из глфункции выташить то что мне нужно... в данном случае мне нужно из ф-и глКВыплатеЗаПериод выташить ужевыплачено. мы объявили ТЗ. далее мы вроде как из ф-и запращиваем ТЗ.. но в ф-и то мы не указывали тз.. что он возьмет?
    я запутался.. я чайник :)
    дальше то вроде должно быть так
    Код:
    [code]ТЗ="";
    СуммаБезПроцента = глКВыплатеЗаПериод(Сотрудник,ДатаПериода, ЖурналЗарплата, , , Контекст,ТЗ);
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл
    //тут все что вам нужно
    Если СуммаБезПроцента>тз.ужевыплачено Тогда
    СуммаБезПроцента=тз.ужевыплачено;
    КонецЕсли;
    КонецЦикла;
    
    но он не вытаскивает ужевылачено..
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В цикле еще нужно смотреть по источникам финансирования...
    Начислено-выплачено
  4. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    так у меня тз.. не видит ужевылачено (смотрю через отладчик) как достучаться до переменной ужевыплачено?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Под рукой нет щас вашей конфы (на работе) Но если память не изменяет такая переменная в ТЗ есть и она заполняется...
  6. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    немогу сообразить как сделать чтоб иф начислено совпадал с иф выплачено?
    поправте :)
    Код:
    ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл  
    Если (ТЗ.ПолучитьСтроку=тз.ужевыплачено) и (ЖурналЗарплата.ИсточникФинансирования=ИФ) Тогда
    Если СуммаБезПроцента>тз.ужевыплачено Тогда
    СуммаБезПроцента=тз.ужевыплачено;
    КонецЕсли; 
    
    КонецЕсли;
    КонецЦикла;
    
  7. TopicStarter Overlay
    fiskal
    Offline

    fiskal

    Регистрация:
    28 дек 2009
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    так и не добился результата.. :unsure:

    в ф-и формируется то что мне нужно а как из нее достать данные так и не понял.. через ТЗ не получается...
Похожие темы
  1. leskin
    Ответов:
    3
    Просмотров:
    1.121
  2. Dimka77
    Ответов:
    8
    Просмотров:
    755
  3. smitog
    Ответов:
    4
    Просмотров:
    548
Загрузка...

Поделиться этой страницей