8.х Нужен помощь

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Шурик_1985, 20 май 2011.

  1. TopicStarter Overlay
    Шурик_1985
    Offline

    Шурик_1985

    Регистрация:
    12 май 2011
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток!
    Не обходимо решить след задание:
    Позаботимся о следующем сервисе для пользователя:
    Допустим, он начинает выписывать ПКО для конкретного контрагента. А программа сразу подсказывает: сколько этот контрагент нам должен. Поэтому:
    При выборе контрагента в документе ПКО создать процедуру, которая проверит задолженность данной организации перед нами, и в случае, если та положительная, пропишет эту задолженность в поле «Сумма».


    Я создал в Документе ПКО Надпись "Долг" реквизит ДолгКон, ТипСтрока и конечнно же в Данных выбрал ДолгКон.
    в модуле документа прописал :
    Процедура ТоварыПриАктивизацииСтроки(Элемент)
    ОПКОЗадолжности = РегистрыНакопления.Задолжности;
    ТекТовар = Контрагент;
    ФильтрТов = Новый Структура();
    ФильтрТов.Вставить("Контрагент", ТекТовар);

    ТабОст = ОПКОЗадолжности.Остатки(Дата,ФильтрТов,"Контрагент", " ДолгСумма");

    ДолгКон = ? (ТабОст.Итого("ДоглСумма")=0,
    "Тек.ДолгКА: " + ТабОст.Итого("ДолгСумма"),
    ?(ТабОст.Итог("ДолгСумма")=0, "Долгов взаиморасчетов нет;",
    "Тек.ДоглМы: "+ТабОст.Итог("ДолгСумма")));

    КонецПроцедуры

    когда запускаю ПКО суммаДогла нет. нифига ничего непоказывает! что я нитак делаю помогите:?
  2. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Конфигурация какая? Пройдитесь отладчиком
  3. Vladius
    Offline

    Vladius Опытный в 1С

    Регистрация:
    10 ноя 2010
    Сообщения:
    663
    Симпатии:
    3
    Баллы:
    29
    Не знаю какая у Вас конфигурация но приведу пример.

    Допустим неоходимо при выборе менеджера проверять работает он или нет, в Вашем случае Вы будете проверять какая сумма у контрагента.


    Код:
    Процедура ОсновнойМенеджерПриИзменении(Элемент)
    Результат = ПроверитьРаботает(Объект.ОсновнойМенеджер);
    Если Не Результат Тогда
    Сообщить("Менеджер не работает!"); 
    КонецЕсли; 
    КонецПроцедуры
    
    
    Функция ПроверитьРаботает(Менеджер)
    Возврат Менеджер.Работающий;
    КонецФункции
    

Поделиться этой страницей