8.х Нумерация!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Romik, 21 ноя 2008.

  1. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Подскажи как сделать нумерация в файлике?
    Вывожу данные в xls файл....и нужно запонить колонку цифрами до количества строк

    Начало
    1
    2
    3
    4
    5
    и тд
    Конец
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Первое: правильно выбираете подфорум
    Второе: при выводе выводи и номер - в чем проблема-то?
  3. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Сори
    проблема решена!
  4. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Сори эта проблема ещё не решена,перепутал с другой:)
    При выводе выводить номер строки?
    Покаж пример..
  5. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Покажи как ты выводишь, какие данные. Так тебе не ответят
  6. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26

    Обычная нумерация..xls как в столбце 2,чтоб нумировалась до конца списка!
    (для примера смотри прикреплённый файл)

    Cтолбец1 Столбец2 Столбец 3
    Имя 1
    - 2
    - 3
    - 4
    - 5
  7. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Так как ты выводишь-то? Покажи код, наконец, некто телепатировать тут не будет
  8. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Дак обычно,файлик ведь прикрепил!

    Код:
     Область                              = Макет.ПолучитьОбласть("Строка");
    Область.Параметры.НомерРН            = Док.Номер;
    Область.Параметры.ИдБазы             = "***";
    Область.Параметры.ДатаНаклданой      = ПреобразованиеДатыВСтроку(Строка(Док.Дата));
    Область.Параметры.СуммаНакладной     = Док.СуммаДокумента;
    Область.Параметры.Контрагент         = Док.Контрагент;
    Область.Параметры.НомерНедели        = (НеделяГода(НачДата));
    
    Область.Параметры.НемерПП = ??? пронумировать
  9. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Перед циклом:
    Код:
    Н = 0;
    
    
    В цикле:
    Код:
    Н = Н + 1;
    Область.Параметры.НемерПП = Н;
    
    
    :unsure:

    Если быть еще более точным:
    Код:
    Область                              = Макет.ПолучитьОбласть("Строка");
    Н = 0;
    Для ... Цикл //Тут перебираешь строки таблицы, данные из которой надо вывести
    Н = Н + 1;
    Область.Параметры.НемерПП = Н;
    ...
    ТабДок.Вывести(Область);
    КонецЦикла;
    
  10. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26

    Так до конца и не понял..что мне нужно в цикле перебирать....
    Для Каждого ИЗ... Цикл
  11. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Задай вопрос корректно. Где прикрепленный файл?

    Я понял, что тебе надо пронумеровать строки в таблице.
  12. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Да мне нужно пронумировать строки в таблице...
    Файл не прикрепляется:(
    В общем структура таблицы простая....
    ИДБазя НомерПП
    *** 1
    2
    3

    Нужно столбец с параметром НомерПП пронумировать до конца данных..то есть до конца списка!

    Код:
    Область                              = Макет.ПолучитьОбласть("Строка");
    Н = 0;
    Для  Цикл
    Н = Н + 1;
    Область.Параметры.НомерПП            = Н; 
    
    Область.Параметры.НомерРН            = Док.Номер;
    Область.Параметры.ДатаНаклданой      = ПреобразованиеДатыВСтроку(Строка(Док.Дата));
    Область.Параметры.СуммаНакладной     = Док.СуммаДокумента;
    Область.Параметры.Контрагент            = Док.Контрагент;
    Область.Параметры.НомерНедели        = (НеделяГода(НачДата));
    
    
    
  13. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Выложи кусок процедуры от инициализации табличного документа до его отображения(то есть от ТабДок = Новый ТабличныйДокумент до ТабДок.Показать()).
  14. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Код:
    	ТабДок = Новый ТабличныйДокумент;		
    Макет = ПолучитьМакет("Макет");
    Область = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Область);
    Запрос=Новый Запрос;
    Штука = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("32");
    Запрос.УстановитьПараметр("НачДата",НачалоДня(НачДата));
    Запрос.УстановитьПараметр("КонДата",КонецДня(КонДата));
    Запрос.УстановитьПараметр("Штука",Штука);
    ТекстЗапроса=("ВЫБРАТЬ
    |	РеализацияТоваровУслугТовары.Ссылка КАК Док
    |ИЗ
    |	Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    |ГДЕ
    |	РеализацияТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачДата И &КонДата");
    
    ТекстЗапроса = ТекстЗапроса + " СГРУППИРОВАТЬ ПО Ссылка УПОРЯДОЧИТЬ ПО Ссылка.Дата";
    Запрос.Текст=ТекстЗапроса;
    РезультатЗапроса=Запрос.Выполнить();
    ТЗ = РезультатЗапроса.Выгрузить();
    Максимум = ТЗ.Количество();
    //ТЗ.ВыбратьСтроку();
    Выборка=РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий() Цикл
    ОбработкаПрерыванияПользователя();
    Док = Выборка.Док;
    
    ЗаписатьСтрокуВРеестрРН(ТабДок,Макет,Док,счНакладных);
    СписокВыгруженныхРН.Добавить(СокрЛП(Док.Номер));
    
    
    КонецЦикла;
    //сохранение в файл xls
    Путь = "C:\RN_w"+(НеделяГода(НачДата))+".xls";
    ТабДок.Записать(Путь,ТипФайлаТабличногоДокумента.XLS);
    
    
    Процедура ЗаписатьСтрокуВРеестрРН(ТабДок,Макет,Док,счРН)	
    
    Область                                          = Макет.ПолучитьОбласть("Строка");
    Область.Параметры.НомерРН            = Док.Номер;
    Область.Параметры.ИдБазы             = "***";
    Область.Параметры.ДатаНаклданой      = ПреобразованиеДатыВСтроку(Строка(Док.Дата));
    Область.Параметры.СуммаНакладной     = Док.СуммаДокумента;
    Область.Параметры.Контрагент         = Док.Контрагент;
    Область.Параметры.НомерНедели        = (НеделяГода(НачДата));
    
    ТабДок.Вывести(Область);
    
    КонецПроцедуры
    
    
    
  15. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Код:
    ТабДок = Новый ТабличныйДокумент;		
    Макет = ПолучитьМакет("Макет");
    Область = Макет.ПолучитьОбласть("Шапка");
    ТабДок.Вывести(Область);
    Запрос=Новый Запрос;
    Штука = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("32");
    Запрос.УстановитьПараметр("НачДата",НачалоДня(НачДата));
    Запрос.УстановитьПараметр("КонДата",КонецДня(КонДата));
    Запрос.УстановитьПараметр("Штука",Штука);
    ТекстЗапроса=("ВЫБРАТЬ
    |	РеализацияТоваровУслугТовары.Ссылка КАК Док
    |ИЗ
    |	Документ.РеализацияТоваровУслуг.Товары КАК РеализацияТоваровУслугТовары
    |ГДЕ
    |	РеализацияТоваровУслугТовары.Ссылка.Дата МЕЖДУ &НачДата И &КонДата");
    
    ТекстЗапроса = ТекстЗапроса + " СГРУППИРОВАТЬ ПО Ссылка УПОРЯДОЧИТЬ ПО Ссылка.Дата";
    Запрос.Текст=ТекстЗапроса;
    РезультатЗапроса=Запрос.Выполнить();
    ТЗ = РезультатЗапроса.Выгрузить();
    Максимум = ТЗ.Количество();
    //ТЗ.ВыбратьСтроку();
    
    Выборка=РезультатЗапроса.Выбрать();
    Область  = Макет.ПолучитьОбласть("Строка");
    Н = 0;
    Пока Выборка.Следующий() Цикл
    ОбработкаПрерыванияПользователя();
    Док = Выборка.Док;
    Н = Н +1;
    Область.Параметры.НомерПП = Н;
    Область.Параметры.НомерРН            = Док.Номер;
    Область.Параметры.ИдБазы             = "***";
    Область.Параметры.ДатаНаклданой      = ПреобразованиеДатыВСтроку(Строка(Док.Дата));
    Область.Параметры.СуммаНакладной     = Док.СуммаДокумента;
    Область.Параметры.Контрагент         = Док.Контрагент;
    Область.Параметры.НомерНедели        = (НеделяГода(НачДата));
    
    ТабДок.Вывести(Область);
    ЗаписатьСтрокуВРеестрРН(ТабДок,Макет,Док,счНакладных);
    СписокВыгруженныхРН.Добавить(СокрЛП(Док.Номер));
    
    
    КонецЦикла;
    //сохранение в файл xls
    Путь = "C:\RN_w"+(НеделяГода(НачДата))+".xls";
    ТабДок.Записать(Путь,ТипФайлаТабличногоДокумента.XLS);
    
    
    Нафига тебе лишняя процедура?? Или ты ее используешь еще откуда-то?
  16. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Уже не нужна,раньше использовал,так как в обработке осуществляю много разных реестров!
    Спасибо,сейчас испытаю:)
  17. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Всё гут чувак:)
    А ещё можешь подсказать как в запросе поставить уловие?
    Сейчас выводится все накладные,а мне нужно чтобы выходили накладные только лишь с определённым товаром....
  18. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    ГДЕ Номенклатура = &НужнаяНоменклатура - в запросе установи
  19. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Хм...такое непрокатит...мне же нужно несколько групп товаров,нужно наверное сначала найти список групп и потом установить условие?
  20. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    ГДЕ Номенклатура В ИЕРАРХИИ(&СписокГрупп)
Похожие темы
  1. кэт
    Ответов:
    1
    Просмотров:
    299
Загрузка...

Поделиться этой страницей