7.7 НовичЁк, вопрос.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем sharik987, 22 мар 2012.

  1. TopicStarter Overlay
    sharik987
    Offline

    sharik987

    Регистрация:
    14 ноя 2011
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Есть справочник товаров, в каждом товаре есть Перечисление единиц измерения (шт. , л. , м. и т.д.). В Перечислении я не смогу каждому значению (к примеру шт.) приписать код (к примеру 796). Если я создам Справочник Единиц измерения то мне придется прописывать ручками в каждом товаре по новой Единице измерения. - Возможно ли создать Справочник Единиц измерения, который бы заменил свои значения на такие же значения Перечисления в справочнике товаров?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Мыслите правильно.... Нужно создать Справочник ЕИ. И потом уже через внешнюю ОБРАБОТКУ присвоить этому реквизиту нужное значение... Работы мин на 5
  3. TopicStarter Overlay
    sharik987
    Offline

    sharik987

    Регистрация:
    14 ноя 2011
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Так...
    А внешнюю Обработку где достать? Или как называется? Я такую внешнею обработку сам создавать буду очень долго, больше 5 минут это точно.

    Вообще задача при распечатке новой счет фактуры поместить "Код единицы измерения", можно было бы в модуле прописать значение. Но боюсь что в будующем еще трудности возникнут. Лучше сразу переделать на Справочник.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    код приблизительно такой
    Код:
    Спр=СоздатьОбъект("Справочник.ВашСправочник");
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда //отсекли группы
    Продолжить;
    КонецЕсли;
    Если Спр.ВашРеквизитПеречисление=ПеречислениеКакРеквизиФормы Тогда
    Спр.НовыйРеквизитЕИ=РеквизитСправочникаЕИ;
    Спр.Записать();
    КонецЕсли;
    КонецЦикла;
    
    где
    ПеречислениеКакРеквизиФормы - реквизит формы типа перечисления ЕИ
    РеквизитСправочникаЕИ - реквизит формы типа нового справочника ЕИ
    ВашСправочник - вид справочника который подлежит "переработке"
    НовыйРеквизитЕИ - новый реквизит справочника ВашСправочник типа РеквизитСправочникаЕИ
  5. TopicStarter Overlay
    sharik987
    Offline

    sharik987

    Регистрация:
    14 ноя 2011
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо!

Поделиться этой страницей