7.7 Новая счет-фактура и страна Россия

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем admin, 5 апр 2012.

  1. TopicStarter Overlay
    admin
    Offline

    admin Опытный в 1С

    Регистрация:
    18 авг 2008
    Сообщения:
    129
    Симпатии:
    0
    Баллы:
    26
    Всем доброго времени суток !!! Помогите пожалуйста сделать, что бы в новой счет-фактуре поля "Страна
    происхождения товара" -> Цифровой код и Краткое наименование для товара со страной происхождения России и кодом 683 выводился прочерк. Заранее спасибо. счет-фактура для торговли 7.7(970 релиз)

    Вложения:

    • SF1137.ERT
      Размер файла:
      117,5 КБ
      Просмотров:
      34
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    [sub]а щаз чё выводится[/sub]

    [sub]поиском по МнЧ.СтранаН[/sub]
    [sub]замени [/sub]
    [sub]МнЧ.СтранаН="";[/sub]
    [sub]на[/sub]
    [sub]МнЧ.СтранаН="-";[/sub]

    [sub]далее поиском по МнЧ.СтранаК аналогично[/sub]
  3. TopicStarter Overlay
    admin
    Offline

    admin Опытный в 1С

    Регистрация:
    18 авг 2008
    Сообщения:
    129
    Симпатии:
    0
    Баллы:
    26
    Сейчас выводиться Россия, Китай, Германия. А нужно, что бы вместо Россия стоял "-"
  4. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    Найди в модуле обработки такой код
    Код:
     МнЧ.ВыбратьСтроки();
    Пока МнЧ.ПолучитьСтроку() = 1 Цикл
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    
    замени на этот код
    Код:
    МнЧ.ВыбратьСтроки();
    Пока МнЧ.ПолучитьСтроку() = 1 Цикл
    Если Найти(нрег(""+МнЧ.СтранаН),"россия")<>0 Тогда
    номС=МнЧ.НомерСтроки;
    МнЧ.УстановитьЗначение(номС,"СтранаК","-");
    МнЧ.УстановитьЗначение(номС,"СтранаН","-");
    КонецЕсли;
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    
  5. daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    вот проверь

    я немножко по другому сделал

    Вложения:

    • SF1137.ERT
      Размер файла:
      47,5 КБ
      Просмотров:
      53
  6. TopicStarter Overlay
    admin
    Offline

    admin Опытный в 1С

    Регистрация:
    18 авг 2008
    Сообщения:
    129
    Симпатии:
    0
    Баллы:
    26
    Спасибо.работает и первый и второй вариант

Поделиться этой страницей