[РЕШЕНО] Номер счета фактуры

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем Golemchik, 13 апр 2015.

  1. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    Добрый день, счета фактуры были закинуты из Ут в Бухгалтерию 3.0. Возникли касяк у счет фактуры.
    Предположим в УТ номер счета фактуры Д0000000000215 при печати выводится номер сф 215,
    а при печати из БП печатает номер сф Д0000000000215. Можно ли что - нибудь сделать с этим?
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    А префиксы в базах совпадают ?
  3. TerANik
    Offline

    TerANik Профессионал в 1С

    Регистрация:
    19 ноя 2014
    Сообщения:
    997
    Симпатии:
    70
    Баллы:
    54
    А касяк в чем? в том что совпадают?

    А сообразил.. Выводит без префикса и начальных нулей.

    Так сами номера документов нормальные? т.е. совпадают? Тогда смотреть почему УТ выводит без префикса.
    Последнее редактирование: 13 апр 2015
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    Ну в УТ и типовых есть специальная функция в общих модулях типа получитьНомерНапечать
    Вот ее и используют
    В Бух может нет
  5. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    касяк в том, что при печати сф у нас в бухгалтерии номер сф не совпадает с номером сф в ут, а это неправильно. Вопрос можно ли научить БП 3,0 не замечать префикса и нулей?
    --- Объединение сообщений, 13 апр 2015 ---
    и да префиксы совпадают
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    Ну напишите внешнюю печатную форму и все. - поставьте ее основной
  7. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    а не программисту, что нибудь реально сделать?
  8. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    ну под рукой БП 3 нет - надо где нить в настройках посмотреть, либо уже по коду самой печатной формы - есть там вариант или нет
  9. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    может у кого есть под рукой?
  10. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    вопрос по программированию, может кто поможет. Обработку напишу. Как из номера счет фактуры убрать первый символ?
    предположим начало -
    Код:
    d = Д0000000000215;
    
    как сделать переменную "d" равную 0000000000215?
  11. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.647
    Симпатии:
    948
    Баллы:
    204
    В типовых есть вот такая фукнция, передаете туда ссылку на документ и возвращает обрезаный номер
    Код:
    Функция ПолучитьНомерНаПечать(Документ, МассивПрефиксов = Неопределено) Экспорт
    
        Если Документ = Неопределено Тогда
            Возврат 0;
        КонецЕсли;
    
        Номер   = СокрЛП(Документ.Номер);
        Префикс = "";
        Если МассивПрефиксов = Неопределено Тогда
           
            Организация = Неопределено;
           
            Если ТипЗнч(Документ) = Тип("ВыборкаИзРезультатаЗапроса")
                ИЛИ ТипЗнч(Документ) = Тип("Структура") Тогда
    
                Организация = Документ.Организация;
               
            Иначе
    
                МетаданныеДокумента = Документ.Метаданные();
    
                Если МетаданныеДокумента.Реквизиты.Найти("Организация") <> Неопределено Тогда
    
                    Организация = Документ.Организация;
    
                КонецЕсли;
    
            КонецЕсли;
           
            МассивПрефиксовДляОбхода = СформироватьМассивПрефиксовДляРИБИОрганизации(Организация)
           
        Иначе
           
            МассивПрефиксовДляОбхода = МассивПрефиксов;
           
        КонецЕсли;
       
        Для Каждого ТекущийПрефикс ИЗ МассивПрефиксовДляОбхода Цикл
           
            // удаление префикса из номера документа
            Если Найти(Номер, ТекущийПрефикс)=1 Тогда
                Номер = Сред(Номер, СтрДлина(ТекущийПрефикс)+1);
            КонецЕсли;
           
            // так же, может остаться "минус" впереди
            Если Лев(Номер, 1) = "-" Тогда
                Номер = Сред(Номер, 2);
            КонецЕсли;
           
            // удаление ведущих нулей
            Пока Лев(Номер, 1)="0" Цикл
                Номер = Сред(Номер, 2);
            КонецЦикла;
        КонецЦикла;
    
        Возврат Номер;
    
    КонецФункции // ПолучитьНомерНаПечать()
  12. TopicStarter Overlay
    Golemchik
    Offline

    Golemchik Опытный в 1С

    Регистрация:
    15 апр 2013
    Сообщения:
    254
    Симпатии:
    1
    Баллы:
    29
    все понял, большое спасибо
  13. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.781
    Симпатии:
    509
    Баллы:
    204
    Теперь понимаете для чего я про префиксы спросил :))))

Поделиться этой страницей