8.х Незнаю как объявить массив глобальным

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Fanatic, 8 май 2009.

  1. TopicStarter Overlay
    Fanatic
    Offline

    Fanatic

    Регистрация:
    12 мар 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Незнаю как объявить массив глобальным?

    с переменной все понятно...

    Перем ляля;
    Процедура первая()
    // и мы и отсюда увидим переменную
    КонецПроцедуры

    Процедура вторая()
    // и отсюда тоже увидим
    КонецПроцедуры

    А вот с массивом как?
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    ляля = новый массив;
    
    в том месте где он будет заполняться.
  3. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Код:
    Перем ляля;
    Процедура первая()
    // и мы и отсюда увидим переменную
    ляля = Новый Массив;
    КонецПроцедуры
    
    Процедура вторая()
    // и отсюда тоже увидим
    ляля.Добавить("ля ля ля!");
    КонецПроцедуры 
    
    Главное, чтобы первая() вызывалась и инициализировала переменную до вызова вторая().
  4. TopicStarter Overlay
    Fanatic
    Offline

    Fanatic

    Регистрация:
    12 мар 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1

    У меня так и есть, но все равно я невижу массив во второй процедуре.
  5. TopicStarter Overlay
    Fanatic
    Offline

    Fanatic

    Регистрация:
    12 мар 2009
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1

    Извиняюсь... все получалось...
    Тема закрыта...

Поделиться этой страницей