8.х УТ НЕуникальность штрих-кода документов «Реализация товаров и услуг»

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем derxander, 5 сен 2013.

  1. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток, товарищи!

    1С 8.2 УТ 10.3.. Две организации в ИБ, работа с ними идет параллельно.. Кто сталкивался с такой ерундистикой? - Один и тот же штрих-код присваевается двум разным документам РТиУ, документы эти могут быть и с одной организации, и с разных.. время тоже "скачет".. Кстати, у всех так или только у нас - коды присваиваются не в хронологическом порядке?.. т.е. если сделать сортировку по дате создания документа, то колонка с штрих-кодами "тусуется", и наоборот..

    Кто подскажет где копнуть, что избавиться от проблемы дублирования штрих-кодов? и почему хронология документов не соответствует порядковым номерам штрих-кодов?

    [​IMG]
  2. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.174
    Симпатии:
    13
    Баллы:
    29
    в типовой УТ у документов есть ШК ????
  3. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    не уверен.. мне конфигурация досталась такой какая она есть, и что с ней делали ДО, - я не в курсе..
  4. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    оператор сидит и под вечер сканирует накладные эти.. по штрихкодам определенным накладным присваевает статус «отгружен» и статус «оплачено» товарам в доках РТиУ.. и вот изза этих дублирований статусы присваиваются только тем докам до чьих штрих-кодов добирается первым.. а второй документ с таким же штрих-кодом остается нетронутым..
  5. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.174
    Симпатии:
    13
    Баллы:
    29
    я делал так - шк отдельно не хранил, а брал ГУИД документа, убирал дефисы, и его печатал.
  6. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    т.е. выход - это печать штрихкода, в котором цифры и полосы генерируются не последовательно (хотя в моем случае это не совсем работало), а в соответствии с УИД документа?
  7. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    ну, в принципе у меня штрих код генерируется по такой системе
    Код:
    Процедура СформироватьШК() Экспорт
    Ном = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глЗначениеПеременной("глТекущийПользователь"),"НомерОператора");  //АВ
    //Сообщить(Ном);
    вШтрихкод         = "";
    НеНашлиУникальный = Истина;
    Префикс           = "25"+Ном;
    Постфикс          = "00";
    Сч = 0;
    ТекКод = УдалитьСимволы(Номер);
    Пока НеНашлиУникальный Цикл
    ТекКод = Число(ТекКод)+Сч;
    ТекКод = СтрЗаменить(ТекКод,Символы.НПП,"");
    ТекКод = ""+ТекКод;
    Пока СтрДлина(ТекКод)<7 Цикл
    ТекКод = "0"+ТекКод;
    КонецЦикла;
    вШтрихкод          = Префикс + ТекКод + Постфикс;
    НеНашлиУникальный  = ПроверитьУникальностьШтрихКодаРеализации(вШтрихКод);
    Сч = Сч+1;
    КонецЦикла;
    ШтрихКод = вШтрихКод;
    КонецПроцедуры
    [​IMG]

    не понятно почему в некоторых случаях код присвается неверный..
    и не понятно почему и эта штука не срабатывает
    Код:
     НеНашлиУникальный  = ПроверитьУникальностьШтрихКодаРеализации(вШтрихКод);
  8. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    не пойму как код генерируется..
    выражение такое
    Код:
    вШтрихкод		  = Префикс + ТекКод + Постфикс;
    префикс я нахожу в ШК, ТекКод - я не понимаю как строится, а вот ПостФикса не вижу.. кто объяснит?
  9. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    если у вас 2 одинаковых штрихкода, значит как минимум несколько пользователей зашли под одним оператором.

    ведь префикс уникальный для каждого оператора..
  10. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    впринципе время от времени мониторю сессии по ИБ, не замечал там более одного гуманоидного существа, которые залогинились бы под одним логином, т.е. пользователем 1С..
    и кстати, как-то можно запретить множественные авторизации с одного 1с Пользователя ?
  11. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    очень интересно.. у всех штрих кодов одинаковый префикс, а операторов у нас не один.. не подскажете где выставляется префикс для операторов?
  12. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Префикс одинаковый возможно из-за неверных настроек пользователя: уникальный номер берут оттуда, но не факт что он есть. А ШК мог неверный появиться так: выбрали одну организацию в документе, сгенерили ШК, заменили организацию (в этот момент сбрасывается номер), а ШК остался тем же.

    Вариант с GUID как вам указали - наиболее приемлем
  13. TopicStarter Overlay
    derxander
    Offline

    derxander

    Регистрация:
    31 июл 2013
    Сообщения:
    19
    Симпатии:
    0
    Баллы:
    1
    ага, спасибо ) буду пробовать сделать по GUID

Поделиться этой страницей