7.7 Нет галочки

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем igorekkrav, 30 мар 2011.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите при создание в ручную СФ в бух7.7 нет галочки попадать в книгу продаж. В чем может быть причина?Или нужно в ручную заводить и в книгу продаж?
  2. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура УстановкаФлажкаВключитьВКнигуПродаж()
    Если Форма.ВключатьВКнигуПродаж.Видимость()=1 Тогда
    Если Аванс = 1 Тогда
    ВключатьВКнигуПродаж = 1;
    
    ИначеЕсли НДСпоСтавкеНольПроцентов = 1 Тогда
    ВключатьВКнигуПродаж = 0;
    
    Иначе
    Если (Договор.Выбран() = 1) и (Договор.АвтоОбработкаНДС = 0) Тогда
    ВключатьВКнигуПродаж = 1;
    
    Иначе
    ВключатьВКнигуПродаж = 0;
    КонецЕсли;
    КонецЕсли;
    Иначе
    ВключатьВКнигуПродаж = 0;
    КонецЕсли;
    КонецПроцедуры // УстановкаФлажкаВключитьВКнигуПродаж()
    
    Вывод - Поставь у договора автообработку НДС
Похожие темы
  1. anton
    Ответов:
    10
    Просмотров:
    517
  2. ypalizokna
    Ответов:
    1
    Просмотров:
    528
Загрузка...

Поделиться этой страницей