8.х Нестандартная картинка в форме списка справочника

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем mai, 28 июл 2009.

  1. TopicStarter Overlay
    mai
    Offline

    mai

    Регистрация:
    4 авг 2008
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Казалось бы, все просто можно сделать, даже без программирования, только через конфигуратор:
    На форме списка иерархического справочника в правом табличном поле (ТП) для колонки Наименование сбросил флажок ОтображатьСтандартнуюКартинку, задал КартинкиСтрок - Библиотека иконок наименований из Общих картинок, добавил в ТП колонку КартинкиСтрок, ввел в нее (не для всех строк) номера картинок из Библиотеки иконок наименований и все. Должно бы работать. Но не работает :)

    Сделал дополнительно так:
    Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)
    ОформленияСтрок[0].Ячейки.Наименование.ОтображатьКартинку = истина;
    ОформленияСтрок[0].Ячейки.Наименование.ОтображатьФлажок = ложь;
    ОформленияСтрок[0].Ячейки.Наименование.ОтображатьТекст = Истина;
    КонецПроцедуры
    или так:
    Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ОформлениеСтроки.Ячейки.Наименование.ОтображатьКартинку = истина;
    ОформлениеСтроки.Ячейки.Наименование.ОтображатьФлажок = ложь;
    ОформлениеСтроки.Ячейки.Наименование.ОтображатьТекст = Истина;
    КонецПроцедуры
    Все равно не работает :unsure:
    Гуру, подскажите, пожалуйста, в чем может быть заковыка?
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    По моему - так:
    Код:
    Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    ОформлениеСтроки.Ячейки.Наименование.ОтображатьКартинку = истина;
    ОформлениеСтроки.Ячейки.Наименование.ОтображатьФлажок = ложь;
    ОформлениеСтроки.Ячейки.Наименование.ОтображатьТекст = Истина;
    ОформлениеСтроки.Ячейки.Наименование.Картинка = БиблиотекаКартинок.БизнесПроцесс;
    КонецПроцедуры
    
    
  3. TopicStarter Overlay
    mai
    Offline

    mai

    Регистрация:
    4 авг 2008
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Для каждой строки может быть своя картинка
  4. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    В данном случае ключевым является
    Код:
    ОформленiиеСтроки.Ячейки.Наименование.Картинка = ....
    
    Подразумевается задание каждой ячейки нужной картинки. Как именно будет получена картинка - уже Вам решать.
    Пример варианта реализации я приводил в http://www.1c-pro.ru/index.php?showtopc=18545&hl=

    Просто я например никогда не работал с библиотеками картинок, как то мне всегда хватало одной картинки в кажой общей картинке...

Поделиться этой страницей