8.х Несоответствие типов (параметр номер '1')

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем algrib, 2 окт 2013.

  1. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте Гуру!
    Приступил к изучению Программирования в 1С 8.2, но не могу понять в чем ошибка

    Код:
    Запрос = новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Дата
    |ИЗ
    | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |ГДЕ
    |   РеализацияТоваровУслуг.Дата МЕЖДУ &ДатаНач И &ДатаКонец ";
    Если Не ЗначениеЗаполнено(ДатаНач) или Не ЗначениеЗаполнено(ДатаКонец) Тогда
    Сообщить("Заполните период!");
    возврат;
    Иначе
    Запрос.УстановитьПараметр("ДатаНач",ДатаНач);
    Запрос.УстановитьПараметр("ДатаКонец",ДатаКонец);
    КонецЕсли;
    
    Результат = Запрос.Выполнить();
    Документы.РеализацияТоваровУслуг.ПолучитьДанныеВыбора (Результат.Выгрузить());
    Собственно выскакивает ошибка Документы.РеализацияТоваровУслуг.ПолучитьДанныеВыбора (Результат.Выгрузить());
    по причине:
    Несоответствие типов (параметр номер '1')

    Пытаюсь отфильтровать документы за период и вывести их в поле.

    Спасибо
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    внимательно изучаем типы параметров, передаваемых внутрь метода
    а у вас Результат.Выгрузить() вернут таблицу значений, потому и не соответствие типов
  3. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Тогда что же мне использовать что бы выгрузить выбранные документы за период?
  4. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Куда выгрузить?
  5. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    В таблицу значений. В форме
  6. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Вам же в конкретный какой то документ в его ТЧ выгрузить? Где на него ссылка? у ТЗ есть метод Загрузить()
  7. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Код:
    Запрос = новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Ссылка
    |ИЗ
    | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |ГДЕ
    | РеализацияТоваровУслуг.Дата МЕЖДУ &ДатаНач И &ДатаКонец";
    
    Если Не ЗначениеЗаполнено(ДатаНач) или Не ЗначениеЗаполнено(ДатаКонец) Тогда
    Сообщить("Заполните период!");
    возврат;
    Иначе
    Запрос.УстановитьПараметр("ДатаНач",ДатаНач);
    Запрос.УстановитьПараметр("ДатаКонец",ДатаКонец);
    КонецЕсли;
    
    Результат = Запрос.Выполнить();
    // Документы.РеализацияТоваровУслуг.ПолучитьСсылку () ;
    
    Со ссылкой догадался, поправил. Не пойму как быть с последней строкой.
  8. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Это обработка. Нужно выбрать документы за период и выбранные поместить в Таблицу значений обработки
  9. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Код:
    ТаблицаЗначений.Загрузить(Резултат.Выгрузить()):
    но колонки таблиц будут сопоставлены по названию, так что будьте внимательны
  10. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Я понял свою проблему. Я не добавил табличную часть, собственно и показывать было не куда. Теперь так
    Код:
    Запрос = новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | РеализацияТоваровУслуг.Ссылка
    |ИЗ
    | Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |ГДЕ
    | РеализацияТоваровУслуг.Дата МЕЖДУ &ДатаНач И &ДатаКонец";
    
    Если Не ЗначениеЗаполнено(ДатаНач) или Не ЗначениеЗаполнено(ДатаКонец) Тогда
    Сообщить("Заполните период!");
    возврат;
    Иначе
    Запрос.УстановитьПараметр("ДатаНач",ДатаНач);
    Запрос.УстановитьПараметр("ДатаКонец",ДатаКонец);
    КонецЕсли;
    
    Результат = Запрос.Выполнить();
    РеализацияТоваровУслуг.Загрузить (Результат.Выгрузить()) ;
    Но результат пустой. Чего-то не хватает...
  11. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    как называется колонка в вашей таб части?
  12. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Ссылка
  13. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    А тип у нее какой?
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    отладчиком пользоваться умеете? установите точку остановки на строку
    Код:
    Результат = Запрос.Выполнить();
    и в табло наберите
    Код:
    Результат.Выгрузить.Колисчество()
    если с отладчком беда, то добавьте в код
    Код:
    Результат = Запрос.Выполнить();
    Сообщить(Результат.Выгрузить().Колиество());
    РеализацияТоваровУслуг.Загрузить (Результат.Выгрузить());
    если вернет 0, то смотрите ваш запрос, может с датами чего не то?

    +1 реально тип должен быть ДокументСсылка.РеализацияТоваровИУслуг - примерно так
  15. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Была ссылка, поправил на ДокументСсылка.РеализацияТоваровУслуг Пока безрезультатно. Документов выгружено 422...
  16. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    что значит была ссылка? название не меняйте тип надо задать колонке, скрин из конфигуратора можете выложить?
  17. TopicStarter Overlay
    algrib
    Offline

    algrib

    Регистрация:
    16 авг 2006
    Сообщения:
    12
    Симпатии:
    0
    Баллы:
    1
    Спасибо, разобрался.

Поделиться этой страницей