7.7 Несколько вопросов про формы и не только

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем ChekFedor, 26 сен 2007.

  1. TopicStarter Overlay
    ChekFedor
    Offline

    ChekFedor

    Регистрация:
    27 авг 2007
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Доброго времени суток. Проблема в следующем (если не считать кривые руки) есть форма ТОРГ-12 (не знаю это стандартная или написаная на заказ).
    Нужно поменять реквезиты Грузоотпровителя....Получателя и т.д.
    Формат
    Грузоотпровитель: <АдресГрузоотпровителя>
    Я так полагаю, что нужно просто добавить новый контрагент и использовать его при формировании печатной формы. Почему не добавляются ИНН и КПП в надпись?

    ...Иначе
    Таб.ИсходнаяТаблица("ТОРГ-12");
    КонецЕсли;

    // формирование адреса поставщика
    ОрганизацияАдрес = СокрЛП(Константа.НазваниеОрганизации);
    глДобавитьРеквизит(ОрганизацияАдрес, ", ", глПредставлениеАдреса(Константа.АдресОрганизации));
    глДобавитьРеквизит(ОрганизацияАдрес, ", тел. : ", Константа.ТелефоныОрганизации);
    Если РасчетныйСчет.Выбран() = 1 Тогда
    глДобавитьРеквизит(ОрганизацияАдрес, ", р/с ", СокрЛП(РасчетныйСчет.Номер) + " в " + РасчетныйСчет.БанкОрганизации);
    глДобавитьРеквизит(ОрганизацияАдрес, ", БИК ", СокрЛП(РасчетныйСчет.БанкОрганизации.Код));
    глДобавитьРеквизит(ОрганизацияАдрес, ", корр/с ", РасчетныйСчет.БанкОрганизации.КоррСчет);
    КонецЕсли;

    // формирование адреса грузоотправителя
    Если ПустоеЗначение(Грузоотправитель) = 1 Тогда
    ГрузоотправительАдрес = ОрганизацияАдрес;

    Иначе
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузоотправитель);
    ГрузоотправительАдрес = СокрЛП(Грузоотправитель.ПолнНаименование)+", "+СокрЛП(Грузоотправитель.ЮридическийАдрес)+", тел: "+СокрЛП(Грузоотправитель.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузоотправительАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузоотправительАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузоотправительАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    КонецЕсли;

    ПредставлениеГода = Лев(ДатаГод(ДатаДок),2);

    // формирование адреса плательщика
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Контрагент);

    //КонтрагентАдрес = СокрЛП(Контрагент.ПолнНаименование)+", "+СокрЛП(Контрагент.ЮридическийАдрес)+", тел: "+СокрЛП(Контрагент.Телефоны);
    КонтрагентАдрес = СокрЛП(Контрагент.ПолнНаименование)+", "+СокрЛП(Контрагент.ЮридическийАдрес)+", тел: "+СокрЛП(Контрагент.Телефоны);

    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(КонтрагентАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(КонтрагентАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(КонтрагентАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;

    // формирование адреса грузополучателя
    Если ПустоеЗначение(Грузополучатель) = 1 Тогда
    ГрузополучательАдрес = СокрЛП(Контрагент.ПолнНаименование)+", "+СокрЛП(Контрагент.ПочтовыйАдрес) +", тел: "+СокрЛП(Контрагент.Телефоны);//КонтрагентАдрес;

    Иначе
    СчетКонтрагента = "";
    СчетКонтрагента = глРасчетныйСчетКонтрагента(Грузополучатель);
    ГрузополучательАдрес = СокрЛП(Грузополучатель.ПолнНаименование)+", "+СокрЛП(Грузополучатель.ПочтовыйАдрес)+", тел: "+СокрЛП(Грузополучатель.Телефоны);
    Если ПустоеЗначение(СчетКонтрагента) = 0 Тогда
    глДобавитьРеквизит(ГрузополучательАдрес, ", р/с ", СокрЛП(СчетКонтрагента.Номер) + " в " + СчетКонтрагента.БанкОрганизации);
    глДобавитьРеквизит(ГрузополучательАдрес, ", БИК ", СокрЛП(СчетКонтрагента.БанкОрганизации.Код));
    глДобавитьРеквизит(ГрузополучательАдрес, ", корр/с ", СчетКонтрагента.БанкОрганизации.КоррСчет);
    КонецЕсли;
    КонецЕсли;

    Также изменить форму путем добавление надписей
    Если я это проделая под определенным пользователем изменения каснутся всех или только того под кем я это сделал?
    База общая, SQL
    Как сделать чтобы изменениями пользовался только один пользователь? Создавать отдельную таблицу или...?
    Заранее, всем огромное спасибо.

Поделиться этой страницей