8.х Неправильно отражается ОНА на убыток текущего периода

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем RIJIK, 14 окт 2008.

  1. TopicStarter Overlay
    RIJIK
    Offline

    RIJIK

    Регистрация:
    20 июн 2008
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    При проведении документа Закрытие месяца за Январь 2008 Формируются проводки по погашению ОНА. При том что в текущем периоде убыток и по БУ и по НУ и ОНА должна начисляться а не погашаться! Залез в модуль закрытия месяца и там увмдел в процедуре РассчитатьОНАПоУбыткаТекущегоПериода

    Код:
    Процедура РассчитатьОНАПоУбыткамТекущегоПериода(СтрокаВидАктиваОбязательства)
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("НачалоМесяца",мНачГраница);
    Запрос.УстановитьПараметр("КонецМесяца", мКонГраница);
    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("СчетН99_01",  ПланыСчетов.Налоговый.ПрибылиИУбыткиБезНалогаНаПрибыль);
    Запрос.УстановитьПараметр("Счет99_01",   ПланыСчетов.Хозрасчетный.ПрибылиИУбыткиБезНалогаНаПрибыль);
    Запрос.УстановитьПараметр("Счет09",      ПланыСчетов.Хозрасчетный.ОтложенныеНалоговыеАктивы);
    Запрос.УстановитьПараметр("Субконто1",   Перечисления.ВидыАктивовИОбязательств.УбытокТекущегоПериода);
    Запрос.УстановитьПараметр("Субконто2",   Перечисления.ВидыАктивовИОбязательств.РасходыБудущихПериодов);
    Запрос.УстановитьПараметр("ВидУчета",    Перечисления.ВидыУчетаПоПБУ18.НУ);
    
    Запрос.Текст = "ВЫБРАТЬ
    |    НалоговыйОстатки.СуммаОстатокДт КАК УбытокНУ,
    |    0 КАК УбытокБУ,
    |    0 КАК СуммаОстаток09
    |ИЗ
    |    РегистрБухгалтерии.Налоговый.Остатки(
    |            &КонецМесяца,
    |            Счет В ИЕРАРХИИ (&СчетН99_01),
    |            ,
    |            Организация = &Организация
    |                И ВидУчета = &ВидУчета) КАК НалоговыйОстатки
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    0,
    |    ХозрасчетныйОстатки.СуммаОстатокДт,
    |    0
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецМесяца, Счет В ИЕРАРХИИ (&Счет99_01), , Организация = &Организация) КАК ХозрасчетныйОстатки
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    0,
    |    0,
    |    ХозрасчетныйОстатки.СуммаОстатокДт
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.Остатки(&КонецМесяца, Счет В ИЕРАРХИИ (&Счет09), , Организация = &Организация) КАК ХозрасчетныйОстатки
    |ГДЕ
    |    ХозрасчетныйОстатки.Субконто1 = &Субконто1
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    |    0,
    |    0,
    |    ХозрасчетныйОборотыДтКт.СуммаОборот
    |ИЗ
    |    РегистрБухгалтерии.Хозрасчетный.ОборотыДтКт(
    |            &НачалоМесяца,
    |            &КонецМесяца,
    |            Месяц,
    |            СчетДт В ИЕРАРХИИ (&Счет09),
    |            ,
    |            СчетКт В ИЕРАРХИИ (&Счет09),
    |            ,
    |            Организация = &Организация
    |                И СубконтоДт1 = &Субконто2
    |                И СубконтоКт1 = &Субконто1) КАК ХозрасчетныйОборотыДтКт";
    Результат = Запрос.Выполнить();
    
    ТаблицаРезультат     = Результат.Выгрузить();
    [color=#FF0000]Сумма    = ТаблицаРезультат.Итог("УбытокНУ") * мСтавкаНалогаНаПрибыль - ТаблицаРезультат.Итог("СуммаОстаток09");    УбытокБУ = ТаблицаРезультат.Итог("УбытокБУ");
    
    СуммаДт77 = 0;
    СуммаКт77 = 0;
    СуммаДт09 = 0;
    СуммаКт09 = 0;
    
    Если Сумма > 0 Тогда
    СуммаДт09 = Сумма;
    Иначе
    СуммаКт09 =- Сумма;
    КонецЕсли;
    
    Если Сумма <> 0 Тогда
    ОтражениеОНАиОНО(СтрокаВидАктиваОбязательства.ВидАктивовОбязательств, Новый Структура("СуммаДт09, СуммаКт09, СуммаДт77, СуммаКт77, СуммаЕНВД", СуммаДт09, СуммаКт09, СуммаДт77, СуммаКт77, 0));
    КонецЕсли;
    
    КонецПроцедуры // ВременныеРазницыПоУбыткамТекущегоПериода()
    
    
    Непонятный алгоритм расчета, приче здесь остаток на 09 счете?
    Подскажите что это вообще может быть, если кто сталкивался...
    Чуть не забыл... Бухгалтерия предприятия 1.6.9.4
    Платформа 8.1.11.67

Поделиться этой страницей