7.7 Непонятный шаг в цикле

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Dmitrij, 4 авг 2011.

  1. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    Код:
    Процедура НайтиФизЛицо(Фамилия, Имя, Отчество, ДатаРож)
    ФизЛица=СоздатьОбъект("Справочник.икФизическиеЛица");
    ЛицСчет=СоздатьОбъект("Справочник.икЛицевыеСчета");
    Проживающие=СоздатьОбъект("Справочник.икПроживающие");
    ВрНаименование=Фамилия+""+Имя+""+Отчество;
    ФизЛицоДБФ=ВрНаименование;
    Проживающие.ВыбратьЭлементы(0);
    Пока Проживающие.ПолучитьЭлемент(0)=1 Цикл  
    ИзмНаименование=СтрЗаменить(СокрЛП(Проживающие.ФизЛицо.Наименование),"  ","");
    ИзмНаименование=СтрЗаменить(СокрЛП(Проживающие.ФизЛицо.Наименование)," ","");
    Если (ИзмНаименование=ВрНаименование) и (Проживающие.ФизЛицо.ДатаРождения=ДатаРож) Тогда
    ЛС=Проживающие.Владелец.Код; 
    ДБФ.NNN=ЛС;       
    ДБФ.Записать();
    НайтиЛьготы(Проживающие.Владелец);
    Иначе
    КонецЕсли;
    КонецЦикла;
    
    КонецПроцедуры
    
    Смотрю в отладчике когда попадаю в цикл на каждый шаг перем ИзмНаименование меняется, как так может быть?
  2. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    маленькое уточнение проживающие - это подчиненный справочник
  3. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
    Непонял, а зачем в цикле первая замена. Вторая строка делает всю работу....
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а почему она не должна меняться?
  5. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    цикл еще не закончен а данные уже изменились
  6. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а, вот в каком плане меняются - внутри 1 итерации?!
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    + постоянно идет идет обновление одной и той же записи ДБФ (добавить то где?)

Поделиться этой страницей