8.х ЗУП Непонятки с записью в регистр сведений

Тема в разделе ""1С:Зарплата и управление персоналом ЗУП"", создана пользователем Одинэснег, 16 окт 2015.

  1. TopicStarter Overlay
    Одинэснег
    Offline

    Одинэснег

    Регистрация:
    16 окт 2015
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    [​IMG] В конфе ЗУП 2.5 на платформе 8.3.5.1517

    Добавляю в регистр сведений ШтатноеРасписаниеОрганизаций дополнительный ресурс (КодКлетки), ставлю его на форму, задаю ему значение. После вызова процедуры ЗаполнитьТекущимСостоянием мой реквизит почему то остается незаполненным, хотя остальные значения записи измерений и ресурсов, переносятся.

    Даже более того, Закомментировал строку. После этого запускаю процедуру заполнения штатного расписания и получаю как на приложенной картинке! Ничего не понимаю как это работает
    Код:
    Процедура ДействияФормыЗаполнитьТекущимСостоянием(Кнопка)
    
    Если Организация.Пустая() Тогда
    Сообщить(ОбщегоНазначенияЗК.ПреобразоватьСтрокуИнтерфейса("Не указана организация!"));
    Возврат;
    КонецЕсли;
    
    Период = ОбщегоНазначенияЗК.ПолучитьРабочуюДату();
    Если Не ВвестиДату(Период, "Дата действия штатного расписания", ЧастиДаты.Дата) Тогда
    Возврат;
    КонецЕсли;
    
    ТекстВопроса = "Перед заполнением текущее штатное расписание на дату: " + Формат(Период, "ДФ=dd.MM.yyyy") + " будет обновлено. Продолжить?";
    Если Вопрос(ТекстВопроса, РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Нет Тогда
    Возврат;
    КонецЕсли;
    
    Набор = РегистрыСведений.ШтатноеРасписаниеОрганизаций.СоздатьНаборЗаписей();
    Набор.Отбор.Период.Значение = Период;
    Набор.Отбор.Период.Использование = Истина;
    
    Набор.Автозаполнение(Организация,Период);
    Если Набор.Количество() > 0 Тогда
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Организация", Организация);
    Запрос.УстановитьПараметр("Период", Период);
    Запрос.Текст =
    "ВЫБРАТЬ
    | ШтатноеРасписаниеОрганизаций.Период,
    | ШтатноеРасписаниеОрганизаций.ПодразделениеОрганизации,
    | ШтатноеРасписаниеОрганизаций.Должность,
    | ШтатноеРасписаниеОрганизаций.КоличествоСтавок,
    | ШтатноеРасписаниеОрганизаций.МинимальнаяТарифнаяСтавка,
    | ШтатноеРасписаниеОрганизаций.МаксимальнаяТарифнаяСтавка,
    | ШтатноеРасписаниеОрганизаций.ВидТарифнойСтавки,
    | ШтатноеРасписаниеОрганизаций.ГрафикРаботы,
    | ШтатноеРасписаниеОрганизаций.ВалютаТарифнойСтавки,
    | ШтатноеРасписаниеОрганизаций.ОсобыеУсловияТруда,
        | ШтатноеРасписаниеОрганизаций.КодКлетки,
    | ШтатноеРасписаниеОрганизаций.Категория
    |ИЗ
    | РегистрСведений.ШтатноеРасписаниеОрганизаций КАК ШтатноеРасписаниеОрганизаций
    |ГДЕ
    | ШтатноеРасписаниеОрганизаций.ПодразделениеОрганизации.Владелец <> &Организация
    | И ШтатноеРасписаниеОрганизаций.Период = &Период";
    
    Выборка = Запрос.Выполнить().Выбрать();
    Пока Выборка.Следующий() Цикл
        //ЗаполнитьЗначенияСвойств(Набор.Добавить(),Выборка);
    КонецЦикла;
    Набор.Записать(Истина);
    КонецЕсли;
    
    КонецПроцедуры
    https://disk.yandex.ru/client/disk|slider/disk/P1.png
    Последнее редактирование: 16 окт 2015
  2. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.634
    Симпатии:
    946
    Баллы:
    204
    картику к сообщению прикрепите через кнопку Загрузить

Поделиться этой страницей