8.х ОБМЕН Необходим совет по переходу с Бух-ии 7.7 на 8.2(8.3)

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Дмитрий1985, 9 авг 2013.

  1. TopicStarter Overlay
    Дмитрий1985
    Offline

    Дмитрий1985 Опытный в 1С

    Регистрация:
    25 фев 2013
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    Коллеги, возникла необходимость перевода с 7ой на 8ую версию бухгалтерии.
    7ка не совсем типовая. Немного "перепаханная".
    Поставил себе 8.3 Бухгалтерию на ПК.
    Выгрузка из нашей рабочей 7ки имеется- тоже стоит.
    Попробовал в 8ой версии перенос данных из информационной базы 7ки напрямую. Выдает ошибку- пишет: Возможно, с информационной базой работают пользователи. Перенос данных возможен только при наличии монопольного доступа к информационной базе, из которой выгружаются данные.


    Хотя в базе никто не сидит.

    Пробую через файл:
    Выдает ошибку:
    DOMDocument = СоздатьОбъект("Msxml2.DOMDocument.4.0");
    {C:\USERS\ADMINBUH\DESKTOP\BP\V77EXP.ERT(18355)}: Неудачная попытка создания объекта (Msxml2.DOMDocument.4.0)


    Но сразу скажу, что попытался на скорую руку и релиз у меня ниже 7.70.462.
    Т.к. конфа перепилена, то обновить целиком не успел ее до данного релиза, а решил попробовать так. Не пинайте.
    Последняя ошибка из-за релиза?

    И вот еще несколько вопросов:
    1. При проверке обработкой:
    ChkCode.ert выдается куча ошибок, т.к. в 7ке, допустим, в справочнике материалов в 7ке длинна кода 9 знаков а в 8ке.
    Т.е. получается следующее:
    000001607
    000016076
    имеют поле НовыйКод: 1607, т.к. берутся первые 4 значящих символа.
    Как быть с этим?

    2. Переносить планирую только справочники и остатки, т.к. документы у нас немного могут отличаться от типовой конфы количеством реквизитов, но еще уточню насколько отличаются.
  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    по ошибке с xml dom вам сюда

    по остальным
    1. перекодировать в 7-ке
    2. это правильно, в общем
  3. TopicStarter Overlay
    Дмитрий1985
    Offline

    Дмитрий1985 Опытный в 1С

    Регистрация:
    25 фев 2013
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    Ветеран, по п1. спасибо!
    П.С. Нужен человек, который окажет грамотные консультативные услуги по переводу с 7ки на 8ку. Именно консультации и поддержка, а не сделать за меня работу.
    Разумеется, готов материально вознаградить. Т.к. хочется детально разобраться в вопросе.
    Просьба писать в личку, кто имел опыт переноса не совсем типовой бухии.
  4. TopicStarter Overlay
    Дмитрий1985
    Offline

    Дмитрий1985 Опытный в 1С

    Регистрация:
    25 фев 2013
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    по указанной ссылке скачал файлы:

    msxml6.msi
    msxml6_ia64.msi
    msxml6_SDK.msi
    msxml6_x64.msi
    установил. все равно выдает ошибку:
    DOMDocument = СоздатьОбъект("Msxml2.DOMDocument.4.0");
    {C:\USERS\ADMINBUH\DESKTOP\BP\V77EXP.ERT(18355)}: Неудачная попытка создания объекта (Msxml2.DOMDocument.4.0)
    Что-то делаю не так?
    ОС: Windows 7 х64
  5. TopicStarter Overlay
    Дмитрий1985
    Offline

    Дмитрий1985 Опытный в 1С

    Регистрация:
    25 фев 2013
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    включив голову, понял, что
    Msxml2.DOMDocument.4.0
    надо поправить на:
    Msxml2.DOMDocument.6.0
    , ибо ставим все же 6ую версию:) пока на этом этапе затыков нет.
  6. TopicStarter Overlay
    Дмитрий1985
    Offline

    Дмитрий1985 Опытный в 1С

    Регистрация:
    25 фев 2013
    Сообщения:
    163
    Симпатии:
    0
    Баллы:
    26
    теперь при загрузке в 8ку выдает:

    Этап конвертации
    Описание ошибки
    Возможные причины, методы устранения Загрузка данных Не удалось определить программу-источник данных. Укажите корректный файл данных

    путь к файлу, куда выгружал указан верно.
    Что делать и куда копать?
    Возможно, проблема кроется где-то здесь?
    Это начало ХМЛ-файла:


    - <ФайлОбмена ВерсияФормата="2.0" ДатаВыгрузки="2013-08-13T09:46:49" НачалоПериодаВыгрузки="2013-01-01T00:00:00" ОкончаниеПериодаВыгрузки="2013-03-31T00:00:00" ИмяКонфигурацииИсточника="Бухгалтерский учет, редакция 4.5" ИмяКонфигурацииПриемника="БухгалтерияПредприятия" ИдПравилКонвертации="cfc979e2-6d82-4bce-b171-bbe8ade6c12b" Комментарий="">


    - <ПравилаОбмена ВерсияФормата="2.00" Ид="cfc979e2-6d82-4bce-b171-bbe8ade6c12b" Наименование="Бухгалтерский учета, ред. 4.5 --> Бухгалтерия предприятия, редакция 1.0" ДатаВремяСоздания="2005-01-21T09:49:49" Источник="Бухгалтерский учет, редакция 4.5" Приемник="БухгалтерияПредприятия">


    <ПослеЗагрузкиОбъекта>Если ИмяТипаОбъекта = "Справочник" ИЛИ ИмяТипаОбъекта = "ПланВидовХарактеристик" Тогда Если ЗначениеНеЗаполнено(Объект.Код) Тогда Объект.УстановитьНовыйКод(); КонецЕсли;ИначеЕсли ИмяТипаОбъекта = "Документ" Тогда Если ЗначениеНеЗаполнено(Объект.Номер) Тогда УстановитьНомерДокумента(Объект); КонецЕсли;КонецЕсли;</ПослеЗагрузкиОбъекта>

    - <ПравилаКонвертацииОбъектов>
  7. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    есть некоторое подозрение, что вы пользуетесь какими-то очень древними правилами обмена, ибо строчка "Бухгалтерский учета, ред. 4.5 --> Бухгалтерия предприятия, редакция 1.0" намекает, что у вас стоит как минимум Бухгалтерия предприятия 2.0, а возможно и 3.0

    бухгалтерия 7.7 обновлена до последней версии?

Поделиться этой страницей