7.7 Немогу вывести запрос в печатную форму

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем 4ndr3j, 7 фев 2012.

  1. TopicStarter Overlay
    4ndr3j
    Offline

    4ndr3j Новичок в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    13
    Симпатии:
    1
    Баллы:
    4
    Люди помогите, туплю не могу вывести запрос в печатную форму

    Код:
    //*******************************************
    // Процедура генерации запроса Сформировать.
    //
    Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Обрабатывать НеПомеченныеНаУдаление;
    |Без итогов;
    |ТекДок = Документ.РасходнаяНакладная.ТекущийДокумент;
    |Клиент = Документ.РасходнаяНакладная.Клиент;
    |Товар = Документ.РасходнаяНакладная.Товар.ТекущийЭлемент;
    |Количество = Документ.РасходнаяНакладная.Количество;
    |Цена = Документ.РасходнаяНакладная.Цена;
    |Скидка = Документ.РасходнаяНакладная.Скидка;
    |Группировка ТекДок;
    |Группировка Товар без упорядочивания без групп;
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли; 
    
    Запрос.Выгрузить(ТЗ);
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
    // Заполнение полей Сформировать
    Таб.ВывестиСекцию("Док");
    Сообщить("Группировка1");
    Пока Запрос.Группировка(2) = 1 Цикл
    Таб.ВывестиСекцию("Сформировать");
    Сообщить("Группировка2")
    КонецЦикла;
    КонецЦикла;
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
    КонецПроцедуры
    циклы по группировкам вообще не запускаются.
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Если указано Без итогов, то результат запроса будет "плоским" и номера (имени) группировки нет, она одна.
    Либо уберите Без итогов, либо используйте Запрос.Группировка().
  3. TopicStarter Overlay
    4ndr3j
    Offline

    4ndr3j Новичок в 1С

    Регистрация:
    1 фев 2012
    Сообщения:
    13
    Симпатии:
    1
    Баллы:
    4
    Вот спасибо
  4. vip6374
    Offline

    vip6374

    Регистрация:
    20 май 2006
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    ТекДок- лишнее
    Сделайте группировку Документ, это стандартная группировка, будет быстрее работать
    У Вас все переменные из одного документа
Похожие темы
  1. ATOLL
    Ответов:
    3
    Просмотров:
    1.175
  2. lumor
    Ответов:
    3
    Просмотров:
    1.976
  3. daab
    Ответов:
    15
    Просмотров:
    1.187
  4. Irbison
    Ответов:
    17
    Просмотров:
    2.497
  5. ExtreMe
    Ответов:
    16
    Просмотров:
    6.558
Загрузка...

Поделиться этой страницей