8.х Нельзя изменять поле, содержащее объект данных формы

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем eViLL, 11 дек 2014.

  1. TopicStarter Overlay
    eViLL
    Offline

    eViLL Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    264
    Симпатии:
    2
    Баллы:
    29
    Код:
    &НаСервере
    Процедура Пометить()
       
        Запрос = Новый Запрос;
        Запрос.Текст = "ВЫБРАТЬ
        |    ХозрасчетныйОстатки.Субконто1,
        |    ХозрасчетныйОстатки.Субконто2,
        |    ХозрасчетныйОстатки.Субконто3
        |ИЗ
        |    РегистрБухгалтерии.Хозрасчетный.Остатки КАК ХозрасчетныйОстатки";
       
        Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий() Цикл
            Если ЗначениеЗаполнено(Выборка.Субконто1) Тогда
                Ссылка = Выборка.Субконто1.Ссылка;
                Объект = Ссылка.ПолучитьОбъект();
                Объект.Переносить = Истина;
                Объект.Записать();
                Сообщить ("Субконто1 записано");
            КонецЕсли;
            Если ЗначениеЗаполнено(Выборка.Субконто2) Тогда
                Объект = Выборка.Субконто2.ПолучитьОбъект();
                Объект.Переносить = Истина;
                Объект.Записать();
                Сообщить ("Субконто2 записано");
            КонецЕсли;
            Если ЗначениеЗаполнено(Выборка.Субконто3) Тогда
                Объект = Выборка.Субконто3.ПолучитьОбъект();
                Объект.Переносить = Истина;
                Объект.Записать();
                Сообщить ("Субконто3 записано");
            КонецЕсли;
        КонецЦикла;
       
    КонецПроцедуры
    
    &НаКлиенте
    Процедура Команда1(Команда)
       
        Пометить();
       
    КонецПроцедуры;
    
    При попытке получить объект выбивает с ошибкой в заголовке. Извиняюсь за возможно глупый вопрос, я в управляемых формах не шарю. Как в них объект по ссылке получить?
  2. saha25
    Offline

    saha25 Опытный в 1С

    Регистрация:
    30 окт 2007
    Сообщения:
    95
    Симпатии:
    3
    Баллы:
    29
    Нужно переименовать переменную Объект т.к. в форме есть реквизит с таким же наименованием
    eViLL нравится это.
  3. KrivosheevEV
    Offline

    KrivosheevEV Новичок в 1С

    Регистрация:
    3 мар 2014
    Сообщения:
    35
    Симпатии:
    2
    Баллы:
    4
    Во всех получаемых субконто есть ссылка на объект?

Поделиться этой страницей