7.7 Неизвестная ошибка

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем vadim, 8 окт 2007.

  1. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    Есть обработка


    Перем ЗотКул,СпКул,СпТз,Текст,ч,м,с,дт,чч,мм,сс,заг,ттттт,ккккк;
    //*******************************************
    Процедура ПриОткрытии()
    Зот=СоздатьОбъект("Документ.ZОтчет");
    Сп=СоздатьОбъект("Документ.СписаниеПоZОтчету");
    Скл=СоздатьОбъект("Справочник.МестаХранения");
    Пр=СоздатьОбъект("Документ.ПриходнаяНакладная");
    Пр.ВыбратьДокументы(ТекущаяДата()-1,ТекущаяДата()-1);
    пр.ОбратныйПорядок(1);
    //Пока Пр.ПолучитьДокумент()=1 Цикл
    // Если Пр.ПометкаУдаления()=0 Тогда
    // Пр.ПолучитьВремя(ч,м,с);
    // КонецЕсли;
    //КонецЦикла;
    Пр.ПолучитьДокумент();
    Пр.ПолучитьВремя(ч,м,с);

    //
    ЗотКул=0;
    СпКул=0;
    СпТз=0;
    Зот.ВыбратьДокументы(ТекущаяДата()-1,ТекущаяДата()-1);
    Пока Зот.ПолучитьДокумент()=1 Цикл
    // Сообщить("Найден зот по "+Скл.НайтиПоНаименованию("Кулинарный отдел",0,1)+"");
    Если (СокрЛП(Строка(Зот.Склад))=СокрЛП("Кулинарный отдел")) И (Зот.Проведен()=1) Тогда
    ЗотКул=1;

    Сп.ВыбратьДокументы(ТекущаяДата()-1,ТекущаяДата()-1);
    Пока Сп.ПолучитьДокумент()=1 Цикл
    Если (СокрЛП(Строка(Сп.Склад))=СокрЛП("Кулинарный отдел")) И (Сп.Проведен()=1) Тогда
    СпКул=1;
    Иначе

    КонецЕсли;

    КонецЦикла;
    Иначе
    Сп.ВыбратьДокументы(ТекущаяДата()-1,ТекущаяДата()-1);
    Пока Сп.ПолучитьДокумент()=1 Цикл
    Сп.ПолучитьВремя(чч,мм,сс);
    Если ((СокрЛП(Строка(Сп.Склад))<СокрЛП("Торговый зал")) и (Сп.Проведен()=1)) и (((ч*3600)+(м*60)+с)<((чч*3600)+(мм*60)+сс)) Тогда
    // Сп.ПолучитьВремя(ч,м,с);
    СпТз=1;
    КонецЕсли;

    КонецЦикла;
    КонецЕсли;

    КонецЦикла;
    Если ЗотКул=0 Тогда
    СпКул=1;
    КонецЕсли;
    Если (СпКул=1) и (СпТз=1) Тогда
    Текст="ОСТАТКИ ЕСТЬ";
    Иначе
    Текст="списание не выполнено";
    КонецЕсли;
    дт=Строка(ТекущаяДата());
    // Сообщить(" ЗотКул="+ЗотКул+" СпКул="+СпКул+" СпТз="+СпТз+"");
    // Сообщить("времяПНК: "+ч+":"+м+":"+с+"");
    // Сообщить("время СП: "+чч+":"+мм+":"+сс+"");
    Сп.ВыбратьДокументы(ТекущаяДата(),ТекущаяДата());
    Пока сп.ПолучитьДокумент()=1 Цикл
    Если (СокрЛП(Строка(Сп.Склад))=СокрЛП("Торговый зал"))и(Сп.Проведен()=1) Тогда
    заг=Строка("текущие остатки:");
    ккккк=Строка("торговый зал: списание проведено");
    ИначеЕсли (СокрЛП(Строка(Сп.Склад))=СокрЛП("Кулинарный отдел"))и(Сп.Проведен()=1) Тогда
    заг=Строка("текущие остатки:");
    ттттт=Строка("кулинарный отдел: списание проведено");
    КонецЕсли;


    КонецЦикла;

    КонецПроцедуры



    раньше работала а потом начала выдавать ошибку вот такую
    Если ((СокрЛП(Строка(Сп.Склад))<СокрЛП("Торговый зал")) и (Сп.Проведен()=1)) и (((ч*3600)+(м*60)+с)<((чч*3600)+(мм*60)+сс)) Тогда
    {C:\DOCUMENTS AND SETTINGS\АДМИНИСТРАТОР.VOENVED.000\РАБОЧИЙ СТОЛ\12312.ERT(41)}: Операции сравнения на больше-меньше допустимы только над значениями совпадающих базовых типов (число, строка, дата)

    ПОМОГИТЕ КТО МОЖЕТ :unsure:
  2. Steel Rain
    Offline

    Steel Rain Опытный в 1С

    Регистрация:
    29 сен 2006
    Сообщения:
    408
    Симпатии:
    2
    Баллы:
    29
    Проверяйте через отладчик типы переменных ч, чч, мм, м, с, сс. Видимо не число туда сваливается. Или вообще значение не попадает.
  3. TopicStarter Overlay
    vadim
    Offline

    vadim Опытный в 1С

    Регистрация:
    31 июл 2007
    Сообщения:
    68
    Симпатии:
    0
    Баллы:
    26
    В тот день когда это случилось не стал разбераться а наследующий день все заработало!!!!! По каким причинам такое произошло впервые за 1-н год не понятно!!!!!!!! :unsure:

Поделиться этой страницей