8.х [NEED]обработка программного получения MAC-адреса машины

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем markin, 21 май 2007.

  1. TopicStarter Overlay
    markin
    Offline

    markin

    Регистрация:
    21 май 2007
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Может ли при этом помочь свойство глобального контекста ИмяКомпьютера() ?
    Какими средствами это можно сделать. Если кто-то поделится готовой обработкой или функцией, то буду очень признателен.
    Спасибо.
  2. Immortal
    Offline

    Immortal Опытный в 1С

    Регистрация:
    2 июл 2006
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    кури WMI .
  3. B@girusss
    Offline

    B@girusss Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    102
    Симпатии:
    0
    Баллы:
    26
    Рабочий пример определения MAC и IP адресов:

    MACAddress = "";
    ServicesSet = ПолучитьCOMОбъект("winmgmts:{impersonationLevel=impersonate}!\\" + ИмяКомпьютера +\root\cimv2");
    Items = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapter");
    Для каждого Item Из Items Цикл
    MACAddress = Item.MACAddress;
    КонецЦикла;

    Если MACAddress <> "" Тогда
    Сообщить (" Mac адрес: "+ MACAddress);
    Item = ServicesSet.ExecQuery("Select * From Win32_NetworkAdapterConfiguration");
    Для каждого Item Из Items Цикл
    Если Item.MACAddress = MACAddress Тогда
    Для каждого IPAddress Из Item.IPAddress Цикл
    Сообщить ("IP адрес: "+ IPAddress);
    КонецЦикла;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;

Поделиться этой страницей