8.х Недоступность ячейки в ТЧ документа...

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Тимон, 12 янв 2011.

  1. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    В ТЧ документа имеются колонки Приход,Расход,Отдел,Статья Доходов и Статья Расходов.При изменении прихода Расход обнуляется,СтатьяРасходов недоступна,при изменении Расхода соответственно наоборот...у меня получается сделать недоступной не ячейку строки,которую мы вводим,а вообще всю колонку через:

    Процедура ТЧПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    СтрокаТЧ=ЭлементыФормы.ТЧ.ТекущиеДанные;
    Если СтрокаТЧ.Приход>0 Тогда
    ЭлементыФормы.ТЧ.Колонки.Расход.Доступность=Истина;
    ЭлементыФормы.ТЧ.Колонки.СтатьяРасходов.Доступность=Ложь;
    ЭлементыФормы.ТЧ.Колонки.СтатьяДоходов.Доступность=Истина;
    ИначеЕсли СтрокаТЧ.Расход>0 Тогда
    ЭлементыФормы.ТЧ.Колонки.Приход.Доступность=Истина;
    ЭлементыФормы.ТЧ.Колонки.СтатьяРасходов.Доступность=Истина;
    ЭлементыФормы.ТЧ.Колонки.СтатьяДоходов.Доступность=Ложь;
    КонецЕсли;
    КонецПроцедуры


    Процедура ТЧПриходПриИзменении(Элемент)
    //СтрокаТЧ=ЭлементыФормы.ТЧ.ТекущиеДанные;
    СтрокаТЧ=ЭлементыФормы.ТЧ.ТекущаяСтрока;
    Если СтрокаТЧ.Приход>0 Тогда
    ЭлементыФормы.ТЧ.ИзменитьСтроку();
    СтрокаТЧ.Расход=0;
    СтрокаТЧ.СтатьяРасходов=0;
    ЭлементыФормы.ТЧ.Колонки.СтатьяРасходов.Доступность=Ложь;
    ЭлементыФормы.ТЧ.Колонки.СтатьяДоходов.Доступность=Истина;
    КонецЕсли;
    КонецПроцедуры

    Как мне прописать недопустимость ввода значения лишь в ячейку заполняемой строки?

    Вложения:

  2. cska-fanat-kz
    Offline

    cska-fanat-kz

    Регистрация:
    8 янв 2011
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Первое что пришло на ум...

    На если выше таблицы разместить поля ввода:

    СуммаПриходРасход - если положительное число, то приход, если отрицательное - расход

    СтатьяДохода
    СтатьяРасхода - разместить их один над другим и в событии СуммаПриходРасходПриИзменении менять видимость.

    КнопкаЗанести - добавить строку в ТЧ.


    Это так, "на подумать"...
  3. TopicStarter Overlay
    Тимон
    Offline

    Тимон Опытный в 1С

    Регистрация:
    30 ноя 2010
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26



    Спс,я уже использовал следующее:
    Процедура ТЧПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Если ДанныеСтроки.Приход>0 Тогда
    ОформлениеСтроки.Ячейки.Расход.ТолькоПросмотр=Ложь;
    ОформлениеСтроки.Ячейки.СтатьяРасходов.ТолькоПросмотр=Истина;
    ОформлениеСтроки.Ячейки.СтатьяДоходов.ТолькоПросмотр=Ложь;
    ИначеЕсли ДанныеСтроки.Расход>0 Тогда
    ОформлениеСтроки.Ячейки.Приход.ТолькоПросмотр=Ложь;
    ОформлениеСтроки.Ячейки.СтатьяРасходов.ТолькоПросмотр=Ложь;
    ОформлениеСтроки.Ячейки.СтатьяДоходов.ТолькоПросмотр=Истина;
    КонецЕсли;
    КонецПроцедуры
    заработало))

Поделиться этой страницей