7.7 Недостаточно Фактических параметров.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kyru6ka, 3 окт 2012.

  1. TopicStarter Overlay
    kyru6ka
    Offline

    kyru6ka

    Регистрация:
    3 окт 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Есть Функция по переводу числа в пропись, для печатной формы, но при её сформировании выдаёт "Недостаточно фактических параметров". Никак не могу понять в чём дело.

    Код:
    Функция ЧислоПрописью(СформироватьВесДокумента,ДП=1)
    
    Перем Возвр;
    Перем ЦелЧасть,ДробЧасть;
    Перем Дробная;
    Перем Окончание;
    Перем последнееСлово;
    
    ЦелЧасть=Цел(СформироватьВесДокумента);
    Дробчасть=окр(СформироватьВесДокумента-целЧасть,4);
    Возвр = "";
    Возвр=Возвр+?(ПустоеЗначение(ЦелЧасть) = 1, "Ноль", СокрЛП(Формат(ЦелЧасть, "ЧП")));
    Если ДробЧасть=0 тогда если дробчасть=окр(дробчасть,0)
    тогда дробчасть = 0; дробная = ""; ИначеЕсли Дробчасть = Окр(ДробЧасть, 1) тогда дробчасть=окр(ДробЧасть, 1)*10;
    Дробная="Десят" ИначеЕсли ДробЧасть = Окр(ДробЧасть,2) тогда ДробЧасть = Окр(ДробЧасть, 2)*100; Дробная="сот" ИначеЕсли ДробЧасть = Окр(ДробЧасть, 3) Тогда Дробчасть=ДробЧасть*1000;
    Дробная="Тысячн";
    Иначе ДробЧасть = ДробЧасть * 10000; Дробная = "Десятитысячн";
    КонецЕсли;
    
    
    ПоследнееСлово="";
    Окончание="";
    Пока(Возвр="") и (Возвр = СокрП(Возвр)) Цикл
    ПоследнееСлово=Прав(Возвр,1)+ПоследнееСлово;
    Возвр = Лев(Возвр, СтрДлина(Возвр)-1);
    КонецЦикла;
    
    Если врег(ПоследнееСлово) ="Один" Тогда
    ПоследнееСлово=Лев(ПоследнееСлово,1)+"Дна";
    Окончание="Ая";
    Иначе Если (Врег(ПоследнееСлово)="Два") Тогда
    ПоследнееСлово = Лев(ПоследнееСлово,1)+"Ве"; КонецЕсли;
    ОКончание = "ых"; КонецЕсли;
    Если ДП=0 тогда Возвр = Возвр + ПоследнееСлово+ "Цел"+ Окончание + " "+Нрег(СокрЛП(Формат(Дробчасть, "Чп")));
    ПоследнееСлово = "";
    Окончание="";
    Пока Возвр = СокрП(Возвр) Цикл
    ПоследнееСлово = Прав(Возвр, 1)+ПоследнееСлово;
    Возвр =Лев(Возвр, СтрДлина(Возвр)-1);
    КонецЦикла;
    Если Врег(ПоследнееСлово) = "Один" Тогда ПоследнееСлово = Лев(ПоследнееСлово, 1)+"Ве";
    КонецЕсли;
    Окончание = "ых";
    КонецЕсли;
    Возвр=Возвр+ПоследнееСлово+" "+ Дробная + Окончание;
    Иначе Возвр = Возвр + ПоследнееСлово + "цел" + Окончание + " " + СокрЛП(Формат(ДробЧасть,"Ч 18.0"));
    ПоследнееСлово = Прав (Возвр,1);
    ОКончание ="";
    Если ПоследнееСлово = "1" Тогда Окончание ="ая";
    Иначе Окончание = "ых"; КонецЕсли;
    Возвр = Возвр + " " + Дробная + Окончание;
    КонецЕсли;
    КонецФункции
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Зачем мудрить?
    Код:
    Сообщить(Формат(ВашеЧисло,"ЧП"));
  3. TopicStarter Overlay
    kyru6ka
    Offline

    kyru6ka

    Регистрация:
    3 окт 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Дело в том, что в ТОРГ 12 нужно массу нетто прописью вывести.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ну так и какие проблемы?
    [
    Код:
    Вес=55666.88; //считаем что это кг
    ВесПРописью="";
    тонны=Цел(Вес/1000);
    кило=Цел(Вес)-Тонны*1000;
    граммы=Вес-тонны*1000-кило;
    
    Ну и объединяйте.
  5. TopicStarter Overlay
    kyru6ka
    Offline

    kyru6ka

    Регистрация:
    3 окт 2012
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    а как же окончания?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    вы имеете ввиду "тонны" или "тонн". Подумаете сами - также всего 2 условия. А не то что в примере наворочено

Поделиться этой страницей