8.х Не знаю в чем ошибка

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Pogroleg, 28 фев 2009.

  1. TopicStarter Overlay
    Pogroleg
    Offline

    Pogroleg

    Регистрация:
    20 окт 2008
    Сообщения:
    44
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура РеестАктов(ДатаНачала, ДатаКонец)  экспорт
    ДокРеалТовИУслуг = Документы.РеализацияТоваровУслуг;
    ДокРеалТовИУслуг = ДокРеалТовИУслуг.Выбрать(НачалоМесяца(ДатаНачала), КонецМесяца(ДатаКонец));
    Пока ДокРеалТовИУслуг.Следующий() Цикл
    ТекДок = ДокРеалТовИУслуг.ПолучитьОбъект();
    Наименование = ТекДок.Контрагент;   
    Таблица = ТекДок.Услуги;		      
    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("Ссылка",      ТекДок);
    Запрос.Текст ="
    |Выбрать
    |   ТабличнаяЧасть.Номенклатура.НаименованиеПолное    КАК НаимМатериала,
    |   ТабличнаяЧасть.Цена                               КАК Цена,
    |   ТабличнаяЧасть.КоличествоПостов                   КАК КолПостов,
    |   ТабличнаяЧасть.Количество                         КАК КолЧасов,
    |   ТабличнаяЧасть.Сумма                              КАК Сумма,
    |   ТабличнаяЧасть.НДС                                КАК НДС
    |ИЗ
    |	Документ.РеализацияТоваровУслуг.Услуги КАК ТабличнаяЧасть
    |
    |ГДЕ
    |	ТабличнаяЧасть.Ссылка = &Ссылка";
    ВыборкаОС = Запрос.Выполнить();
    Пока ВыборкаОС.Следующий() Цикл
    Сообщить(ВыборкаОС.Цена)
    КонецЦикла;
    КонецЦикла; 
    КонецПроцедуры
    

    Пишет вот такую ошибку
    {ВнешняяОбработка.ВнешняяОбработка2(25)}: Ошибка при вызове метода контекста (Выполнить): {(13, 24)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
    неограниченной длины и поля несовместимых типов.
    ТабличнаяЧасть.Ссылка <<?>>= &Ссылка
    ВыборкаОС = Запрос.Выполнить();
    по причине:
    {(13, 24)}: Неверные параметры в операции сравнения. Нельзя сравнивать поля
    неограниченной длины и поля несовместимых типов.
    ТабличнаяЧасть.Ссылка <<?>>= &Ссылка

    Помогите разобратся
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Потому, что ТекДок у тебя - Объект, а сравниваешь ты его с ссылкой.

    Попробуй заменить
    Код:
     ТекДок = ДокРеалТовИУслуг.ПолучитьОбъект();
    
    на
    Код:
     ТекДок = ДокРеалТовИУслуг.Ссылка;
    
  3. TopicStarter Overlay
    Pogroleg
    Offline

    Pogroleg

    Регистрация:
    20 окт 2008
    Сообщения:
    44
    Симпатии:
    0
    Баллы:
    1
    Точно) Спасибо за помощь
Похожие темы
  1. J-F
    Ответов:
    4
    Просмотров:
    581
Загрузка...

Поделиться этой страницей