7.7 Не выходит

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Archivar, 18 янв 2014.

  1. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    В спр номенклатура - цена приходная не правильная(((


    да, вот http://files.mail.ru...AB2740CA66FC293
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    откуда ей быть правильной, когда вы ее не получаете?
    Надо так
    Код:
     ТЗ.ВыбратьСтроки();
    Пока ТЗ.ПолучитьСтроку()=1 Цикл 
    ЦенаК=ТЗ.Товар.Цена.Получить(РабочаяДата());
    КонтрагентК=ТЗ.Товар.ОтКого.Получить(РабочаяДата());
    Т.ВывестиСекцию("Строка");
    КонецЦикла;
    
    Когда вы начнете голову включать?????????
  3. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Вы о чем? я написал же про В спр номенклатура - справочник. Где реквизиты ОтКого, ПоЦене.Так реквизит ПоЦене заполнился не верно. Он пестрит цефрами от 100 до 900.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    а разве в документе поступление не та цена стоит?
  5. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    нет, это не связанные друг с другом цифры.
  6. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Мб вот в чем???

    Код:
    Спр.ПоЦене.Установить(ДатаДок,Контр);
    а должно мб так:
    Код:
    Спр.ПоЦене.Установить(ДатаДок,Цена);
  7. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    все теперь показывает цену поступления
  8. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    отчет выводится....а дату можно вывести? прихода
    или надо было ее в модуле док поступления описать?
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    можно... смотри объект периодический...
  10. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПолД.ДатаЗнач= // ???
    ПерВал.Записать();
    Так?
    Я не знаю откуда эта дата должна забираться(
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    почти! И дату правильно поняли как получить... Именно через ДатаЗнач.
    Осталось совсем чуть-чуть... Организовать ВЫБОРКУ значений... Для этого используем ВыбратьЗначения, ОбратныйПорядок, ПолучитьЗначение() объекта Периодический.
  12. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26

    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПерВал.ОбратныйПорядок(1);
    ПерВал.ВыбратьЗначения();
    Пока ПерВал.ПолучитьЗначение() = 1 Цикл
    ДатаПолуч=ПолД.ДатаЗнач;
    ПерВал.Записать();
    КонецЦикла
    
    Так?
  13. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Ой сорь





    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПолД.ОбратныйПорядок(1);
    ПолД.ВыбратьЗначения();
    Пока ПолД.ПолучитьЗначение() = 1 Цикл
    ДатаПолуч=ПолД.ДатаЗнач;
    ПолД.Записать();
    КонецЦикла
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    не совсем так....
    Вам же нужно получить ОДНО ПОСЛЕДНЕЕ значение... + зачем там запись???

    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПерВал.ОбратныйПорядок(1);
    ПерВал.ВыбратьЗначения();
    Если ПерВал.ПолучитьЗначение() = 1 Тогда
    ДатаПолуч=ПолД.ДатаЗнач;
    КонецЕсли;
    
  15. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26

    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПолД.ОбратныйПорядок(1);
    ПолД.ВыбратьЗначения();
    Пока ПолД.ПолучитьЗначение()=1 Цикл
    ДатаПолуч=ПолД.ДатаЗнач.Получить(РабочаяДата());
    КонецЦикла
    Мб так? я искал искал про последнее значение...не нашел....
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    нет... именно так как я сказал http://www.1c-pro.ru/topic55379.html/page__view__findpost__p__311192
    в цикле вы переберете ВСЕ значения. А применяя метод ОбратныйПорядок и 1 раз ПолучитьЗначение вы получите ПОСЛЕДНЕЕ значение.
  17. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    Так, я написал изначально
    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПолД.ОбратныйПорядок(1);
    ПолД.ВыбратьЗначения();
    Пока ПолД.ПолучитьЗначение()=1 Цикл
    ДатаПолуч=ПолД.ДатаЗнач;
    КонецЦикла
    только там еще была и запись, ничего же не изменилось? я что-то запутался....мне надо еще что-то тут делать? или это уже готовый вариант?
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы получаете В ЦИКЛЕ. Т.е. получите ВСЕ значения. А в данном случае самое раннее.
    Вам же нужно - самое ПОСЛЕДНЕЕ. Поэтому получаем значение ОДИН РАЗ.
    операнд условия от цикла отличаем?
    Правильнее даже будет так
    Код:
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПерВал.ОбратныйПорядок(1);
    ПерВал.ВыбратьЗначения();
    Если ПерВал.ПолучитьЗначение() = 1 Тогда
    ДатаПолуч=ПолД.ДатаЗнач;
    ИНАЧЕ
    ДатаПолуч=""; //значений вообще нет
    КонецЕсли;
    
  19. TopicStarter Overlay
    Archivar
    Offline

    Archivar Опытный в 1С

    Регистрация:
    14 авг 2013
    Сообщения:
    319
    Симпатии:
    0
    Баллы:
    26
    ПолД = СоздатьОбъект("Периодический");
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    ПолД.ОбратныйПорядок(1);
    ПолД.ВыбратьЗначения();
    Если ПолД.ПолучитьЗначение() = 1 Тогда
    ДатаПолуч=ПолД.ДатаЗнач;
    ИНАЧЕ
    ДатаПолуч="";
    КонецЕсли;


    выдает:

    ПолД.ИспользоватьОбъект("Наименование"<<?>>.Номенклатура);
    {C:\USERS\USER\DESKTOP\НОВАЯ ПАПКА (9)\КАТЕГОРИИ(ЧАСТЬ3)РАННЯЯ.ERT(45)}: Ожидается символ ')'

    разве там нужна скобка?
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) выложите обработку... не знаю где там у вас 45я строка
    2) Вот тут
    Код:
    ПолД.ИспользоватьОбъект("Наименование".Номенклатура);
    как минимум не точка, а запятая

Поделиться этой страницей