7.7 Не выводится диаграмма

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем veh, 16 окт 2008.

  1. TopicStarter Overlay
    veh
    Offline

    veh

    Регистрация:
    2 апр 2008
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    0
    Код:
    Процедура СформироватьДиаграмму(Диагр,ИмяС,КвоС)
    Диагр.Обновление(0);
    КвоТочек=ДатаК-ДатаН;
    Диагр.КоличествоСерий(КвоС);
    Диагр.КоличествоТочек(КвоТочек);
    Диагр.УстановитьИмяСерии(1,ИмяС);
    Н=1;
    Для Д=ДатаНачала По ДатаКонца Цикл
    Диагр.УстановитьИмяТочки(Н,Строка(Д));
    Н=Н+1;
    Стр="";
    Курс="";
    Если ТабЗнач.НайтиЗначение(Д,Стр,Курс)=0 Тогда
    Продолжить;
    КонецЕсли;
    ТабЗнач.ПолучитьСтрокуПоНомеру(Стр);
    Диагр.УстановитьЗначение(Стр,1,ТабЗнач.Курс); 
    КонецЦикла;
    КонецПроцедуры
    
    В свойствах диаграммы в поле текст:
    Код:
    СформироватьДиаграмму (График.ТекущийОбъект, ИмяСерии,КвоСерий)
    
    А что получилось в результате не вижу :unsure: . В чем может быть проблема? Подскажите...
  2. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Может быть потому, что в процедуре КвоС, а поле КвоСерий?
  3. TopicStarter Overlay
    veh
    Offline

    veh

    Регистрация:
    2 апр 2008
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    0
    А как это может влиять?
Похожие темы
  1. Yoda
    Ответов:
    1
    Просмотров:
    1.306
  2. Gfdtk
    Ответов:
    5
    Просмотров:
    895
Загрузка...

Поделиться этой страницей