8.х ОБМЕН Не выводит в форму хранилище значений

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем IntegraLL, 10 сен 2009.

  1. TopicStarter Overlay
    IntegraLL
    Offline

    IntegraLL

    Регистрация:
    18 июн 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    надо открыть файл картинки, записать его в константу ЛоготипФирмы (ХранилищеЗначений), и вывести на форму.


    Процедура Кнопка1Нажатие(Элемент)
    :unsure:
    //Тут мы открываем файл
    Режим = РежимДиалогаВыбораФайла.Открытие;
    Фильтр = "Текст (*,*)|*.*";

    ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);

    ДиалогОткрытияФайла.ПолноеИмяФайла = "";
    ДиалогОткрытияФайла.Фильтр = Фильтр;
    ДиалогОткрытияФайла.МножественныйВыбор = Ложь;
    ДиалогОткрытияФайла.Заголовок = "Выберите картинку";

    //здесь мы константе присваиваем выбранный файл
    Если ДиалогОткрытияФайла.Выбрать() Тогда
    ВыбраннаяКартинка = Новый Картинка(ДиалогОткрытияФайла.ПолноеИмяФайла);
    Константы.ЛоготипФирмы.Установить(ВыбраннаяКартинка);
    КонецЕсли;
    //и выводим в форму
    Логотип = Константы.ЛоготипФирмы.Получить(); ===> !!!ВОТ ТУТ ОШИБКА!!!
    Если Логотип <> Неопределено Тогда
    ЭлементыФормы.ПолеКартинки1.Картинка = Логотип.Получить();
    КонецЕсли;

    КонецПроцедуры



    Ошибка:
    {ОбщаяФорма.ФормаКонстант(24)}: Ошибка при установке значения атрибута контекста (Картинка): Несоответствие типов
    ЭлементыФормы.ПолеКартинки1.Картинка = Логотип.Получить();
    по причине:
    Несоответствие типов


    Почему у меня элементу формы с картинкой не присваивается значение из хранилища?(((

    БОЛЕЕ ТОГО! Он в папке с выбранным фалом создаёт файл "хранилище значений". Размер 0 байт =р
  2. Darlock
    Offline

    Darlock

    Регистрация:
    21 янв 2008
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Проверьте тип константы. Должен быть "ХранилищеЗначения"

Поделиться этой страницей