7.7 НЕ выводит данные

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AD1986, 30 мар 2011.

  1. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Проблема вот в чем есть условие первую часть Товар.ФлПервыйИмпортер = 0 выполняет тоетсь все выводит. но когда условие стоитТовар.ФлПервыйИмпортер = 1 то оно ничего не выводит может у меня что то неправильно в коде помогите плиз
    Код:
    Если Товар.ФлПервыйИмпортер = 0 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>   
    Если Докум.ОптНадбавка>0 Тогда     
    стрОценах =Видд+"Надб. " + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    ИначеЕсли Докум.ОптНадбавка<0 Тогда     
    стрОценах =Видд+"Оптовая скидка " + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " ";
    Иначе
    стрОценах =Видд+"Оптовая надбавка " + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    Если Товар.ФлПервыйИмпортер = 1 Тогда
    стрОценах =Видд+""+СтрПервыйПроизводитель+"";
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    
  2. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    спасибо всем вопрос снят , раскинув мозгами использовал другое решение)

Поделиться этой страницей