[РЕШЕНО] Не выводит артикул и ЕдИзм

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем webmastersb, 24 май 2014.

  1. TopicStarter Overlay
    webmastersb
    Offline

    webmastersb

    Регистрация:
    2 май 2014
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Сделал ВПФ Упаковочный лист, но проблема в том, что на печать выводится номер строки, номенклатура и количество, а вот артикул и ед.изм не выводит.
    Я уже создавал тему по этой форме, но с той проблемой разобрался, а с этой ни как.


    Функция СформироватьПечатнуюФорму(МассивОбъектов, ОбъектыПечати)

    УстановитьПривилегированныйРежим(Истина);

    ТабличныйДокумент = Новый ТабличныйДокумент;




    Запрос = Новый Запрос();
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
    Запрос.Текст =
    "ВЫБРАТЬ
    | ЗаказКлиента.Ссылка,
    | ЗаказКлиента.Номер,
    | ЗаказКлиента.Дата,
    | ЗаказКлиента.Контрагент,
    | ЗаказКлиента.Организация,
    | ЗаказКлиента.АдресДоставки,
    | ЗаказКлиента.КонтактноеЛицо,
    | ЗаказКлиента.Менеджер,
    | ЗаказКлиента.Товары.(
    | НомерСтроки,
    | Номенклатура.код,
    | Номенклатура.Артикул,
    | Номенклатура,
    | Номенклатура.ЕдиницаИзмерения,
    | Количество
    | )
    |ИЗ
    | Документ.ЗаказКлиента КАК ЗаказКлиента
    |ГДЕ
    | ЗаказКлиента.Ссылка В(&МассивОбъектов)
    |
    |УПОРЯДОЧИТЬ ПО
    | Ссылка";


    ДанныеПечати = Запрос.Выполнить().Выбрать();

    ПервыйДокумент = Истина;
    НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;

    Макет = ЭтотОбъект.ПолучитьМакет("УпаковочныйЛист1");



    //Если ЗначениеЗаполнено(Выборка.ОрганизацияСокращенноеНаименование) Тогда
    // ПредставлениеОрганизации = Выборка.ОрганизацияСокращенноеНаименование;
    //Иначе
    // ПредставлениеОрганизации = Выборка.ОрганизацияНаименование;
    //КонецЕсли;





    ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_УпаковочныйЛист";

    Пока ДанныеПечати.Следующий() Цикл

    Если Не ПервыйДокумент Тогда
    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;

    //ПервыйДокумент = Ложь;
    //
    //НомерСтрокиНачало = ТабличныйДокумент.ВысотаСтроки + 1;





    НомерДокументаНаПечать = ПрефиксацияОбъектовКлиентСервер.ПолучитьНомерНаПечать(ДанныеПечати.Номер, Ложь, Ложь);
    ФамилияИмяОтчествоКонтактноеЛицо = ФизическиеЛица.ФамилияИнициалыФизЛица(ДанныеПечати.КонтактноеЛицо);
    ФамилияИмяОтчествоМенеджер = ФизическиеЛица.ФамилияИнициалыФизЛица(ДанныеПечати.Менеджер);
    //НомерДокументаНаПоставку= ПрефиксацияОбъектовКлиентСервер. ПолучитьНомерНаПечать(ДанныеПечати.НомерПоставки, Ложь, Истина);

    СведенияОбОрганизации = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(
    ДанныеПечати.Организация,
    ДанныеПечати.Дата,

    //ДанныеПечати.БанковскийСчет,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
    );

    ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(
    СведенияОбОрганизации,
    "ПолноеНаименование, ИНН, КПП, ЮридическийАдрес, Телефоны"
    );

    СведенияОбКонтрагенте = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(
    ДанныеПечати.Контрагент, ДанныеПечати.АдресДоставки);

    ПредставлениеКонтрагента = ФормированиеПечатныхФорм.ОписаниеОрганизации(
    СведенияОбКонтрагенте, "ПолноеНаименование, ИНН, КПП"
    );



    КонецЦикла;

    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");

    ОбластьМакета.Параметры.Заполнить(ДанныеПечати);

    ОбластьМакета.Параметры.НомерДокумента = НомерДокументаНаПечать;
    ОбластьМакета.Параметры.НомерПоставки = НомерДокументаНаПечать+1;

    ОбластьМакета.Параметры.Дата = Формат(ДанныеПечати.Дата,"ДФ = ""дд ММММ гггг """"г.""");



    ТабличныйДокумент.Вывести(ОбластьМакета);








    ОбластьМакета = Макет.ПолучитьОбласть("Тело");

    ОбластьМакета.Параметры.ОрганизацияПредставление = ПредставлениеОрганизации;

    ОбластьМакета.Параметры.Контрагент = ПредставлениеКонтрагента;
    ОбластьМакета.Параметры.АдресДоставки = ДанныеПечати.АдресДоставки;

    ТабличныйДокумент.Вывести(ОбластьМакета);

    // Заполнить таблицу
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокТаблицы");
    ТабличныйДокумент.Вывести(ОбластьМакета);

    ОбластьМакета = Макет.ПолучитьОбласть("НомерКолонки");
    ТабличныйДокумент.Вывести(ОбластьМакета);


    ОбластьМакета = Макет.ПолучитьОбласть("СтрокаТаблицы");
    ТабличныйДокумент.Вывести(ОбластьМакета);



    ВыборкаСтрокТовары = ДанныеПечати.Товары.Выбрать();

    //КоличествоСтрок = 0;

    // ДанныеОбъекта = Новый Структура;
    //
    // ДанныеОбъекта.Вставить("Товары", Новый Массив);
    //
    // КоличествоТоваров = 0;
    //
    // НомерСтроки = 0;

    // Товары = Выборка.Товары.Выгрузить();



    Пока ВыборкаСтрокТовары.Следующий() Цикл




    ОбластьМакета.Параметры.Заполнить(ВыборкаСтрокТовары);


    //ОбластьМакета.Параметры.Номенклатура = ДанныеПечати.Товары.Выбрать();


    //ОбластьМакета.Параметры.Номенклатура = ВыборкаСтрокТовары.Номенклатура;


    // Если ЗначениеЗаполнено(ВыборкаСтрокТовары) Тогда
    //
    // ОбластьМакета.Параметры.Номенклатура = ВыборкаСтрокТовары.Номенклатура;
    //
    // Иначе
    //
    //
    //
    //
    // ОбластьМакета.Параметры.Номенклатура = ФормированиеПечатныхФорм.ПолучитьПредставлениеНоменклатурыДляПечати(
    // ВыборкаСтрокТовары.Номенклатура,
    // ВыборкаСтрокТовары.Номенклатура.ЕдиницаИзмерения,
    // ВыборкаСтрокТовары.Номенклатура.Артикул
    // );
    //

    //
    //КонецЕсли;


    ТабличныйДокумент.Вывести(ОбластьМакета);


    КонецЦикла;


    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалТаб");
    ТабличныйДокумент.Вывести(ОбластьМакета);


    ОбластьМакета = Макет.ПолучитьОбласть("Подвал");


    ОбластьМакета.Параметры.КонтактноеЛицо = ДанныеПечати.КонтактноеЛицо;
    ОбластьМакета.Параметры.Менеджер = ДанныеПечати.Менеджер;

    ТабличныйДокумент.Вывести(ОбластьМакета);






    ТабличныйДокумент.АвтоМасштаб = Истина;

    Возврат ТабличныйДокумент;


    КонецФункции
  2. TopicStarter Overlay
    webmastersb
    Offline

    webmastersb

    Регистрация:
    2 май 2014
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    1с Предприятие 8.3 УТ11
  3. TopicStarter Overlay
    webmastersb
    Offline

    webmastersb

    Регистрация:
    2 май 2014
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Спасибо разобрался.
    Надо было добавить несколько доп строчек кода с выборкой

Поделиться этой страницей