8.х не выполняется резервное копирование ИБ

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем monzarek, 18 апр 2012.

  1. TopicStarter Overlay
    monzarek
    Offline

    monzarek

    Регистрация:
    4 мар 2012
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Добрый день! у меня проблема не выполняется автоматическое резервное копировапние. настроить настроил , но выходит ошибка. подскажите пожалуйста вчем проблема?

    Вложения:

  2. leemuar
    Offline

    leemuar Опытный в 1С

    Регистрация:
    21 окт 2010
    Сообщения:
    310
    Симпатии:
    0
    Баллы:
    26
    Видимо в том что поле объекта не обнаружено "ИмяАдминистратораБД".
    Открывайте отладчик и разбирайтесь.
  3. TopicStarter Overlay
    monzarek
    Offline

    monzarek

    Регистрация:
    4 мар 2012
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    в коде ничего не понимаю. подскажите что нужно поменять. код такой
    Код:
    Если Элементы.СтраницыПомощника.ТекущаяСтраница = Элементы.СтраницыПомощника.ПодчиненныеЭлементы.СтраницаИнформацииИВыполненияРезервногоКопирования Тогда
    Если Объект.КодТипаРезервногоКопирования = 1 Тогда
    
    СтруктураАдминистраторскихНастроек = СоединенияИБПовтИсп.ПолучитьПараметрыАдминистрированияИБ();
    АдминистраторИБ = СтруктураАдминистраторскихНастроек.ИмяАдминистратораИБ;
    ПарольАдминистратораИБ = СтруктураАдминистраторскихНастроек.ПарольАдминистратораИБ;
    ПарольАдминистратораИБПроверка = СтруктураАдминистраторскихНастроек.ПарольАдминистратораИБ;
    
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;
    ошибка
    {Обработка.РезервноеКопированиеИБ.Форма.РезервноеКопированиеИнформационнойБазы.Форма(387)}: Поле объекта не обнаружено (ИмяАдминистратораИБ)
    АдминистраторИБ = СтруктураАдминистраторскихНастроек.ИмяАдминистратораИБ;
  4. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    надо смотреть отладчиком, что попадает вот сюда
    Код:
    СтруктураАдминистраторскихНастроек = СоединенияИБПовтИсп.ПолучитьПараметрыАдминистрированияИБ();
    З.Ы. пользуйтесь тегом Код1С, чтоб нагляднее было....
  5. TopicStarter Overlay
    monzarek
    Offline

    monzarek

    Регистрация:
    4 мар 2012
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Этоглюк релиза. в новом релизе УТ 11.0.8.8 резервное копирование работает нормально. но с одним недочетом:
    при выходе из программы предлагает сохранить копию, затем она сохраняет копю базы и снова заходит в программу и так пока не убрать галочку в окне сообщение о резервном копировании. Будем надеяться 1С исправят это в следующем релизе.
  6. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Вышел новый релиз 11.0.8.11. Можете проверить в нем.

Поделиться этой страницей